× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Bureautique
 excel : formule à mettre en placeSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
mrb
  Posté le 27/01/2007 @ 18:23 
Aller en bas de la page 
Petit astucien

Bonjour,

Quelqu'un pourrait-il m'aider à mettre en place une formule.

J'ai un tableau avec dans la colonne A des références

dans la colonne B rien pour le moment

Dans la colonne C également des références et dans la colonne D des prix correspondant aux références de la colonne C.

si dans la colonne A je trouve la même référence que dans la colonne C j'aimerais qu'automatiquement le prix s'affiche dans la colonne C sur la même ligne.

Ai je été assez claire. Merci pour votre aide

Publicité
Marmotte18
 Posté le 27/01/2007 à 18:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir,

Je ne comprends pas :

si dans la colonne A je trouve la même référence que dans la colonne C j'aimerais qu'automatiquement le prix s'affiche dans la colonne C sur la même ligne.

Peut-être pourrais-tu fournir ici un petit fichier de démonstration avec les résultats attendus ?



Modifié par Marmotte18 le 27/01/2007 18:30
mrb
 Posté le 27/01/2007 à 18:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

je ne sais plus comment joindre un fichier



Modifié par mrb le 27/01/2007 18:36
mrb
 Posté le 27/01/2007 à 18:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

voici à priori le fichier : http://www.cijoint.fr/cij7968555532604.xls

Marmotte18
 Posté le 27/01/2007 à 19:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir,

La 1ère action que j'ai faite, est de trier l'ensemble de tes données, d'abord sur la colonne C puis sur la colonne A. Ensuite, j'ai mis les formules.

Exemple en B1 :

=SI(ESTERREUR(RECHERCHEV(A1;C:D;2;FAUX));"";RECHERCHEV(A1;C:D;2;FAUX))

Voilà un fichier qui devrait te donner satisfaction :

http://cjoint.com/?bBtkWHd5wV

Remarque :

J'aurai tendance à mettre ta table de tarifs (colonnes C et D) dans un autre onglet (le tri est malgré tout impératif sur les références dans cette table). Cela aurait l'intérêt de ne pas modifier l'ordre de tes données des colonnes A et B et la démarche serait plus propre.

La formule que je mets en B1 devient alors :

=SI(ESTERREUR(RECHERCHEV(A1;Tarifs!A:B;2;FAUX));"";RECHERCHEV(A1;Tarifs!A:B;2;FAUX))

Voilà un fichier qui tient compte de cette remarque :

http://cjoint.com/?bCimvAprNO



Modifié par Marmotte18 le 28/01/2007 08:16
mrb
 Posté le 28/01/2007 à 08:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Merci beaucoup pour votre aide et bon week end

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
249,99 €Ecran 27 pouces LG Ultragear 27GL63T (FullHD IPS, 144 Hz, 1ms, FreeSync/Gsync compatible) à 249,99 €
Valable jusqu'au 15 Août

Amazon fait une promotion sur l'écran LG Ultragear 27GL83A-B qui passe à 399,99 € au lieu de 445 € ailleurs. Cet écran possède une dalle 27 pouces WQHD (2560x1440) à 144 Hz, un temps de réponse de 1 ms. Il est compatible Nvidia G-SYNC et Adaptive Sync


> Voir l'offre
113,22 €SSD Crucial P1 1 To (3D NAND, NVMe, PCIe, M.2) à 113,22 € livré
Valable jusqu'au 15 Août

Amazon Italie fait une promotion sur le SSD Crucial P1 1 To (3D NAND, NVMe, PCIe, M.2) qui passe à 108,68 € (avec la TVA ajustée). Comptez 4,54 € pour la livraison en France soit un total de 113,22 € livré. On le trouve ailleurs à partir de 130 €. Ce SSD offre des vitesses de lecture/écriture séquentielle allant jusqu’à 2 000/1 750 Mo/s. Il est garanti 5 ans.


> Voir l'offre
50,99 €SSD Silicon Power A55 512 Go à 50,99 €
Valable jusqu'au 17 Août

Amazon fait une promotion sur le SSD Silicon Power A55 512 Go qui passe à 50,99 € livré gratuitement. Ce SSD à mémoire TLC possède un cache SLC et offre des taux de transfert de 550 Mo/s en lecture et 450 Mo/s en écriture. 


> Voir l'offre

Sujets relatifs
excel : formule à mettre en place
Excel-Mettre en gras une partie d'une formule
[résolu] Excel : calcul à mettre en place
Formule excel 2007
formule excel
Formule excel
Report résultat formule Excel
mettre a jour liason feuille excel 2007
Formule EXCEL
Excel 7 aide sur formule svp
Plus de sujets relatifs à excel : formule à mettre en place
 > Tous les forums > Forum Bureautique