> Tous les forums > Forum Bureautique
 EXCEL cherche quelle Formule ?Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
rudika
  Posté le 14/02/2018 @ 11:13 
Aller en bas de la page 
Petite astucienne

Bonjour les Astuciens,

je bloque à nouveau sur une formule. Formule en colonne F trop longue et non acceptée lors validation : Je voudrais dire en F1 :

si C1 contient M01 ou M02 ou M03 etc jusqu'à M15, alors écrire "Modif" et idem pour T01 jusqu'à T15, alors écrire "Transfert"; sinon ""

Peut-on envisager que M01 …. M15 et T01... T15 soient en table matrice et que cela passe par une RechercheV ?

ou autre astuce à laquelle je ne pense pas ? ci-dessous mon exemple.

https://www.cjoint.com/c/HBokisr6JNG

Merci à vous si vous vous penchez sur ma problématique.

rudika

[Configuration automatique à compléter]
Windows 7
Chrome 63.0.3239.132

Publicité
dlxpat
 Posté le 14/02/2018 à 11:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour Rudika ! Essayes ta formule mais simplifiée =SI(NB.SI(C1;"*M*");"Modif";SI(NB.SI(C1;"*T*");"Transfert";""))

rudika
 Posté le 14/02/2018 à 11:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Bonjour dlxpat,

oui,mais pas possible car je peux avoir dans les 2 premiers caractères à gauche ou 4 premiers à gauche, la lettre M ou T (ex. AT 12345 17 C0005 ou ATMI 12345 17 C0005)

merci

dlxpat
 Posté le 14/02/2018 à 11:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

OK mais ça tu l'avais pas dit !! J'essaye de regarder !

dlxpat
 Posté le 14/02/2018 à 12:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Nouvel essai !

SI(NB.SI(C1;"*M0*");"Modif";SI(NB.SI(C1;"*T0*");"Transfert";SI(NB.SI(C1;"*m1*");"Modif";SI(NB.SI(C1;"*t1*");"Transfert";""))))
rudika
 Posté le 14/02/2018 à 13:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

oui, mais c'est ce que je fais depuis le départ, sauf que lorsque tu veux dire jusqu'à M15 ou T15, c'est hyper long comme formule et bien évidemment, cela ne fonctionne pas. La question est : Comment faire une formule courte ?? RECHEH V ?? index ??

dlxpat
 Posté le 14/02/2018 à 14:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Mais ma formule n'est pas si longue (et en plus il suffit de la copier !!). Tu as bien (dans ma formule) tout ce qui commence par M0, M1, T0 et T1. Ou alors je n'ai pas compris ton besoin!

https://www.cjoint.com/c/HBonXYLSUoJ

rudika
 Posté le 14/02/2018 à 18:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Mais oui, bien-sûr, comment ai-je pu ne pas comprendre ??

j'avais la tête dans plusieurs dossiers et donc pas compris que "*1*" comprenait de 1 à 19.

Vraiment désolée pour cette étourderie.

Merci et belle soirée "St-Valentin"

rudika

dlxpat
 Posté le 14/02/2018 à 18:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci à toi aussi (mais je suis célibataire, mais très heureux quand même): Penses à mettre en résolu !

Publicité
mdo100
 Posté le 15/02/2018 à 12:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour rudika, dlxpat,

On peut réduire la formule de dlxpat ainsi:

=SI(OU(NB.SI(C1;"*M0*");NB.SI(C1;"*m1*"));"Modif";SI(OU(NB.SI(C1;"*T0*");NB.SI(C1;"*t1*"));"Transfert";""))

Cordialement.

dlxpat
 Posté le 15/02/2018 à 13:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour ldo100. Tu as parfaitement raison, mais pour être très honnête, je manie très mal les foncions ET OU !!!

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Aucun sujet pertinent lié trouvé
 > Tous les forums > Forum Bureautique