> Tous les forums > Forum Bureautique
 [EXCEL] Filtrer par noms .. URGENT !!Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Katach
  Posté le 22/06/2015 @ 12:43 
Aller en bas de la page 
Nouvel astucien

Bonjour a tous .

Surfant pas mal pour m'aider sur ce site , je suis bloqué a mon tour ..

#####

Sur ce tableau vous pouvez voire la colonne A,B ce sont les clients ou j'ai besoin d'extraire leur numéros .

Les colonnes E,F,G , sont la Base clients . + telephone .

J'aurais besoin de faire coincider les deux listes pour que les numéro de la colonne G ce complete dans la colonne C ..

Sans forcément me taper les 10000 clients ..

J'ai besoin de 200 numéro dans la liste qui contient 11345 numéros ....

Merci de votre aide



Modifié par Katach le 22/06/2015 15:15
Publicité
Courtjus
 Posté le 22/06/2015 à 13:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

je suis pas expert - je suis sous excel 2003 - et je sais pas vraiment si c'est ça que tu veux ?

donc si j'ai bien compris tu veux copier la liste de la colonne G dans C :

j'ai fais :

clic dans la cellule C1

tape sur le symbole =

clic dans la cellule G1 et tape sur la touche entrée

la logiquement ça copie la cellule ( G1 )

dans la cellule C1 en bas à droite tu as un point noir ( sur le quadrillage )

tu clic dessus en maintenant le clic et tu descend jusque disons 12000 lignes ( vu le nombre de tél à copier ) 2 minutes environs le temps d'arriver en bas

au delà des indications ( 11345 ) ça te met des 0 mais si par la suite tu ajoutes quoi que ce soit ds G ça le copie

j’espère avoir détaillé assez clairement !!!!

A+

Courtjus
 Posté le 22/06/2015 à 13:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

re

si par cas c'est résolu ton blême supprime le message car tu risques d'avoir des margoulins qui récupèrent les noms et téléphones de ta liste

Katach
 Posté le 22/06/2015 à 15:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Trouvé merci :

( =RECHERCHEV(A2;E:G;A178:C2003;FAUX) )

je supprime

ferrand
 Posté le 22/06/2015 à 15:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

S'il n'y a pas de doublons dans la base clients, une formule de recherche pourrait convenir, mais il faut savoir si le nom suffit ou s'il faut rechercher sur nom et prénom simultanément.

En nommant ta base Base par commodité :

Sur Nom seulement, en C1 : =RECHERCHEV(A1;Base;3;FAUX)

devrait convenir (à tirer ensuite sur la colonne C).

S'il faut rechercher sur les noms et prénoms simultanément, il faut opérer autrement. La formule compose une matrice de 0 et 1, résultat du produit de la colonne E (1 si = A1) par la colonne F (1 si = B1). Cette matrice ne comprendra normalement que des 0 et un seul 1 correspondant à la valeur cherchée, dont cherche le rang avec EQUIV, ce qui permet de récupérer la valeur Numéro en G avec INDEX.

Cela donne en C1 (à noter que le nom Base correspondant à 3 colonnes, on le réduit à la colonne voulue avec DECALER) :

=INDEX(DECALER(Base;;2;;1);EQUIV(1;(DECALER(Base;;;;1)=A1)*(DECALER(Base;;1;;1)=B1);0))

Cette formule (matricielle) est à valider par Ctrl+Maj+Entrée, et est à tirer ensuite comme précédemment.

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Excel : filtrer une liste de contact
excel urgent !!!
Excel : regrouper les même noms en 1 seule ligne
excel 2007 Trier et Filtrer grisé
EXCEL 2007 Filtrer les données
URGENT!! macro excel
probelme avec excel Urgent help me
Excel : taille de la police des noms de feuille
Urgent feuille Excel vers Word avec mise en page
Comment générer une liste de noms aléatoire Excel
Plus de sujets relatifs à [EXCEL] Filtrer par noms .. URGENT !!
 > Tous les forums > Forum Bureautique