> Tous les forums > Forum Bureautique
 excel (somme si)Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
padymen
  Posté le 28/05/2014 @ 14:22 
Aller en bas de la page 
Astucien

Bonjour,

Pour essayer de faire simple : un tableau composé de X colonnes (soit par exemple une colonne 1, une colonne 2 et une colonne 3) comment faire la somme de la colonne 3 uniquement si il y a quelque chose dans la ligne correspondante dans par exemple la colonne 1 ?

Publicité
ZenJP
 Posté le 28/05/2014 à 14:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

J'avoue que je comprends pas trop la demande ! Si il n'y a rien dans la ligne correspondante, ta somme sera égale à 0 donc bonne donc pas besoin de condition ?

padymen
 Posté le 28/05/2014 à 14:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour ZenJP,

je m'exprime peut être mal, si dans la colonne 1 à la ligne 1 il y a par exemple "orange" et qu'il y a 20 dans la colonnes 3 alors il faut prendre en compte le calcul.

je pense avoir trouvé avec la formule suivante : =SOMME.SI(A1:A2000;"*";K1:K2000)

ferrand
 Posté le 28/05/2014 à 14:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

=SOMME.SI(A1:A2000;"<>"&"";K1:K2000)

ou bien :

{=SOMME(SI(A1:A2000<>"";K1:K2000))}
à valider par Ctrl+Maj+Entrée

padymen
 Posté le 28/05/2014 à 15:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour Ferrand,

les trois formules semblent valables, les deux que tu donnes et celles que je teste (celle donnée un peu plus haut), je considère donc que le sujet est résolu.

merci pour votre attention et votre aide.

ferrand
 Posté le 28/05/2014 à 15:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Re,

Le critère "*" (caractère joker) ignore les valeurs numériques et les cellules vides, mais prend en compte toute valeur texte y compris les chaînes vides.

Tout dépend donc du contenu de ta colonne...

padymen
 Posté le 28/05/2014 à 15:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

re,

c'est pour faire une feuille de compte familiale, il y aura en fait deux colonnes à prendre en compte : dans une colonne le libellé soit du texte et l'autre colonne ce sera le chiffre "2" qui signifie que le montant est pointé, j'en arrive à la formule finale qui semble fonctionner:

=SOMME.SI.ENS(L10:L2001;B10:B2001;"*";M10:M2001;"2")

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
listing et somme valeurs unique dans colonne excel
somme excel 2007 ne fonctionne pas
Avec Excel = Somme jour+Heures+minutes
Excel : Faire une somme si condition.
Excel 2007 formule somme dont 2 chiffres ds cellul
Excel : somme si ?
Excel fonctions sommeprod ou somme.si ?
somme sur excel marche pas toujours
Somme de résultat de recherche sous Excel?[RESOLU]
Somme comprise entre (sous Excel)
Plus de sujets relatifs à excel (somme si)
 > Tous les forums > Forum Bureautique