> Tous les forums > Forum Bureautique
 Faire disparaître #N/A (et) 0Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Gorfous
  Posté le 19/06/2017 @ 15:17 
Aller en bas de la page 
Petit astucien

Bonjour,
Je sollicite votre aide pour le problème suivant et vous en remercie par avance :
Ce code permet d'effacer le contenu des cellules sans effacer les formules.
Range("A9:B9,A12:C12,A15:D15,A19:B19").SpecialCells(xlCellTypeConstants, 3).ClearContents 'C'est OK
Dont la formule (exemple) est :
=RECHERCHEV($A$9;Base!A:M;3;0) qui renvoi #N/A
Je modifie cette formule :
=SI(ESTNA(RECHERCHEV($A$9;Base!A:M;2));0;RECHERCHEV($A$9;Base!A:M;2)) 'Ça me met "0" dans la cellule
Et le code ne marche plus.
Pour faire disparaître ce "0" je fais une Mfc, c'est OK le "0" ne se voit plus. 'Mais le code ne marche pas non plus.

ps : Je précise que #N/A apparaît lorsque je supprime la donnée en A9

Publicité
Labougie
 Posté le 19/06/2017 à 18:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Groupe Sécurité

,

Et si tu donnais un classeur. Cela serait bien plus simple pour tous.

Car pour nous A9, quésaco?

Labougie

Gorfous
 Posté le 19/06/2017 à 20:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour Labougie,

Je te remercie de me répondre, mais j'ai trouvé la formule à mettre qui est :

=SI(A9=0;"";RECHERCHEV($A$9;Base!A:M;3;0))

Au plaisir et bonne soirée

gilbert_rgi
 Posté le 20/06/2017 à 09:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Gorfous a écrit :

Bonjour Labougie,

Je te remercie de me répondre, mais j'ai trouvé la formule à mettre qui est :

=SI(A9=0;"";RECHERCHEV($A$9;Base!A:M;3;0))

Au plaisir et bonne soirée

Tu peux aussi mettre un test d'erreur du genre

ESTERREUR La valeur fait référence à une des valeurs d’erreur (#N/A, #VALEUR!, #REF!, #DIV/0!, #NOMBRE!, #NOM? ou #NUL!).

ou

ESTNA La valeur fait référence à la valeur d’erreur #N/A (valeur non disponible).

Salutations

Gilbert

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !

Sujets relatifs
Faire disparaître des éléments dans Word.
Faire disparaître un bouton ?
Faire disparaitre automatiquement le ,0 ds formule
Word : Faire disparaitre les docu recents
faire disparaître les lignes Excel
Faire une boucle VBA Excel
Faire un montage
comment faire
comment faire passer d'une page à l'autre d'après conditions
Faire un saut de colonne sur la page précédente
Plus de sujets relatifs à Faire disparaître #N/A (et) 0
 > Tous les forums > Forum Bureautique