> Tous les forums > Forum Bureautique
 faire qu'une cellule vide soit égal à une valeur de 0Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
williamsss
  Posté le 31/08/2015 @ 20:39 
Aller en bas de la page 
Petit astucien

Bonjour,

Dans un tableau dans une cellule comme B65, après une formule comme celle-ci =SI($AL25<0;$AL25;"") voilà que des cellules sont sans valeurs suite au "". Donc dans une autre cellule B114 où cela addition certaines cellules avec la formule précédente voilà que cela ne fonctionne pas comme certaines cellules du tableau sont sans valeur et donc cela mets comme résultat #VALEUR!.

Donc comment peut ont faire pour que dans la formule des cellules comme dans celle de B65 lorsque le résultat doit être "" , donc une cellule vide, que celle-ci soit de valeur nulle pour pas bloquer les calculs ??

Pour la clareté de mon tableau je ne souhaite pas remplir ces cellules de 0.

Merci

Williams

Publicité
Topodoco
 Posté le 31/08/2015 à 21:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir,

Quelle est ta version d'EXCEL ?

Es-tu sur de ta formule ?

Je viens de tester sur EXCEL 2013 et je n'ai pas de problème, par contre la formule ne laisse apparaitre que les valeurs négatives.

J'ai testé dans la colonne A des valeurs, le résultat dans la colonne B et la somme en C.

Dans mon exemple, j'ai:

<A> - <B> - <C>

<-1> <-1> <-6>

< 5> < >

< 0> < >

< 3> < >

<-5> <-5>

Sinon petite idée pas pour résoudre ce problème, mais le contourner, n'est-il pas possible dans ta version de remplacer tes "" par 0, et d'ajouter une mise en forme conditionelle qui masque ces 0 ?

ferrand
 Posté le 01/09/2015 à 02:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut !

Fonction N (qui renvoie 0 pour toute chaîne).

Ou utiliser SOMME au lieu de l'opérateur +.

williamsss
 Posté le 01/09/2015 à 11:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Topodoco a écrit :

Bonsoir,

Quelle est ta version d'EXCEL ?

Es-tu sur de ta formule ?

Je viens de tester sur EXCEL 2013 et je n'ai pas de problème, par contre la formule ne laisse apparaitre que les valeurs négatives.

J'ai testé dans la colonne A des valeurs, le résultat dans la colonne B et la somme en C.

Dans mon exemple, j'ai:

<A> - <B> - <C>

<-1> <-1> <-6>

< 5> < >

< 0> < >

< 3> < >

<-5> <-5>

Sinon petite idée pas pour résoudre ce problème, mais le contourner, n'est-il pas possible dans ta version de remplacer tes "" par 0, et d'ajouter une mise en forme conditionelle qui masque ces 0 ?

J'ai Excel 2003.

Si on a un tableau comme celui-ci où les "" sont les cellules sans valeurs suite à la formule :

........<A> <B> <C>

<1> <1> <5> <"">

<2> <""> <3> <2>

<3> <9> <""><1>

Alors toutes formules mathématiques (+ et ou - et ou : et ou x) ne fonctionne pas suite aux cellules <""> qui ne sont pas considérée comme des cellules avec la valeur 0.

Après il est possible de faire comme vous dites mais ceci alourdie si je ne me trompe pas. Donc c'était au cas qu'il y avait quelque chose de possible à faire.

ferrand a écrit :

Salut !

Fonction N (qui renvoie 0 pour toute chaîne).

Ou utiliser SOMME au lieu de l'opérateur +.

Avec cette méthode cela fonctionne comme c'est qu'à additionner que je dois faire, mais cela aurait été à soustraire comment fait-on ??

Merci

Williams

ferrand
 Posté le 01/09/2015 à 11:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Pareil !

-N(...)

-SOMME(...)

williamsss
 Posté le 01/09/2015 à 12:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
ferrand a écrit :

Pareil !

-N(...)

-SOMME(...)

Ok merci Ferrand,

je ne connaissais pas la formule N(...) qui semble utile pour ceci.

Williams

Topodoco
 Posté le 01/09/2015 à 17:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
ferrand a écrit :

Salut !

Fonction N (qui renvoie 0 pour toute chaîne).

Ou utiliser SOMME au lieu de l'opérateur +.

Je viens de m'apercevoir que c'est exactement ce que j'ai fait....

En fait ce n'est pas EXCEL 2013 qui fonctionne mieux, mais j'ai utilisé le raccourci "Somme automatique" pour faire le total.

Ce raccourci m'a simplement écrit =SOMME(B1:B5)

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
copier ligne si cellule vide
Effacer cellule par rapport a la valeur d'une autre
Rendre une cellule vide
modification automatique valeur cellule
valeur par défaut d'une cellule
Excel: Faire apparaître dans cellule nom sélection
Excel: valeur cellule impliquée dans calcul ailleurs -> connexions
interdire une valeur dans une cellule en fonction d'une autre cellu
sélectionner la première cellule vide d'une colonne
Supprimer le 0 pour rendre la cellule vide
Plus de sujets relatifs à faire qu''une cellule vide soit égal à une valeur de 0
 > Tous les forums > Forum Bureautique