> Tous les forums > Forum Bureautique
 faire somme selon une chaine contenu dans une colonne
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Elieg
  Posté le 17/02/2016 @ 16:25 
Aller en bas de la page 
Petit astucien

Bonjour,

mieux qu'un long discours, je vous remercie de voir le fichier excel joint, la colonne C peux contenir soit un nom soit une chaine de caractere la colonne A des nombres ou rien.

Ma problematique est de pouvoir additionner tous les nombres de la colonne A si dans la colonne C on retrouve une certaine chaine de caracteres (dans mon exemple philippe) cette formule ne doit pas respecter le casse.

merci pour votre aide si precieuse

ci dessous lien de mon fichier test

http://www.cjoint.com/c/FBrpsU8fyPc

Publicité
pcastuces
 Posté le 17/02/2016 à 19:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Equipe PC Astuces
Bonjour,

Le sujet a été déplacé par la modération dans le forum Bureautique qui semble plus adéquat.

Vous pouvez continuer la discussion à la suite de ce message.

A bientôt.
Elieg
 Posté le 17/02/2016 à 22:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour

Merci pour ton aide, ta formule est impec, mais il y a juste une petite erreur a corriger, si j ai 2 nom qui se ressemble mais ne sont pas la meme personne comme leon et leonide et que je cherche leon, il me prendra les 2 en compte or ce n est pas bon

Saurais tu gerer cela? perso moi je ne sais pas et pour les noms composes, je ne pense pas qu il y ai de solution si on a louis et jean louis ou jean-louis

Qu'en pense tu?

en tout cas chapeau, j avais cherche et pas trouve alors que la formule est super simple, je cherchais des trucs beaucoup plus compliques

encore un grand merci O GRAND SACHEM ASTUCIEN

jpr73
 Posté le 18/02/2016 à 00:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Une autre solution :

=SOMME.SI.ENS(A1:A11;C1:C11;C1)

C1 pour philippe ou une autre référence de cellule pour extraire la somme correspondante à la chaine de caractère

Test OK avec noms composés et noms qui se ressemble

Cordialement

Elieg
 Posté le 22/02/2016 à 23:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci jpr

ta formule est ok si je laisse c1 mais si a la place je met "philippe", ca ne marche pas sais tu pourquoi?

merci pour votre aide

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
listing et somme valeurs unique dans colonne excel
Impression du contenu de colonne dans tableur
somme de lettre dans une colonne
faire apparaitre l'icone Word dans le menu demarrez
faire un tri sur une colonne
Figer colonne ou ligne dans excell
chercher chaîne de caractères VBA dans plusieurs fichiers XL
Protéger introduction données dans une colonne
Adresses Mail dans colonne restent noires
Excel : Faire une somme si condition.
Plus de sujets relatifs à faire somme selon une chaine contenu dans une colonne
 > Tous les forums > Forum Bureautique