× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Windows 10
 Faire une additionSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
saxe
  Posté le 24/01/2020 @ 15:42 
Aller en bas de la page 
Nouvel astucien

Bonjour à vous tous

Voici mon problème :

AA AB AC AD AE AF AG …. AK AL AM AN AO AP AQ 3 2 1 2 2 1 3 … 13 22 31 42 52 61 73 Dans la cellule AA le 3 est donné par la formule suivante: =SI(AK10=11;1;"")&SI(AK10=13;3;"")&SI(AK10=12;2;"") de même pour AB le 2 provient de la formule :=SI(AL10=21;1;"")&SI(AL10=23;3;"")&SI(AL10=22;2;""). mon problème je n'arrive pas à additionner de AA à AG le résultat me donne 0 au lieu de 14. Je vous remercie par avance de bien vouloir m'éclairer sur ce problème. Bonne fin de semaine et bon week end.





[Configuration automatique à compléter]
Windows 8.1
Firefox 72.0

Publicité
poussebois
 Posté le 24/01/2020 à 16:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour et bienvenue sur PC Astuces ,

En apparence, il y a de quoi s'arracher les cheveux !

En effet : =SOMME(AA1:AG1) donne 0 alors que =(AA1+AB1+AC1+AD1+AE1+AF1+AG1) donne 14 !

Je vois 2 solutions à ton problème. Celui-ci vient du fait que les contenus de AA1:AG1 sont le résultat de formules et ces résultats sont en format texte, même si tu vois un nombre.

D'où première solution en convertissant le nombre format texte en nombre format nombre. Pour cela, une astuce : multiplier ta formule par 1. Ainsi : =SI(AK10=11;1;"")&SI(AK10=13;3;"")&SI(AK10=12;2;"") devient =(SI(AK10=11;1;"")&SI(AK10=13;3;"")&SI(AK10=12;2;""))*1 et là, la SOMME marche !

Deuxième solution plus élégante : en AA1, tu écris la formule =MOD(AK10;10) et tu tires la formule jusqu'en AG1. Et là pas de problème pour faire la somme !

@ +

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
97,99 €Pack Gaming Corsair (casque HS50 + clavier K55 RGB + souris Harpoon RGB Pro + tapis MM100) à 97,99 €
Valable jusqu'au 27 Septembre

RueDuCommerce fait une belle promotion sur l'Essential Gaming Bundle de Corsair qui passe à 97,99 € alors qu'on le trouve ailleurs à partir de 130 €. Ce pack comporte un casque filaire HS50, un clavier K55 RGB, une souris Harpoon RGB Pro et un tapis de souris MM100. Tout pour équiper un PC de joueur.


> Voir l'offre
87,02 €Set de 10 clés mixtes à cliquet Bosch Professional (8 à 19 mm) à 87,02 € livré
Valable jusqu'au 28 Septembre

Amazon Allemagne fait une promotion sur le set de 10 clés mixtes à cliquet Bosch Professional (8 à 19 mm) à 80,06 € (avec la TVA ajustée). Comptez 6,96 € pour la livraison en France (gratuite en Belgique) soit un total de 87,02 € livré. On trouve le lot ailleurs autour de 115 €. Utilisez votre compte Amazon FR sur Amazon DE. Pas de douane.


> Voir l'offre
34,90 €Routeur TP-Link Archer C6 Gigabit et Wifi double bande AC à 34,90 €
Valable jusqu'au 27 Septembre

Amazon fait une vente flash sur le routeur TP-Link Archer C6 qui passe à 34,90 € livré gratuitement. On le trouve ailleurs à partir de 50 €.  Ce routeur dispose de 5 ports Ethernet Gigabit, du WiFi 802.11 AC sur 2 bandes (délivre des débits combinés allant jusqu’à 1.2Gbps). Vous pouvez le convertir en point d'accès pour partager votre réseau filaire avec d'autres appareils WiFi.


> Voir l'offre

Sujets relatifs
Aucun sujet pertinent lié trouvé
 > Tous les forums > Forum Windows 10