> Tous les forums > Forum Bureautique
 feuille de nite sous excelSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
mondeheureux
  Posté le 02/08/2009 @ 00:17 
Aller en bas de la page 
Petit astucien

salut

sous excel, j'ai réalisé une feuillede notes.les moyennes sont calculés automatiquement.le problème auquel je me suis heurté, c'est que je n'arrive pas à faire prendre en charge par excel les devoirs manqués mais justifiés.

je m'explique:supposons qu'on ait fait trois devoirs.Excel calcule la somme et divise par 3.si un élève a manqué le premier devoir à cause d'une maladie,son absence est justifiée par un certificat de maladie, alors dans la case correspondante je mets AJ(cad absence justifiée) dans ce cas là, je veux qu'excel prenne en charge cette indication et divise uniquement par 2.Au cas où l'absence ne serait pas justifiée,je mettrai dans la case correspondante ANJ(absence non justifiée) et dans ce cas excel devrait diviser par trois.

y a-t-il une formule que je peux utiliser?

merci

Publicité
ferrand
 Posté le 02/08/2009 à 00:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

Supposons que tu fais dans la cellule J6 la moyenne des notes portées dans les colonnes C à H sur la ligne 6. Si un devoir n'est pas fait il y aura indiqué AJ ou ANJ.

Si tu ne t'intéresses à la moyenne qu'une fois toutes les colonnes servies, tu peux utiliser en J6 la formule suivante :

=SOMME(C6:H6)/NB.SI(C6:H6;"<>AJ")

Le total des notes sera divisé par le nombre de cellules ne contenant pas "AJ". Mais si tu t'intéresses à la moyenne avant que tous les devoirs soient faits ou que leur nombre total peut varier, utilise plutôt :

=SOMME(C6:H6)/(NB(C6:H6)+NB.SI(C6:H6;"ANJ"))

Le total des notes sera alors divisé par le nombre de cellules contenant une valeur numérique (y compris 0) ou l'indication "ANJ". Les cellules vides ne seront pas prises en comptes.

Bonne continuation.

mondeheureux
 Posté le 02/08/2009 à 02:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

salut Ferrand

j'ai essayé les deux formules, avec les deux cas. c'est formidable! je vous remercie.

j'aimerais préciser qu'au fure et à mesure que je porte les notes, la moyenne se calcule.

merci

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
80,45 €Alimentation semi modulaire Corsair CX750M (750W, 80Plus Bronze) à 80,45 €
Valable jusqu'au 24 Janvier

RueDuCommerce fait une promotion sur l'alimentation semi modulaire Corsair CX750M 750W 80Plus Bronze qui passe à 80,45 €. On la trouve ailleurs à partir de 110 €. Cette alimentation est silencieuse et est certifiée 80PLUS bronze qui offre des rendements de plus de 82% en charge. Elle est garantie 3 ans.


> Voir l'offre
1199,99 €Acer Nitro 5 (15,6'' FHD, i7 11800H,16Go, SSD 512 Go, RTX 3070, Windows 10) à 1199,99 €
Valable jusqu'au 22 Janvier

Fnac fait une belle promotion sur l'ordinateur portable Acer Aspire Nitro AN515-57-7218 qui passe à 1199,99 € au lieu de 1800 €. Ce portable dédié aux joueurs dispose d'un écran 15,6 pouces FHD 1920 x 1080 144 Hz, d'un processeur Intel Core i7-11800H, de 16 Go de mémoire RAM, d'un SSD de 512 Go et d'une carte graphique Nvidia GeForce RTX 3070 Max Q  8 Go. Le tout tourne sous Windows 10.

De quoi faire tourner tous vos jeux en haute définition.


> Voir l'offre
999,99 €PC Portable 16.1' HP Victus (FHD, Core i5 11400H, 16Go/512Go,RTX 3600 6Go) à 999,99 €
Valable jusqu'au 25 Janvier

Cdiscount fait une réduction sur le PC Portable 16.1' HP Victus 16-d0206nf qui passe à 999,99 € au lieu de 1200 €.

Il comporte un écran IPS Full HD de 16.1 pouces, un processeur Intel Core i5 11400H, 16 Go de RAM, un SSD NVMe de 512 Go, une carte graphique dédiée GeForce RTX 3600 6 Go, un clavier rétro éclairé, une batterie charge rapide (autonomie 10h).

Le tout tourne sous Windows 10 que vous pourrez passer à Windows 11. Une bonne affaire !


> Voir l'offre

Sujets relatifs
Feuille de calcul sous excel / mot de passe
Blocage création feuille sous excel 2003
Publication feuille Excel sous FrontPage
2 pages par feuille dans macro excel
organiser mes contacts sous Excel
Excel 2013 sous Windowss 8.1
Excel 2007 Copier/Coller d’une feuille à l’autre Dans un même classeur.
Graphique Nuage de points sous excel
mettre a jour liason feuille excel 2007
Changer nom de feuille attribué par excel
Plus de sujets relatifs à feuille de nite sous excel
 > Tous les forums > Forum Bureautique