× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Bureautique
 Fichier en lecture seule avec Excel 2003 ?Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Josie11
  Posté le 04/12/2012 @ 01:49 
Aller en bas de la page 
Petite astucienne

Bonsoir, Mes fichiers Excel, sont tous conservés sur un disque externe. Je viens de passer à Windows 7 et en ouvrant un fichier Excel, ils s’ouvrent tous en lecture seule. Si je choisis Propriété sur le fichier, la case Lecture seule n'est pas coché, alors je ne comprends pas. Merci pour l'aide.

Publicité
galopin01
 Posté le 04/12/2012 à 04:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Je pense que c'est un problème de protection. Une fois créé ta zone de travail habituelle tu y transfers tes documents et tu les utilises sans problème.

Mais quand tu ouvres directement des fichiers depuis une répertoire ou un lecteur "mobile" -un répertoire de téléchargement par exemple, ou un lecteur externe-Excel considère ces zones comme suspectes et te permet d'examiner ces fichiers en toute sécurité soit pour éviter de laisser agir des macros malveillantes, soit pour éviter de modifier accidentellement des copies de sécurité de tes fichiers sensibles.

Dans le menu :

Fichier / Options Excel / Gestion de la confidentialité / Paramètres du centre de gestion de la Confidentialité / Emplacements approuvés

Tu dois créer et définir le(s) répertoire(s) de travail et de stockage des fichiers que tu utilises :

En bas à droite de cette dernière fenêtre Ajouter un nouvel emplacement... / Parcourir

Penser à cocher Les sous dossiers de cet emplacement sont également approuvés.

On crée en général pour cela un répertoire dans Mes documents...

D'autres options concernant le mode protégé sont également disponibles toutefois je te déconseille de les modifier. Une fois tes fichiers importés dans un emplacement approuvé tu pourras y travailler normalement et c'est en général suffisant.

Bien sur tu n'es pas obligé d'en passer par là : il suffit d'ouvrir chaque fichier et de l'Enregistrer sous... dans un autre emplacement pour qu'il se comporte à nouveau comme tous tes fichiers habituels. Mais bien sur cela n'est pas recommandé car en procédant comme celà tu inhibes en quelque sorte le système de sécurité prévu.

A noter toutefois que les fichiers importés depuis des versions antérieures d'Excel ne doivent pas être protégés au moment du transfert car le codage du système de mots de passe n'est souvent pas le même... Une fois ouvert il suffit de reprotéger le fichier sous ton nouvel Excel et ça fonctionne ensuite comme d'habitude.

A+

Josie11
 Posté le 04/12/2012 à 08:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Bonjour, J'ai omis de dire que j'avais Office 2003 et je n'ai pas : Fichier / Options Excel / Gestion de la confidentialité / Paramètres du centre de gestion de la Confidentialité / Emplacements approuvés. Voici les possibilités :

galopin01
 Posté le 04/12/2012 à 08:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Désolé comme tu es passé sous Windows 7 je pensais que tu avais adopté un Excel récent.

Je n'ai donc pas de meilleure explication si tu as conservé ton 2003.

A+

Josie11
 Posté le 04/12/2012 à 09:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Je peux les enregistrer à un autre endroit sans problèmes, sur le Bureau par exemple, je peux l'ouvrir normalement.

Je viens de faire cette manip :

  • Dans le dossier d'origine, je coupe et colle le fichier sur le Bureau
  • Sur le Bureau, je coupe et colle le fichier dans le dossier d'origine
  • Maintenant, je peux l'ouvrir normalement !!!!

J'ai un grand nombre de fichiers Excel et je voudrais avoir une manip qui me permette de récupérer ces fichiers d'un seul coup !!!

De plus, les documents Word fonctionnent très bien !!!

Merci de vos lumières .....

galopin01
 Posté le 04/12/2012 à 09:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Il est possible que ce soit un peu le même genre de sécurité. Les supports mobiles ou externes de mêmes que les serveurs sont souvent considérés comme potentiellement dangereux :

Dans les options d'Excel Outils / Options / Enregistrer, tu dois avoir si mes souvenirs sont exacts une ou deux lignes permettant de définir ton répertoire de travail et/ou (?) d'enregistrement par défaut.

Essaie de définir ton disque comme répertoire de travail.

A+

Josie11
 Posté le 04/12/2012 à 09:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

J'ai tout de suite regardé à cet endroit et je n'ai que pour l'enregistrement de récupération que je préfère laisser sur le disque principale. D'ailleurs quand j'ouvre un nouveau fichier, celui-ci n'est pas en lecture seule ....

galopin01
 Posté le 04/12/2012 à 10:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Et dans les autres onglets Modification / Général / Sécurité ??? il me semble pourtant bien me rappeler qu'on pouvait définir un répertoire par défaut.

De toute façon ce doit être une histoire comme ça. Par sécurité Excel aime pas qu'on lui sorte des fichiers comme ça d'un chapeau !

Donc soit tu mets tous tes fichiers dans le répertoire par défaut, soit tu arrives à lui faire comprendre que ton disque dur externe est inoffensif...

Pourquoi ne pas être passé à Exel 2010 dans la foulée il y a pourtant de nombreuses amélioration non négligeables ?

A+

Josie11
 Posté le 04/12/2012 à 10:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Je ne vois rien :

Je n'ai pas 2010 et je préfère la version de 2003 à 2007 que je possède pourtant !!

Publicité
galopin01
 Posté le 04/12/2012 à 10:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Désolé mais mes souvenirs commencent à s'effilocher... Tu as regardé quand même les autres onglets (Général et Sécurité) ?

Je te concède que 2007 n'était pas Top. Personne ne le regrettera !

Josie11
 Posté le 04/12/2012 à 11:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Merci d'être d'accord avec moi pour 2007 !!!

Dans l'onglet sécurité, l'option lecture seule n'est pas cochée .... J'y perds le latin que je n'ai jamais eu !!!

Je pense que Seven en est la cause, car avec XP, je n'avais pas ce problème et je vais rester avec ma manip au coup par coup.

Si jamais je trouve, je ne manquerai pas de venir alimenter ce post et le mettre enfin comme résolu !

Merci pour l'aide. Cordialement.

mystique23
 Posté le 08/01/2013 à 06:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne

J'suis pas certaine que ça va t'aider, mais j'ai eu le même problème avec des fichiers excels sur une clef usb. Bien sûr, en les copiant sur le bureau, ce problème n'est plus présent, mais si tu veux absolument les laisser sur ton disque externe, je crois qu'il y a une solution.

Je suis pas certaine que c'est exactement pareil cart j'utilise Excel 2010, mais ça devrait se ressembler.

Tu vas dans ton disque interne et tu te rends sur le dossier dans lequel tes fichiers excel se retrouvent (n'ouvrent pas le dossier, sinon tu devras faire la manipulation pour chaque fichier un par un, alors que tu peux le faire pour le dossier en un coup). Clique à droite, «propriétés» puis «sécurité», «modifer», sélectionne «utilisateurs», va cocher «autoriser» vis à vis «contrôle total» et les autres niveaux d'autorisation vont se sélectionner automatiquement, tu appliques et voilà. Les classeurs de ce document ne s'ouvrent alors plus en lecture seule.

J'espère que ça va t'aider!

Josie11
 Posté le 08/01/2013 à 08:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Bonjour Mystique23, et merci pour ta réponse. J'avais fini par trouver cette soluce, mais avec les vacances, j'ai omis de mettre le sujet comme résolu, ce que je fais à l'instant.

C'est un peu long, car il faut le faire pour chaque dossier présent sur le disque, mais ça marche !!!

Bonne journée

starcos
 Posté le 08/01/2013 à 13:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Concernant ce souci, il faut copier les fichiers sur un autre support, puis reformater le disque concerner et de remettre les fichiers et voilà en gros la solution.

A méditer

mystique23
 Posté le 08/01/2013 à 17:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne

J'ai aussi réalisé qu'au lieu de la faire sur chaque dossier, je peux aller faire la même opération directement sur la clef usb (ou sur le disque externe, je suppose) en allant voir la clef dans le poste de travail

ça sauve beaucoup de temps

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
489,99 €Disque dur externe Western Digital My Book Duo 24 To USB 3.1 à 489,99 €
Valable jusqu'au 28 Septembre

Amazon propose actuellement le disque dur externe Western Digital My Book 24 To USB 3.1 à 489,99 € livré gratuitement. On le trouve ailleurs à partir de 700 €. Le My Book Duo est une solution de stockage RAID de bureau d’une très grande capacité, idéale pour stocker des photos, des vidéos, des documents et de la musique. Vous pourrez l'utiliser en mode RAID 0 pour des perfomances ultrarapides (vitesse de lecture séquentielle pouvant atteindre 360 Mo/s) ou bien en mode RAID 1 pour bénéficier d’une redondance et mettre vos données en miroir sur les disques durs installés dans le boîtier. Ce dernier comporte en effet 2 disques durs Western Digital RED de 12 To adaptés aux NAS et qui peuvent être récupérés pour être utilisés ailleurs. Sachant qu'un disque dur RED 12 To coûte au moins 400 €, l'achat du Western Digital My Book Duo 24 To peut aussi être une solution économique si vous avez besoin de 2 disques durs 12 To pour votre NAS.


> Voir l'offre
34,99 €Clé USB 3.1 SanDisk Extreme Pro 128 Go (420 Mo/s) à 34,99 €
Valable jusqu'au 22 Septembre

Amazon fait une promotion sur la clé USB 3.1 Sandisk Extreme Pro 128 Go qui passe à 34,99 € livrée gratuitement alors qu'on la trouve ailleurs à partir de 55 €. Cette clé USB 3.1 (compatible usb 3.0) est extrèmement rapide puisqu'elle offre des débits jusqu'à 420 Mo/s en lecture et 380 Mo/s en écriture. Pratique, son connecteur rétractable vous évitera d'avoir à manipuler (et perdre ?) un bouchon.


> Voir l'offre
23,99 €Chargeur panneau solaire RAVPower USB (21W, 2 ports USB, pliable, étanche) à 23,99 € via coupon
Valable jusqu'au 20 Septembre

Amazon fait une promotion sur le chargeur panneau solaire RAVPower 21W qui passe à 23,99 € via un coupon de réduction de 40% alors qu'on le trouve ailleurs à partir de 40 €. Ce panneau solaire est résistant et étanche, est équipé de 4 crochets pour l'accrocher partout et possède 2 ports USB capables d'atteindre 2,4 A chacun pour un total de 4,8 A. 2 câbles micro usb sont fournis. Pour profiter de l'offre, cochez la case Coupon : utiliser le coupon de réduction de 40%. Le prix passera à 23,99 €.


> Voir l'offre

Sujets relatifs
Ouverture fichier excel avec microsoft office 2003
Choisir ouverture fichier avec Excel 2000 ou 2003
ouvrir un fichier excel - pb lecture seule
Fichier .csv avec Excel
Comment recuperer des fichiers Excel 2007 avec Excel 2003
Données d'un Fichier txt avec EXCEL
problème lecture fichier docx avec Open Office
Problème ouverture de fichier protégé dans Excel 2003
Problème avec un fichier excel
ouverture d'un fichier excel cree sur xp avec windows 7
Plus de sujets relatifs à Fichier en lecture seule avec Excel 2003 ?
 > Tous les forums > Forum Bureautique