> Tous les forums > Forum Linux
 Firefox des solutions aux problèmes pas convaincantes. (Résolu)
Ajouter un message à la discussion
Pages : 1 [2] ... Fin
Page 2 sur 2 [Fin]
m_n
 Posté le 06/09/2019 à 18:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Avec Arcolinux basé sur Arch :

Taras_Boulba
 Posté le 07/09/2019 à 13:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

vu que arcolinux est basée sur arch, il utilise les mêmes dépôts qu'arch. firefox 69 est bien dispo dans le dépôt extra d'arch depuis le 3 sept.

Logicien
 Posté le 07/09/2019 à 18:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

je suis entrain de faire ma mise-jour hebdomadaire de la Arch et effectivement Firefox 69 va être installé. Sous Debian dans le dépôt unstable Firefox 69 est également disponible. J'ai hâte d'utiliser cette version.



Modifié par Logicien le 07/09/2019 18:27
Logicien
 Posté le 08/09/2019 à 18:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Même problème sous la Arch avec Firefox 69 ici même dans la boîte à messages du forum.

aug
 Posté le 08/09/2019 à 19:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

logicien,

Personnellement, j' utilise la version ESR de Firefox sur toute mes distributions linux ( Arch, debian, dérivées de ces dernières, mint).

Aucun problème particulier à signaler.

Pour en revenir à ton problème: utilises-tu une police particulière autre que celles du navigateur ?

Une autre question, si tu le permet: quels réglages fais tu pour l'affichage correcte des pages du navigateur sur ton écran ?

Logicien
 Posté le 08/09/2019 à 20:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut aug, merci de ton intervention.

J'utilise la police Bitstream Vera Sans qui est une police sans serif. C'est la même police que j'utilise avec Seamonkey et Falkon qui ne me donnent pas de lenteurs d'affichage des frappes au clavier. Je force l'utilisation de mes polices dans tous mes navigateurs.

J'utilisais justement Firefox-esr sous Debian qui me donne aussi ce problème. Je vais passer à Firefox tout court version 69 lors de ma prochaine semaine sous Debian. Je suis une semaine sous Debian et une semaine sous la Arch sur mon ordinateur principal. Sous la Arch Firefox 69 ne fait aucune différence. C'est très pénible d'écrire présentement. Avec un nouveau profil Firefox a encore ce problème.

Il me reste à voir aussi sur mon ordinateur secondaire et mon portable comment se comporte Firefox. Un matériel différent peut peut-être avoir des effects différents.



Modifié par Logicien le 08/09/2019 20:23
aug
 Posté le 08/09/2019 à 21:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

...

Tu indiques avoir le même problème avec deux versions de Firefox sur deux distributions différentes sur la même machine.

Qu'est ce qui est commun aux deux: la carte graphique et la police utilisée.

J'essaierai plusieurs polices pour voir si le problème se règle.

je vais suivre le sujet, par curiosité.

Logicien
 Posté le 23/09/2019 à 15:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bon jour,

j'ai désactivé des services en les masquant. Pour l'instant Firefox a retrouvé sa cadence normale d'affichage des caractères des frappes au clavier ici et sur d'autres sites. Je me croise les doigts. Voici ce que j'ai fait:

systemctl mask accounts-daemon.service

Ce service gère les ressources allouées aux applications et peut ne pas en donner assez à Firefox qui en demande beaucoup.

systemctl mask upower.service

Gère l'économie d'énergie. Xscreensaver fonctionne mieux depuis je je l'ai désactivé.

systemctl mask udisks2.service

Gère l'accès aux disques pour les utilisateurs. Les gestionnaires de fichiers s'ouvrent plus rapidement quand il est désactivé surtout losrqu'on partage comme moi des fichiers en réseau avec Samba.

J'ai aussi désactivé des services de jeux qui s'étaient activés automatiquement. Les causes précises des lenteurs de Firefox restent encore pour moi obscures. Je vais suivre encore longtemps si tout est en ordre avec cet important navigateur Web. Retour à la normal autant sous Debian que la Arch avec Firefox version 69.



Modifié par Logicien le 23/09/2019 16:40
Publicité
Slyvester
 Posté le 25/09/2019 à 10:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour Logicien,

... j'ai désactivé des services en les masquant. Pour l'instant Firefox a retrouvé sa cadence normale d'affichage des caractères des frappes au clavier ici et sur d'autres sites. Je me croise les doigts. Voici ce que j'ai fait:

systemctl mask accounts-daemon.service

Ce service gère les ressources allouées aux applications et peut ne pas en donner assez à Firefox qui en demande beaucoup.

systemctl mask upower.service

Gère l'économie d'énergie. Xscreensaver fonctionne mieux depuis je je l'ai désactivé.

systemctl mask udisks2.service

Gère l'accès aux disques pour les utilisateurs...

Logicien, tu m'as profondément déçu aujourd'hui. J'ai appliqué les trois formules ci-dessus en me disant bien stupidement que - te connaissant - je ne risquais rien ! Bien mal m'en a pris. La formule ci-dessus :

systemctl mask udisks2.service

qui doit être précédée de "sudo" a comme conséquence bien fâcheuse de désactiver et de bloquer tout accès aux disques externes (USB, ...). Après application de celle-ci, j'ai eu la désagréable surprise de ne plus pouvoir accéder (ni ouvrir) à mes clés USB ni autres disques durs externes.
Cela m'a pris la bagatelle d'une heure et demi pour retrouver la situation antérieure et avoir accès - à nouveau - à mes média externes, et ce grâce à des sites pointus (heureusement que je comprends bien l'anglais) comme : https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=884530;msg=58 ou encore : https://unix.stackexchange.com/questions/308904/systemd-how-to-unmask-a-service-whose-unit-file-is-empty et surtout celui-ci : https://askubuntu.com/questions/804946/systemctl-how-to-unmask

C'est très dangereux de "balancer" comme cela (à l'emporte-pièce) des formules qui peuvent paraître innocentes, voire inoffensives. Ces fichues forrmules ont des conséquences qui peuvent être considèrées comme désastreuses sur le système interne. Cela m'est arrivé - en plus - sur ma distribution Linux préférée "SparkyLinux" transformée par mes soins en "sid - unstable".
Il m'a fallu près d'une heure et demi pour retrouver l'accès à mes disques externes, médias externes et autres clés USB.
Désolé; Logicien, d'exprimer ainsi ma mauvaise humeur,

N.B. Je conseille vivement aux autres P.C. Astuciens de ne pas essayer ni appliquer aucune des formules reprises dans le post de Logicien et surtout pas celle-ci :

sudo systemctl mask udisks2.service



Modifié par Slyvester le 25/09/2019 12:15
Logicien
 Posté le 26/09/2019 à 08:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Sous Linux une maxime revient souvent 'si vous savez ce que vous faites'. Sinon, s'abstenir. J'en ai souvent parlé.

Je n'ai rien balancé de dangereux à l'emporte pièce. C'est de la diffamation de ta part Slyvester parce-que j'explique ce que je fais et les commandes dont j'ai parlé sont réversibles.

C'est pire d'écrire ça que le préjudice que mes commandes ont pu te poser. C'est ta foi eveugle qui t'a trahi. Prend en conscience et cherche à comprendre avant s'agir.

Je ne suis pas mal intentionné. Je vais être plus prudent encore à l'avenir. Surtout que Linux est une bête vraiment difficile à maîtriser. Ça peut devenir très frustrant à long terme.

Ce n'est pas donné à tous de vouloir et de comprendre. Mon but n'est pas de m'imposer ni d'étaler mes connaissances il m'en manquera toujours.

J'aime simplement le défi que pose GNU/Linux et les logiciels libres à l'entendement humain.



Modifié par Logicien le 26/09/2019 08:43
Slyvester
 Posté le 26/09/2019 à 14:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

... C'est de la diffamation de ta part Slyvester parce-que j'explique ce que je fais et les commandes dont j'ai parlé sont réversibles.

Diffamation : connais-tu réellement le sens de ce mot ? Crois-tu que j'ai inventé les conséquences de ta formule : systemctl mask udisks2.service ?, à savoir ne plus avoir accès aux disques externes, médias externes ou autres clés USB ?Puisque tes formules sont réversibles, pourquoi ne pas les avoir indiquées ?

C'est pire d'écrire ça que le préjudice que mes commandes ont pu te poser. C'est ta foi eveugle qui t'a trahi.

Comme c'est facile d'écrire des inepties ! Je constate surtout que ce n'est pas toi qui a passé/perdu beaucoup de temps à effectuer les recherches nécessaires ainsi qu'à appliquer les solutions trouvées sur internet.

Pour ceux qui ont eu la malencontreuse idée de tester/d'appliquer la formule "systemctl mask udisks2.service" préconisée par l'omniscient Logicien, voici la solution que j'ai trouvée pour retrouver dans l'explorateur de fichiers l'accès aux disques durs externes (USB, medias externes, ...) est ici (c'est en anglais cfr. réponse 32) : https://askubuntu.com/questions/804946/systemctl-how-to-unmask Il ne s'agit que de quelques lignes à copier/coller dans un terminal.

.

Taras_Boulba
 Posté le 26/09/2019 à 15:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

c'est assez comique de te lire Sylvester... nul part Logicien conseille d'appliquer les commandes qu'il donne, il se contente d'expliquer ce qu'il a fait pour résoudre son problème.

tu as de ton propre chef appliqué des commandes sans connaître leurs conséquences et maintenant tu t'en prends à un forumeur plutôt qu'à toi même. tu es le seul responsable. quand on touche à systemd, il faut savoir ce qu'on fait...



Modifié par Taras_Boulba le 26/09/2019 15:47
Logicien
 Posté le 26/09/2019 à 18:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Slyvester,

non seulement tu me prêtes des intentions que je n'ai pas mais tu m'insultes en disant que je dis des inepties et que je suis omniscient. Ce sujet est le mien et ne te sert pas de ton ressentiment pour en faire un troll. Si tu m'avais demandé de l'aide pour résoudre ton problème la solution n'aurait pas tardée à venir.

Je peine sous Firefox depuis longtemps maintenant sans trouver la solution à ses lenteurs.



Modifié par Logicien le 26/09/2019 18:08
Logicien
 Posté le 27/09/2019 à 17:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bon,

about:support

dans la barre d'adresse de Firefox et

Réparer Firefox

a remis Firefox à flot. Pas de lenteur depuis plusieurs heures, je me croise les doigts.



Modifié par Logicien le 27/09/2019 17:18
m_n
 Posté le 03/10/2019 à 11:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
Logicien a écrit :

Bon,

about:support

dans la barre d'adresse de Firefox et

Réparer Firefox

a remis Firefox à flot. Pas de lenteur depuis plusieurs heures, je me croise les doigts.

Tres bonne astuce .. Merci ..

Logicien
 Posté le 04/10/2019 à 15:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bon,

je pense que j'ai trouvé le problème. Firefox n'aime pas ma personnalisation d'Xorg. Effectivement, j'ai un fichier de configuration d'Xorg, /etc/X11/xorg.conf que j'ai amélioré au fil du temps depuis l'an 2000, date à laquelle j'ai utilisé pour la première fois une distribution Linux, Mandrake 8.0.

Je ne sais pas encore ce que Firefox n'aime pas dans ce fichier mais quand je l'enlève et que j'utilise la configuration par défaut d'Xorg je n'ai pas de lenteur. Je dois encore utiliser Firefox pendant plusieurs jours sans le fermer pour m'assurer que ses lenteurs ne reviennent pas.

C'est d'autant plus étrange que mes autres navigateurs Web ne souffrent pas de lenteurs ni mes applications en général. J'espère quand même pouvoir marquer ce sujet comme résolu. Il m'a suffisamment causé de problème d'autant plus que sous Debian, Seamonkey n'est pas dans les dépôts officiels comme il l'est sous la Arch, ce qui réduit mes choix de navigation Web.

Comme Firefox est compatible avec la plupart des sites Web, je l'ai adopté comme navigateur par défaut. Retour dans le temps pour conclure j'espère dans quelques jours. Je ne ferai pas de mise-à-jours d'ici là.

Publicité
Taras_Boulba
 Posté le 05/10/2019 à 17:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

tu peux nous faire voir ton xorg.conf, juste par curiosité...

Logicien
 Posté le 06/10/2019 à 04:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bien sûr, j'ai plusieurs types de cartes graphiques, je décommente la section de celle en fonction. Pour le reste je suis à regarder. Sous Debian que je viens de tester pendant plusieurs jours sans problème avec Firefox et sans ma personnalisation dans /etc/X11/xorg.conf, voici ce fichier:

# File generated by XFdrake (rev 247269)

#Section "Device"
#    BoardName  "01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series]"
#    BoardName  "01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV710 [Radeon HD 4350/4550]"
#    BoardName  "01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 610] (rev a1)"
#    BusID      "PCI:1:0:0"
#    Driver     "fbdev"
#    Identifier "Fbdev"
#    VendorName "Amd Corporation"
#EndSection

#Section "Device"
#    BoardName  "00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03)"
#    BusID      "PCI:0:2:0"
#    Driver     "intel"
#    Identifier "Intel"
#    Option     "AccelMethod"       "UXA"
#    Option     "DRI"               "3"
#    Option     "SwapbuffersWait"   "off"
#    Option     "VSync"             "off"
#    VendorName "Intel Corporation"
#EndSection

Section "Device"
#    BoardName  "01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series]"
    BoardName  "01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV710 [Radeon HD 4350/4550]"
#    BoardName  "01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 610] (rev a1)"
    BusID      "PCI:1:0:0"
    Driver     "modesetting"
    Identifier "Modesetting"
    Option     "AccelMethod"         "glamor"
    Option     "DoubleShadow"        "on"
    VendorName "Amd Corporation"
EndSection

#Section "Device"
#    BoardName  "01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 610] (rev a1)"
#    BusID      "PCI:1:0:0"
#    Driver     "nouveau"
#    Identifier "Nouveau"
#    VendorName "NVIDIA Corporation"
#EndSection

#Section "Device"
#    BoardName  "01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series]"
#    BoardName  "01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV710 [Radeon HD 4350/4550]"
#    BusID      "PCI:1:0:0"
#    Driver     "radeon"
#    Identifier "Radeon"
#    Option     "AccelMethod"     "glamor"
#    Option     "DRI"             "3"
#    Option     "EXAVSync"        "off"
#    Option     "SwapbuffersWait" "off"
#    Option     "TearFree"        "off"
#    VendorName "Amd Corporation"
#EndSection

#Section "Device"
#    BoardName  "01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series]"
#    BoardName  "01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV710 [Radeon HD 4350/4550]"
#    BoardName  "01:00.0 VGA compatible controller: NVIDIA Corporation GF119 [GeForce GT 610] (rev a1)"
#    BusID      "PCI:1:0:0"
#    Driver     "vesa"
#    Identifier "Vesa"
#    VendorName "Amd Corporation"
#EndSection

Section "Extensions"
    Option "DAMAGE"    "Enable"
    Option "DPMS"      "Enable"
    Option "RENDER"    "Enable"
    Option "XINERAMA"  "Disable"
EndSection

Section "Files"
    FontPath   "/usr/share/fonts/X11/100dpi/"
    FontPath   "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath   "/usr/share/fonts/X11/75dpi/"
    FontPath   "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath   "/usr/share/fonts/X11/misc/"

    ModulePath "/usr/lib/xorg/modules"
EndSection

Section "InputDevice"
    Driver     "evdev"
    Identifier "Clavier Usb (sans fil) 0"
    Option     "Device"                   "/dev/input/by-id/usb-Logitech_USB_Receiver-if02-event-kbd"
    Option     "XkbLayout"                "ca"
    Option     "XkbModel"                 "logitech_base"
    Option     "XkbRules"                 "base"
EndSection

Section "InputDevice"
    Driver     "evdev"
    Identifier "Souris Usb (sans fil) 0"
    Option     "AccelerationProfile"     "3"
#    Option     "Device"                  "/dev/gpmdata"
    Option     "Device"                  "/dev/input/by-id/usb-Logitech_USB_Receiver-if02-mouse"
#    Option     "Device"                  "/dev/input/mice"
#    Option     "Device"                  "/dev/psaux"
    Option     "Emulate3Buttons"         "off"
    Option     "Protocol"                "ImPS/2"
EndSection

Section "Module"
    Disable "vnc"
    Load    "ddc"
    Load    "dri2"
    Load    "glamoregl"
EndSection

Section "Monitor"
    Identifier "DP1"
    Option     "DPMS"                "on"       
    Option     "PreferredMode"       "1920x1080"
    ModelName  "S22D390"
    VendorName "Samsung Corporation"
EndSection

Section "Monitor"
    Identifier "DVI-0"
    Option     "DPMS"                "on"       
    Option     "PreferredMode"       "1920x1080"
    ModelName  "S22D390"
    VendorName "Samsung Corporation"
EndSection

Section "Monitor"
    Identifier "DVI-I-1"
    Option     "DPMS"                "on"       
    Option     "PreferredMode"       "1920x1080"
    ModelName  "S22D390"
    VendorName "Samsung Corporation"
EndSection

Section "Monitor"
    Identifier "HDMI-0"
    Option     "DPMS"                "on"       
    Option     "PreferredMode"       "1920x1080"
    ModelName  "S22D390"
    VendorName "Samsung Corporation"
EndSection

Section "Monitor"
    Identifier "HDMI-1"
    Option     "DPMS"                "on"       
    Option     "PreferredMode"       "1920x1080"
    ModelName  "S22D390"
    VendorName "Samsung Corporation"
EndSection

Section "Monitor"
    Identifier "HDMI1"
    Option     "DPMS"                "on"       
    Option     "PreferredMode"       "1920x1080"
    ModelName  "S22D390"
    VendorName "Samsung Corporation"
EndSection

Section "Monitor"
    Identifier "VGA-0"
    Option     "DPMS"                "on"       
    Option     "PreferredMode"       "1920x1080"
    ModelName  "S22D390"
    VendorName "Samsung Corporation"
EndSection

Section "Monitor"
    Identifier "VGA1"
    Option     "DPMS"                "on"       
    Option     "PreferredMode"       "1920x1080"
    ModelName  "S22D390"
    VendorName "Samsung Corporation"
EndSection

Section "Monitor"
    Identifier "VGA-1"
    Option     "DPMS"                "on"       
    Option     "PreferredMode"       "1920x1080"
    ModelName  "S22D390"
    VendorName "Samsung Corporation"
EndSection

Section "Screen"
    DefaultDepth 24 
    DefaultFbBpp 32
#    Device       "Fbdev"
#    Device       "Intel"
    Device       "Modesetting"
#    Device       "Nouveau"
#    Device       "Radeon"
#    Device       "Vesa"
    Identifier   "Ecran 0"
    Monitor      "HDMI-0"
#    Option       "PasswordFile"       "/root/.vnc/passwd"
#    Option       "SecurityTypes"      "VncAuth"
#    Option       "UserPasswdVerifier" "VncAuth"

#    SubSection "Display"
#	Virtual  1440 900
#	Virtual  1360 768
#	Virtual  1920 1080
#    EndSubSection
    
EndSection

Section "ServerFlags"
    Option "BlankTime"          "5"
    Option "DontVTSwitch"       "off"
    Option "DontZap"            "off"
    Option "GlxVisuals"         "all"
    Option "DontZoom"           "off"
    Option "Log"                "flush"
    Option "NoPM"               "off"
    Option "NoTrapSignals"      "off"
    Option "OffTime"            "5"
    Option "StandbyTime"        "5"
    Option "SuspendTime"        "5"
    Option "UseDefaultFontPath" "off"
    Option "Xinerama"           "off"
    Option "XkbDisable"         "off"
EndSection

Section "ServerLayout"
    Identifier  "X.org Configure"
    InputDevice "Clavier Usb (sans fil) 0" "CoreKeyboard"
    InputDevice "Souris Usb (sans fil) 0"  "CorePointer"
    Screen      0                          "Ecran 0"      0 0
EndSection



Modifié par Logicien le 06/10/2019 13:56
Logicien
 Posté le 19/10/2019 à 23:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je met mon fichier de configuration d'Xorg /etc/X11/xorg.conf sur la glace et dans mes archives. En utilisant la configuration par défaut d'Xorg Firefox ne présente aucun signe de ralentissement autant sous la Arch que Debian. Comme il y a une nouvelle syntaxe pour configurer Xorg et que je suis sous l'ancienne syntaxe dans /etc/X11/xorg.conf, je vais me contenter de la configuration par défaut d'Xorg autant que possible.

Résolu.

Pages : 1 [2] ... Fin
Page 2 sur 2 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Quelques problèmes avec Firefox 3 Beta 5
Corriger la saisie lente des caractères au clavier dans Firefox
Youtube n'aime pas Firefox avec le Raspberry Pi 3 B+
Mise à jour Firefox -extensions désactivées
Manjaro = Firefox et Thunderbird en Anglais
Firefox sur toutes les distros et connexion impossible sur PC A ce matin
kubuntu 18 en double demarrage avec win10 sur hp nbook restent qq problemes
Firefox et fichiers des paramètres
Firefox 62, impose google
Firefox K16.04LTS: comment augmenter l'historique ?
Plus de sujets relatifs à Firefox des solutions aux problèmes pas convaincantes. (Résolu)
 > Tous les forums > Forum Linux