> Tous les forums > Forum Bureautique
 fonction SiSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Gorfous
  Posté le 03/04/2017 @ 15:53 
Aller en bas de la page 
Petit astucien

Bonjour,

La formule ci-dessous paraît incomplète

=SI(A10="";"Non communiquée")

car si elle affiche bien ce que j'attends, lorsque je la recopie elle affiche FAUX et efface les données

que me manque-t-il svp ? Merci



Modifié par Gorfous le 03/04/2017 15:56
Publicité
pouyou
 Posté le 03/04/2017 à 16:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Je viens de recopier ta formule (dans la colonne B) dans un fichier Excel10 il n'y a pas de soucis, lorsque je tape un où plusieurs caractères dans les cellules de la colonne A (lettres où chiffres) le résultat est "Faux".

pouyou



Modifié par pouyou le 03/04/2017 16:06
poussebois
 Posté le 03/04/2017 à 16:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour ,

=SI(A10="";Valeur si VRAI;valeur si FAUX)

@ +

Daneel Olivaw
 Posté le 03/04/2017 à 19:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour

Comme dit Anonyme, la formule c'est : si(test_logique,valeur_si_vrai,valeur_si_faux)

Mais le ";" donne une erreur chez moi. Il faut une ","

Daneel Olivaw
 Posté le 03/04/2017 à 20:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Anonyme a écrit :
Daneel Olivaw a écrit : ...

Salut

C'est bien ; avec la fonction SI() !

La , c'est pour la fonction IF() donc

sur un EXCEL US.

Anonyme

Anonyme

Ah ! Je ne savais pas que la ponctuation dans les formules était différente selon les langues.

poussebois
 Posté le 04/04/2017 à 09:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

@ Daneel Olivaw

Ah ! Je ne savais pas que la ponctuation dans les formules était différente selon les langues.

Et pourquoi pas ? Les mots sont bien différents : IF in english, SI en français. Même chose pour le "." décimal

Bonne fin de journée (les heures aussi sont différentes au Canada, ici, c'est la matinée )

Gorfous
 Posté le 04/04/2017 à 13:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour à vous tous,

Je m'aperçois que la formule n'est pas vraiment adaptée à ce que je voudrais obtenir

Peut-on le faire par une macro qui remplirait les cellules vides ("") de la colonne "J" par la mention "Non communiquée"

En vous remerciant infiniment

pouyou
 Posté le 04/04/2017 à 15:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Gorfous a écrit :

Bonjour à vous tous,

Je m'aperçois que la formule n'est pas vraiment adaptée à ce que je voudrais obtenir

Peut-on le faire par une macro qui remplirait les cellules vides ("") de la colonne "J" par la mention "Non communiquée"

En vous remerciant infiniment

Tu as plusieurs possibilités avec la fonction SI, en voici plusieurs:

A adapter à ton problème en nous disant ce que tu veux dans chaque cellule.

pouyou



Modifié par pouyou le 04/04/2017 21:59
Gorfous
 Posté le 04/04/2017 à 16:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour à tous

La colonne J contient des adresses, parfois il n'y a pas d'adresse et c'est là que je souhaiterai que s'inscrive : "Non communiquée"

Anonyme : Et que veux tu vraiment obtenir ?

Peut-on le faire par une macro qui remplirait les cellules vides ("") de la colonne "J" ou du champ dynamique "ColJ" par la mention "Non communiquée"

en vous remerciant



Modifié par Gorfous le 04/04/2017 17:00
Publicité
Gorfous
 Posté le 06/04/2017 à 15:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Sub NonCommuniquée() 'Si pas d'adresse OKOK
Dim DerL&, Lig&
DerL = Feuil3.Range("J" & Rows.Count).End(xlUp).Row
For Lig = 1 To DerL
If Cells(Lig, 10) = "" Then Cells(Lig, 10) = "Non communiqué"
Selection.Font.Bold = True
Selection.Font.ColorIndex = 3
Next Lig
Columns("J:J").EntireColumn.AutoFit
End Sub

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
utiliser une array {} dans une fonction personnalisée
fonction SI
la fonction si avec plusieurs conditions
on error goto sur une fonction de recherche
Erreur dans la conception de la fonction DATEDIF !
Fonction Excel et conditions
Fonction Excel et conditions
Fonction Excel et conditions
fonction fréquence
utilisation méthode "Evaluate" dans une fonction personnalisée
Plus de sujets relatifs à fonction Si
 > Tous les forums > Forum Bureautique