> Tous les forums > Forum Bureautique
 Format de cellule personnalisée - Excel 2007Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Gabrilou
  Posté le 07/02/2013 @ 05:52 
Aller en bas de la page 
Astucienne

,

J'essaie de créer un format de cellule personnalisée. Il s'agit d'une séquence de chiffres + une lettre. Les chiffres ne sont jamais les mêmes, la lettre non plus, et tout se passe dans la colonne A. Le № se présente toujours de la façon suivante : 2 chiffres suivis d'une espace, 6 chiffres suivis d'une espace, 3 chiffres suivis d'une espace et d'une lettre en majuscule : (ex. : 46 120417 356 F). Il semble impossible de formater des chiffres et des lettres, en tout cas je n'ai pas réussi.

J'ai essayé de travailler avec 2 colonnes mais je n'ai pas réussi non plus ce formatage. J'ai tapé 46120417356 dans la colonne A et la lettre F dans la colonne B.

Dans la colonne C, j'ai mis la formule suivante : =TEXTE(A1;"000# 000#")&" "&B1. Ça ne marche pas comme je le voudrai.

Merci pour votre aide.

Publicité
DjiDji59430
 Posté le 07/02/2013 à 11:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

A partir du moment ou on melange des nombres et des lettres, c'est du texte, et il n'y a pas de format texte.

Avec 2 colonnes

=GAUCHE(A1;2)&" "&STXT(A1;3;6)&" "&STXT(A1;9;3)&" "&DROITE(A1;1)

46120417356A, dans A1, la formule dans B1


Il ya surement une façon plus élégante ! (genre zone de saisie qui formate le texte et va le placer a la derniere cellule vide de la colonne ! ), mais je ne sais pas faire.



Modifié par DjiDji59430 le 07/02/2013 11:12
Gabrilou
 Posté le 07/02/2013 à 14:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Je n'ai pas compris la formule, mais le résultat est là, comme je le voulais.

Merci d'avoir pris le temps de m'aider.

Bonne journée

papouclo
 Posté le 07/02/2013 à 19:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,
Peut-être une possibilité de "formater" la saisie avec une procédure évènementielle :

Private Sub Worksheet_Change(ByVal Target As Range)
Dim machaine As String

If Target.Count > 1 Then Exit Sub
'permet de sortir de la procédure si plus d'une cellule est sélectionnée
'(sinon la suite de la macro renvoie un message d'erreur)

If Target.Column > 1 Then Exit Sub
'permet de sortir de la procédure si la cellule modifiée
' n'est pas dans la colonne A

machaine = Target.Value

If Len(machaine) = 15 Then Exit Sub
'permet de sortir de la procédure lorsque la cellule est réécrite au format désiré

Target.Value = Format(Left(machaine, 5), "00 000") & Format(Mid(machaine, 6, 6), "000 000") & " " & Right(machaine, 1)

End Sub

Cordialement

Gabrilou
 Posté le 07/02/2013 à 19:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

DjiDji59430, papouclo

Me voilà avec deux formules qui marchent

Merci à vous deux

ferrand
 Posté le 08/02/2013 à 16:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonsoir,

Une version de ta formule utilisant TEXTE qui me paraît fonctionner...

=TEXTE(A1;"00\ 000000\ 000\ ")&B1

La définition des formats de cellule personnalisés n'est pas toujours identique à la définition du format dans la fonction, il faut souvent tâtonner...

Cela peut toujours être utile.

papouclo
 Posté le 08/02/2013 à 17:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour à tous,

Merci ferrand pour ce format.
cela peut servir pour d'autres formats inhabituels.
Cordialement

Gabrilou
 Posté le 08/02/2013 à 17:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Merci à toi Ferrand

Quelle chance on a de vous avoir , je l'apprécie tellement

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
Pâte thermique Arctic MX-4 (8 g) à 5,99 €
5,99 € 11 € -46% @Amazon
SSD Interne M.2 NVMe Samsung 980 500 Go à 49,33 €
49,33 € 65 € -24% @Amazon
Lot de 3 ventilateurs upHere 120 mm LED bleu à 5,99 €
5,99 € 12,99 € -54% @Amazon
Enceinte connectée Amazon Echo Dot (5ème génération) avec assistant Alexa + prise connectée Meross à 29,99 €
29,99 € 84,98 € -65% @Amazon
Clavier Logitech G213 Prodigy RVB + Norton 360 Deluxe (3 postes, 12 mois)à 36,99 €
36,99 € 70 € -47% @Cdiscount
Souris sans fil bluetooth Microsoft Modern Mobile Mouse à 14,99 €
14,99 € 30 € -50% @Amazon
Amazon Fire TV Cube à 74,99 €
74,99 € 119,99 € -38% @Amazon
Webcam Logitech C922 Pro à 54,99 €
54,99 € 85 € -35% @Amazon
SSD PNY CS900 480 Go à 36,28 €
36,28 € 50 € -27% @Amazon
Microsoft Office 365 Famille (1 utilisateur) + Norton 360 (1 appareil) pendant 15 mois à 45,99 €
45,99 € 69 € -33% @Amazon

Sujets relatifs
Format de cellule personnalisée excel
Imposer format dans cellule excel 2007
Excel 2007 macro rajouter tri + cellule en surbrillance à chaque changement
Comment verrouiller une cellule Excel 2007
format cellule Excel
Excel 2007 résultat formule dans une autre cellule
Excel 2007 formule et saisie dans la même cellule
Excel 2007 couleur dans une cellule non imprimable
Excel 2007 - Suppression selon format
cellule excel 2007
Plus de sujets relatifs à Format de cellule personnalisée - Excel 2007
 > Tous les forums > Forum Bureautique