> Tous les forums > Forum Bureautique
 Formule à créer dans Excel 2010Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
cascada31
  Posté le 02/11/2017 @ 10:58 
Aller en bas de la page 
Nouvelle astucienne

Bonjour à vous tous,

J'ai besoin d'aide afin de créer une formule mathématique dans Excel 2010.

Je tourne en rond depuis un moment car excel compare un chiffre à un mot et la réponse n'est pas la bonne. Mon tableau est le suivant :

Dans la case F2 il n'y aura que des chiffres.

Par contre dans la case G2, il peut y avoir soit des chiffres soit le mot "SO".

En fonction de ce qu'il y a dans les cases F2 et G2, je dois obtenir dans E2 soit E2="O" soit E2="N".

La formule que je recherche comporte les conditions suivantes :

Pour D2="PC" j'ai 3 choix possibles

si F2>=10 et G2>=5 ou G2<5 ou G2="SO" alors E2="O"

si F2<10 et G2>=5 alors E2="O"

si F2<10 et G2<5 ou G2="SO" alors E2="N"

Voici deux des formules qui fonctionnent mais la condition G2<5 ou G2="SO" est séparée :

SI(OU((D5="PC")*(F5>=10);(D5="PC")*(G5<>"SO"));"O";SI((F5<10)*(G5="SO");"N";""))

SI(OU((D5="PC")*(F5>=10);(D5="PC")*(G5>=5));"O";SI((F5<10)*(G5<5);"N";""))

Je cherche une solution où je puisse mettre G2<5 ou G2="SO" dans la même formule.

Excel compare le mot "SO" et le chiffre 5 et donc ne m'affiche pas le bon résultat.

J'espère avoir été assez claire et vous remercie par avance pour vos réponses.




[Configuration automatique à compléter]
Windows 7
Chrome 61.0.3163.100



Modifié par cascada31 le 02/11/2017 11:06
Publicité
poussebois
 Posté le 02/11/2017 à 12:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour ,

Cette formule te convient-elle ?

=SI(D2="PC";SI(ET(OU(G2<5;G2="SO");F2<10);"N";"O");"")

@ +

cascada31
 Posté le 02/11/2017 à 14:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne

Bonjour,

Merci beaucoup, tu me sauves la vie.

Elle fonctionne très bien.

Mille mercis et bonne fin de journée

poussebois
 Posté le 02/11/2017 à 14:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

et bienvenue sur PC Astuces (je n'avais pas fait attention au fait que tu étais nouvelle),

Content pour toi que cela fonctionne comme tu le souhaitais

Il est de coutume de le signaler en cliquant, à la fin de ton post sur "Marquer comme résolu".

cascada31
 Posté le 02/11/2017 à 16:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvelle astucienne

Merci, contente de m'être inscrite.

Je ne l'ai pas clôturé car j'ai d'autres formules à créer sur cette même base et je me disais que je pourrais continuer sur cette discussion?

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Aucun sujet pertinent lié trouvé
 > Tous les forums > Forum Bureautique