> Tous les forums > Forum Bureautique
 Formule avec datesSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Customer71
  Posté le 28/09/2011 @ 09:46 
Aller en bas de la page 
Petit astucien

Bonjour à tous,

Je sèche sur une formule avec des conditions . A noter que je préfère une formule à une macro

Voilà mon problème. Avec Excel 2007, j'ai construis un tableau pourtant simple :

Dans la colonne "A" sont écrites des dates au format jj/mm/aa (Ex pour A1: 28/09/11). Les cellules A1 à A500 sont renseignées de dates diverses

Dans la colonne "B" sont écrites des valeurs en (Ex pour B1: 18.30 €). Les cellules B1 à B500 sont renseignées de valeurs diverses

Je voudrais en C1 par exemple avoir la somme en € de tous les mm/aa (je ne tiens pas compte du jour)

En C1 Somme de toutes les dates dont le mois et l'année sont 01/10, en C2 02/10, en C3 03/10 ...... jusqu'à Cx 09/11

Merci de votre aide si vous avez une idée

Publicité
qmike549
 Posté le 28/09/2011 à 10:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

bnjour

Utilise de ce genre de projet la fonction sommeprod()

Customer71
 Posté le 28/09/2011 à 10:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour qmike549

OK, pour utiliser cette fonction, mais la formule en elle-même, elle donne quoi ?. Je suis novice

Merci

galopin01
 Posté le 28/09/2011 à 11:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

La formule pour la plage A1:B7

=SOMMEPROD(((ANNEE(A1:A7)=2010)*1)*B1:B7) +SOMMEPROD((MOIS(A1:A7)<10)*(ANNEE(A1:A7)=2011)*1)*B1:B7

= Somme pour l'année 2010 ------------------------- + somme pour les mois <10 de l'année 2011

A+

Customer71
 Posté le 28/09/2011 à 14:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Galopin,

Si j'écris ta formule en C1, le résultat ne me convient pas. Pourtant en lisant tes (autres) réponses dans le forum, tu m'as l'air particulièrement doué et à l'aise avec Excel

Peut-être me suis-je mal exprimé

Voici d'après le tableau ci-dessous (et c'est beaucoup plus représentatif) ce que j'attend :

Je voudrais créer une formule dans la colonne "C" qui me donne le résultat (que j'ai écrit manuellement en "F")

La colonne "E" décrit comment j'arrive à ce résultat. Je prend en compte le mois et l'année de chaque date

Si tu peux me trouver ça ce serait génial

Merci de ton aide

rj390111
 Posté le 28/09/2011 à 17:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

En C1 mettre la formule

=SOMMEPROD((ANNEE($A$1:$A$24)=E1)*(MOIS($A$1:$A$24)=D1)*($B$1:$B$24))

Et tirer cette formule vers le bas jusque C24 par exemple pour 24 mois

En D1 à D24 on met les mois 1 à 12 puis de nouveau 1 à 12

En E1 à E12 on met 2010 et En E13 à E24 onmet 2011

Et vous aurez le résultat escompté.

Customer71
 Posté le 28/09/2011 à 18:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
rj390111 a écrit :

Bonjour,

En C1 mettre la formule

=SOMMEPROD((ANNEE($A$1:$A$24)=E1)*(MOIS($A$1:$A$24)=D1)*($B$1:$B$24))

Et tirer cette formule vers le bas jusque C24 par exemple pour 24 mois

En D1 à D24 on met les mois 1 à 12 puis de nouveau 1 à 12

En E1 à E12 on met 2010 et En E13 à E24 onmet 2011

Et vous aurez le résultat escompté.

Bonjour,

Merci de ton aide, je mets tout celà en place demain matin et te tiens au courant

Bonne soirée

galopin01
 Posté le 28/09/2011 à 20:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonsoir,

La formule pour la plage A1:B22 et pour janvier 2010 :

=SOMMEPROD((MOIS(A1:A22)=1)*(ANNEE(A1:A22)=2010)*1)*B1:B22

Pour Février 2010:

=SOMMEPROD((MOIS(A1:A22)=2)*(ANNEE(A1:A22)=2010)*1)*B1:B22

Et ainsi de suite...

A+

papouclo
 Posté le 29/09/2011 à 09:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour le forum,

Voici une proposition dans le classeur joint ICI.

La formule est pratiquement la même que celles proposées par galopin et rj.

Le problème est peut-être d’avoir une seule formule à recopier en tirant vers le bas (méthode rj) et éventuellement d’écrire les mois de référence
pour calculer les sommes (janv-10 ; fév-10 ; ;… ; oct – 11) au moyen d’une formule sans avoir à écrire dans chaque case.

J’ai permuté les colonnes C et D dans le classeur proposé (mois en colonne C ; somme d’argent en colonne D) mais cela peut se permuter facilement.

Pour les mois, écrire en C1 la formule : =FIN.MOIS($A$1;LIGNE()-1) avec le format personnalisé mmm - aa
et la recopier dans la colonne vers le bas.

Pour les sommes par mois, la formule en D1 est alors :
=SOMMEPROD((ANNEE($A$1:$A$22)=ANNEE(C1))*(MOIS($A$1:$A$22)=MOIS(C1))*$B$1:$B$22)
à recopier dans la colonne D vers le bas.

Ceci se retrouve dans le classeur à la feuille Exemple1.

Le problème est de modifier la formule en D1 si l’on veut rajouter d’autres mouvements d’argent dans les colonnes A et B.

D’où l’Exemple2 où les plages des colonnes A et B sont appelés Dates et Mouvements (noms définis de façon dynamique au moyen de la formule DECALER).
La formule en D1 (et à recopier vers le bas) devient :
=SOMMEPROD((ANNEE(Dates)=ANNEE(C1))*(MOIS(Dates)=MOIS(C1))*Mouvements)

Cordialement



Modifié par papouclo le 29/09/2011 10:18
Customer71
 Posté le 29/09/2011 à 10:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

rj390111, Galopin et Papouclo

Ah! Je savais bien que j'aurais à faire à des caustauds ! Comme promis, voici le résultat de mes tests.

J'ai testé séparemment les formules proposées par rj390111 et Galopin. Elles me donne toutes les deux le résultat que je souhaitais

Quand à celle de Papouclo, je me suis contenté de recopier son fichier et ça fonctionne également

Il ne me reste plus qu'à choisir entre ces 3 formules en fonction de la "gueule" que je veux donner à mon fichier

Un grand MERCI à vous trois

Une petite remarque toutefois concernant la formule de Gapolin. Afin d'avoir le résultat escompté j'ai déplacé une parenthèse :

Ce que tu proposes : =SOMMEPROD((MOIS(A1:A22)=1)*(ANNEE(A1:A22)=2010)*1)*B1:B22

Ce que j'ai modifié : =SOMMEPROD((MOIS(A1:A22)=1*(ANNEE(A1:A22)=2010)*1)*B1:B22)

J'ai déplacé la parenthèse située après =1 pour la placé en fin de formule

Merci encore à tous, bonne journée et à bientôt peut-être

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
599 €Portable 17,3 pouces HP (FHD IPS, Ryzen 5 5500U, 16Go/512Go, Windows 11) à 599 €
Valable jusqu'au 21 Mai

Leclerc fait une belle promotion sur l'ordinateur portable HP Pavilion 17-cp0298nf qui passe à 599 € au lieu de 699 €. Une bonne affaire ! Ce portable possède un écran 17.3 pouces HD Full HD IPS (1920x1080), un processeur AMD Ryzen 5 5500U (6 coeurs), un SSD NVMe de 512 Go et un chip graphique Vega 7. Le tout tourne sous Windows 11.

De quoi faire de la bureautique, surfer sur Internet, du multimédia et des petits jeux en toute tranquillité.


> Voir l'offre
12,99 €Hub USB C 6 en 1 (HDMI 4K, 3xUSB 3.0, SD et MicroSD) à 12,99 €
Valable jusqu'au 21 Mai

Amazon fait une promotion sur le hub USB C 6 en 1 Cappuon qui passe à 12,99 € au lieu de 29,99 € grâce à un coupon de réduction à activer sur la page du produit. Ce hub vous permettra de rajouter un port HDMI 4K, 3 ports USB 3.0 et un lecteur de cartes SD et MicroSD à votre ordinateur via un simple USB-C. 


> Voir l'offre
308,95 €Disque dur externe Western Digital Elements Desktop USB 3.0 18 To à 308,95 € livré
Valable jusqu'au 21 Mai

Amazon Allemagne propose actuellement le disque dur externe Western Digital Elements Desktop USB 3.0 18 To à 302,51 €. Comptez 6,44 € pour la livraison en France soit un total de 308,95 € livré. On le trouve ailleurs à partir de 450 €. Ce disque dur dispose d'un grande capacité de stockage (18 To) et d'une connectique USB 3.0 qui vous offrira des transferts rapides. Il est compatible USB 2.0. Une très bonne affaire.

Notez que le disque dur n'est pas soudé et que vous pouvez le récupérer pour l'utiliser dans un ordinateur ou un NAS (il s'agit d'un disque dur CMR Hélium UltraStar DC HC 550).


> Voir l'offre

Sujets relatifs
FORMULE SI avec 2 conditions et dates
Formule avec conditions dates
Formule de comptage avec filtre
Calcul avec excel entre 2 dates sur plusiuers années
Formule de choix avec 3 conditions
verrouiller ou déverrouiller une cellule avec la formule SI
PB mise à jour des données avec une formule
vba : ds tableau, insérer ligne (non entière) avec reprise formule
formule excel avec 20^2
Formule SOMME.SI.ENS avec un numéro de semaine
Plus de sujets relatifs à Formule avec dates
 > Tous les forums > Forum Bureautique