× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Bureautique
 Formule avec feuille précédenteSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
boubinette
  Posté le 17/12/2010 @ 13:39 
Aller en bas de la page 
Petite astucienne

Bonjour à tous,

J'ai créé cette formule pour mes notes de frais en fonction des semaines (feuille 1 = semaine 1 et ainsi de suite)

=SOMME('1'!G4;J40;K43*13;K44*13;K45*13;K46*13;K47*13)

Mon problème est que cette formule ne s'applique qu'à la feuille 2. J'aurais voulu qu'il aille me chercher l'information dans la cellule G4 de la feuille précédente

Est-ce possible?

Merci de votre aide



Modifié par boubinette le 17/12/2010 13:42
Publicité
g
 Posté le 17/12/2010 à 15:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

=SOMME(Feuil1!G4;J40;K43*13;K44*13;K45*13;K46*13;K47*13)

Bonne suite.

boubinette
 Posté le 17/12/2010 à 15:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Merci, mais dans ma formule ce n'est pas feuil1 car j'ai renommé ma feuille en "1" uniquement.

Merci mais du coup ça ne résoud pas la question{#} car il va toujours chercher G4 dans la feuille 1 et non dans celle qui la précède

boubinette
 Posté le 17/12/2010 à 15:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Je pense que j'ai du mal m'exprimer dans ma question :

mon calcul est pour des kilomètres. En G4 le km de mon compteur.

Je veux qu'il additionne le comteur de la semaine précédente (donc en feuille précédente) avec les kilomètres de ma semaine en cours (la suite de l'addition).

ferrand
 Posté le 17/12/2010 à 20:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

=SOMME(INDIRECT(A2-1&"!G4");J40;SOMME(K43:K47)*13)

Salut

boubinette
 Posté le 18/12/2010 à 08:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Je viens d'essayer mais ça ne marche pas. Merci {#}

louvigne
 Posté le 18/12/2010 à 08:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

slt boubinette

envoie ton fichier je pense que tu auras la bonne reponse

http://cjoint.com/

ferrand
 Posté le 18/12/2010 à 09:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Feuil1 => semaine 1 => A2=1
Feuil2 => semaine 2 => A2=2 ...... INDIRECT(A2-1&"!G4")=1!G4
Feuil3 => semaine 3 => A2=3 ...... INDIRECT(A2-1&"!G4")=2!G4
....
Feuil53 => semaine 53 => A2=53 ...... INDIRECT(A2-1&"!G4")=52!G4

SOMME(K43*13;K44*13;K45*13;K46*13;K47*13)=K43*13+K44*13+K45*13+K46*13+K47*13=(K43+K44+K45+K46+K47)*13=SOMME(K43:K47)*13

g
 Posté le 18/12/2010 à 09:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

boubinette a écrit :

Je viens d'essayer mais ça ne marche pas. Merci {#}

Bonjour,

Si, cela fonctionne à condition de mettre le N° de la feuille en A2.

Bonne journée.

Publicité
galopin01
 Posté le 18/12/2010 à 11:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

bonjour,

une autre solution :

=INDIRECT(DROITE(CELLULE("nomfichier";A1);1)-1&"!G4")+SOMME(K43:K47)*13)+J40

Nota : cela semble aussi marcher avec "finename"

=INDIRECT(DROITE(CELLULE("filename";A1);1)-1&"!G4")+SOMME(K43:K47)*13)+J40

A+



Modifié par galopin01 le 18/12/2010 14:23
w36xb2w
 Posté le 18/12/2010 à 16:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Message original par boubinette

Bonjour à tous,

J'ai créé cette formule pour mes notes de frais en fonction des semaines (feuille 1 = semaine 1 et ainsi de suite)

=SOMME('1'!G4;J40;K43*13;K44*13;K45*13;K46*13;K47*13)

Mon problème est que cette formule ne s'applique qu'à la feuille 2. J'aurais voulu qu'il aille me chercher l'information dans la cellule G4 de la feuille précédente

Est-ce possible?

Merci de votre aide

Bonjour

Chez moi ta formule fonctionne parfaitement du moment que la feuille 1 soit crée au départ et non après avoir crée la formule n'aurais tu pas un interval entre '1' et !

=SOMME('1'!G4;J40;K43*13;K44*13;K45*13;K46*13;K47*13)

boubinette
 Posté le 18/12/2010 à 19:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Merci à vous tous{#}

J'ai essayé la solution de Ferrand et effectivement je ne savais ce qu'était A2!!!!!

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
169,95 €Ecran 24 pouces ViewSonic XG2405 (FullHD, 144Hz, IPS, 1ms, FreeSync/G-Sync) à 169,95 €
Valable jusqu'au 26 Octobre

Materiel.net fait une promotion l'écran 24 pouces ViewSonic XG2405 qui passe à 169,95 €On le trouve ailleurs autour de 200 €. Le ViewSonic XG2405 est un écran gamer 24 pouces conçu sur la base d'une dalle IPS. Idéal pour les joueurs à la recherche d'un écran efficace, il propose des caractéristiques techniques équilibrées : résolution Full HD, taux de rafraîchissement de 144 Hz, temps de réponse de 1 ms et compatibilité FreeSync / G-Sync. Précision, rapidité et fluidité sont réunis dans cet écran !


> Voir l'offre
50 € | 30 €6 Blu-Ray Disney pour 50 € / 3 Blu-Ray pour 30 €
Valable jusqu'au 26 Octobre

La Fnac propose actuellement l'offre Disney Mix vous permettant de profiter d'une réduction à l'achat de Blu-ray Disney parmi une vaste sélection (près de 90 titres). Le lot de 6 Blu-Ray Disney ne vous reviendra ainsi qu'à 50 € (8,33 € l'unité) tandis que le lot de 3 Blu-ray vous reviendra à 30 €. Ajoutez simplement les blu-ray qui vous intéressent à votre panier, la remise se fera automatiquement.


> Voir l'offre
89,07 €Onduleur APC BX 700 à 89,07 €
Valable jusqu'au 28 Octobre

Amazon fait une promotion sur le très bon onduleur APC BX 700U FR qui passe à 89,07 € livré gratuitement alors qu'on le trouve ailleurs à partir de 105 €. Cet onduleur assure une alimentation de secours sur batteries et une protection contre les surtensions pour votre ordinateur et vos périphériques le temps que vous fermiez vos documents et éteignez correctement votre materiel en cas de coupure de courant. Il offre une puissance de sortie de 390W/700 VA. Son port USB vous permettra de brancher votre NAS ou votre ordinateur dessus pour qu'il gère automatiquement l'arrêt en cas de coupure.


> Voir l'offre

Sujets relatifs
insertion de ligne avec formule ligne précédente
Formule de comptage avec filtre
Excel 2007 extraction feuille 1 dans feuille 2 avec mise en forme
Formule de choix avec 3 conditions
Afficher une feuille masquée mais avec mot de passe
verrouiller ou déverrouiller une cellule avec la formule SI
PB mise à jour des données avec une formule
vba : ds tableau, insérer ligne (non entière) avec reprise formule
Copier feuille 1 dans feuilles 2 et 3 avec mise à jour
formule excel avec 20^2
Plus de sujets relatifs à Formule avec feuille précédente
 > Tous les forums > Forum Bureautique