> Tous les forums > Forum Bureautique
 Formule de calcul pour questionnaireSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
romuald45
  Posté le 11/01/2014 @ 12:41 
Aller en bas de la page 
Petit astucien

Bonjour à tous,

Voici mon souci.

Je veux faire un questionnaire à choix multiples.

J'ai trouvé la formule de calcul qui me permet de calculer le résultat lorsque qu'une personne sélectionne une réponse.

Par contre je n'ai pas trouvé la formule qui permet d'additionner des réponses sur une même question.

Pas facile à expliquer ! et donc à comprendre ! je vous joins donc le fichier excel qui me permet de chercher.

Merci pour votre aide ! car les messages d'erreur me sortent des yeux !

Voici le document excel :

http://cjoint.com/?DAlmOHAFlI4

Publicité
poussebois
 Posté le 11/01/2014 à 15:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour ,

Je ne sais si cela va marcher, c'est la première que j'utilise cjoint.

Voici le lien : ici

Si ça marche, tu peux voir que j'ai simplifié la première formule et que la seconde est une réplique de la première.

Qu'il y ait un ou plusieurs choix, c'est la somme des lignes cochées qui apparaît.

si ça ne marche pas, je t'enverrai les formules.

@ +

ferrand
 Posté le 11/01/2014 à 15:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Suggestions :

- Pour la première formule (en G6) : =SI(NB.SI(B6:B8;"x")=1;RECHERCHEV("x";B6:C8;2;FAUX);SI(NB.SI(B6:B8;"x")>1;"Choix erroné";"Aucun choix"))

Ainsi, si l'utilisateur ne met aucun "x", cela affichera "Aucun choix", et s'il en met 2 ou plus, cela affichera "Choix erroné" (et s'il en met 1 comme prévu, cela affichera le choix).

- Pour le 2e cas : afficher le 1er choix en G14 :

=SI(NB.SI(B14:B17;"x")>2;"Choix erroné";SI(NB.SI(B14:B17;"x")>0;RECHERCHEV("x";B14:C17;2;FAUX);"Aucun choix"))

Si l'utilisateur met plus de 2 "x", cela affiche "Choix erroné", s'il n'en met aucun, cela affiche "Aucun choix", s'il en met 1 ou 2, cela affiche le (premier) choix de la liste.

Afficher le 2e choix en G15 :

=SI(NB.SI(B14:B17;"x")>2;"Choix erroné";SI(NB.SI(B14:B17;"x")>1;RECHERCHEV("x";DECALER(B14:C17;EQUIV("x";B14:B17;0);0);2;FAUX);SI(NB.SI(B14:B17;"x")>0;"Aucun 2e choix";"Aucun choix")))

Si l'utilisateur met plus de 2 "x", cela affiche "Choix erroné", s'il n'en a mis qu'un, cela affiche "Aucun 2e choix", s'il n'en a mis aucun, cela affiche "Aucun choix", s'il en a mis 2, cela affiche le 2e choix effectué dans la liste.

ferrand
 Posté le 11/01/2014 à 15:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

poussebois

La solution peut être intéressante (selon l'objectif recherché), mais tu aurais pu te contenter de l'utilisation de SOMMEPROD !

=SOMMEPROD((B6:B8="x")*C6:C8)

=SOMMEPROD((B14:B17="x")*C14:C17)

Cependant dans le 1er tableau, le choix "poire" va donner comme résultat 4 et le choix "pomme" + choix "banane" donnera aussi 4, d'où résultat ambigu. On aura de même divers résultats identiques pour des choix différents dans le second tableau.

Pour que cela marche, il faut alors que les numéros affectés à chacun des choix soient selon une suite : 1, 2, 4, 8, 16, 32, ... Ainsi, la somme de plusieurs choix donnera toujours un résultat différent pour chaque combinaison possible.

poussebois
 Posté le 11/01/2014 à 16:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

ferrand,

Tu as raison sur toute la ligne.

Ta formule est encore plus simple. J'étais parti de la formule initiale que j'avais transformée ensuite.

Ta seconde remarque aussi. Seule une progression géométrique selon les puissances de 2 lève toute ambiguïté.

Tes formules répondent exactement à la question posée !

romuald45
 Posté le 11/01/2014 à 19:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir Ferrand et Poussebois !

Merci pour vos réponses.

Ferrand tes formules me plaisent bien ! j'ai juste un souci c'est que dans une question (notamment) pour la seconde, j'aurais voulu que la personne donne 2 choix et que ces deux s'additionnent !

En tout cas merci encore ! rien n'est perdu !!!

Romuald

romuald45
 Posté le 11/01/2014 à 19:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Oups Ferrand !

Désolé je suis allé trop vite ! tu avais mis ensuite !!

Merci encore ! bonne soirée à tous !

Je mets en résolu !

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
37,73 €Carte mémoire microSDXC SanDisk 256 Go pour Nintendo Switch à 37,73 €
Valable jusqu'au 26 Juin

Amazon propose actuellement la carte mémoire microSDXC 256 Go pour Nintendo Switch à 37,73 € alors qu'on la trouve ailleurs à partir de 70 €. Cette carte mémoire offre des vitesses jusqu'à 100 Mo/s et vous permet d'ajouter 256 Go de stockage pour vos jeux sur la console Nintendo Switch. La livraison est gratuite.


> Voir l'offre
GratuitJeu PC Hell is Other Demons gratuit
Valable jusqu'au 24 Juin

Epic Game Store offre actuellement le jeu PC Hell is Other Demons. Hell is Other Demons est un jeu de tir d'action et de plateforme qui contient des éléments roguelite. Explorez un monde tentaculaire, conçu à la main, rempli de démons, de combats de boss délirants et d'une bande-son synthwave.


> Voir l'offre
26,99 €Hub USB 3.0 7 ports TP-Link UH700 à 26,99 €
Valable jusqu'au 27 Juin

Amazon fait une promotion sur le hub USB 3.0 7 ports TP-Link UH700 qui passe à 26,99 € au lieu de 39 €. L'UH700 ajoute 7 ports USB 3.0 à votre ordinateur rendant inutile les déconnexions de périphériques pour libérer un port. Le hub dispose d'une alimentation externe pour garantir assez de puissance pour une utilisation simultanée des ports (en transfert ou en recharge).


> Voir l'offre

Sujets relatifs
formule pour calcul entre dates
Formule de calcul pour les heures
Aide pour une formule de calcul dans un tableau
beson d'aide pour une formule
Aide pour formule excel 2011
Recherche formule pour les jours de la semaine
une formule pour fixer
Formule pour remplacer une valeur négative par la valeur 0
Formule pour éviter l'erreur #DIV/0
formule de calcul sur excel
Plus de sujets relatifs à Formule de calcul pour questionnaire
 > Tous les forums > Forum Bureautique