> Tous les forums > Forum Bureautique
 formule excelSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
rudika
  Posté le 16/08/2018 @ 12:13 
Aller en bas de la page 
Petite astucienne


Bonjour les Astucien(ne)s,

je souhaiterais la formule qui va bien pour dire ceci :

en A3, j'ai pour exemple : AT / DP / PA / PC / PCMI / AP

en M4, j'ai pour exemple : PC

EN N4, je voudrais que s'inscrive OUI ou NON si la valeur trouvée en M4 est contenue par A3. En l’occurrence, dans cet exemple, oui.

si je prends un autre exemple,

si en A3, j'ai : AT / DP / PA / PCMI / AP

en M4, j'ai : PC

EN N4, la réponse devra être NON

Merci par avance de vos réponses.

Cordialement.

Rudika

Publicité
dlxpat
 Posté le 16/08/2018 à 14:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour, mettre en N4 (ou ailleurs !!) la formule : =SI(NB.SI(($A$3;"*PC")>0;"oui";"non")

bon PM !

rudika
 Posté le 16/08/2018 à 15:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Bonjour dlxpat,

merci mais cela ne fonctionne pas. Et je dois dire que je ne comprends pas pourquoi vous dites "*PC". Est-ce que s'il est écrit en M4 DP, le résultat sera OUI ? Je ne comprends pas bien. Et comme ça ne fonctionne pas, je ne peux pas tester cette formule.

Dommage.

dlxpat
 Posté le 16/08/2018 à 15:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re-bonjour, ci joint fichier qui marche très bien chez moi !

les astérisques empêchent les risques d'erreur entre PC et PCMI par exemple

https://www.cjoint.com/c/HHqnZ0knrXv

dlxpat
 Posté le 16/08/2018 à 15:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

ou bien cette formule qui évite d'avoir à entrer la valeur de A4

=SI(ESTERREUR(CHERCHE(A4;A3));"NON";"OUI")

rudika
 Posté le 16/08/2018 à 16:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Je retiens la seconde solution qui fonctionne très bien. Merci beaucoup. je vais pouvoir la tester. j'ai environ 7000 lignes à traiter.

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Aucun sujet pertinent lié trouvé
 > Tous les forums > Forum Bureautique