> Tous les forums > Forum Bureautique
 Formule ExcelSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Claude3
  Posté le 01/03/2019 @ 11:20 
Aller en bas de la page 
Petit astucien

Bonjour à tous
Je travaille avec Excel.
Voici mon problème. Je cherche une formule qui arrondit en-dessous un nombre (avec la fonction ARRONDI.INF) en ne gardant qu'un chiffre significatif.
Exemple. 6,32 devient 6
45,14 devient 40
199 devient 100

J'utilise la fonction ARRONDI.INF mais je dois à chaque fois changer le deuxième argument selon la "taille" du nombre.
Une idée serait la bienvenue. Merci d'avance.

[Configuration automatique à compléter]
Windows 10
Firefox 65.0

Publicité
poussebois
 Posté le 01/03/2019 à 13:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour ,

J'ai 2 solutions, mais qui ne me satisfont pas ! Si ton nombre est en A1 :

  1. =SI(A1<10;ARRONDI.INF(A1;0);SI(A1<100;ARRONDI.INF(A1;-1);SI(A1<1000;ARRONDI.INF(A1;-2))))
  2. =SI(A1<10;GAUCHE(A1;1);SI(A1<100;GAUCHE(A1;1)*10;SI(A1<1000;GAUCHE(A1;1)*100)))

Ça ne me satisfait pas parce que c'est lourd, bestial et ne fonctionne que pour les nombres < 1000.

Si >= 1000, il faut rallonger la formule et si >= 10000, ... jusqu'où ?

Ne fonctionne pas non plus pour les nombre <0.

@ +

Claude3
 Posté le 01/03/2019 à 13:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

bonjour poussebois

merci d'être là

je me demandais s'il y a une façon simple de compter le nombre de chiffres de la partie entière d'un nombre.

Exemple 125,5 donne 3

4,5 donne 1

parce que le deuxième argument de ARRONDI.INF dépend de ce nombre.

poussebois
 Posté le 01/03/2019 à 13:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

,

Moi aussi, j'ai cherché ça (sans utiliser de macro), mais en vain. jusqu'à présent.

Un autre astucien, peut-être ...

Claude3
 Posté le 01/03/2019 à 14:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

J'ai enfin trouvé une solution avec les fonctions TRONQUE et NBCAR.

Si mon nombre est dans A2, une formule qui marche est :

=ARRONDI.INF(A2,-NBCAR(TRONQUE(A2))+1)

poussebois
 Posté le 01/03/2019 à 14:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

,

Je vieillis car ce n'était pas bien compliqué .

Bravo à toi .

Bonne fin de journée

Claude3
 Posté le 01/03/2019 à 14:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

merci poussebois pour ta participation

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Aucun sujet pertinent lié trouvé
 > Tous les forums > Forum Bureautique