> Tous les forums > Forum Bureautique
 formule excel 2007Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
ninda
  Posté le 20/04/2011 @ 11:21 
Aller en bas de la page 
Nouvel astucien

Bonjour,

j'ai une petit soucis avec une formule excel :

Le sujet est un dépanneur gagne entre 18 h et 22 h, 50 euros au prorata par heure pour le dépannage et 100 euros au prorata pas heure entre 22 h et 6 h du matin :

a b c d e f

Nom dépanneur heure debut heure fin 18 h 22 h 22 h 6 h total 21 0 30 1 2,3 280 18 22 4 200

En fait j'ai une formule suivante =SI(D2<=4;D2*50)+SI(E2<=8;E2*100) qui marche super

Je voudrais une formule qui marche avec mes colonnes b et c pour pouvoir supprimer les colonnes d et e mais j'arrive pas a trouver une formule qui marche

merci de votre aide

Publicité
ninda
 Posté le 20/04/2011 à 11:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

a b c d e f

Nom dépanneur heure debut heure fin 18 h 22 h 22 h 6 h total

21 0 30 1 2,3 280

pardon j'ai raté le tableau

qmike549
 Posté le 20/04/2011 à 12:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

bonjour

Pour une meilleur compréhension de ton problème

essais de poster un exemple de fichier sur :

http://www.cijoint.fr/

ninda
 Posté le 20/04/2011 à 14:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien
ferrand
 Posté le 20/04/2011 à 15:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Si les heures saisies de début et de fin sont au format horaire d'Excel.

En considérant que la "journée" de travail débute à 06:00 pour se terminer à 06:00 le lendemain (nb: la plage 06:00-18:00 étant neutralisée, on considèrera que le début est postérieur à 06:00 [pour éviter qu'en notant début=06:00 et fin=06:00, on ne prenne en compte un écart de 24 h qui validerait la totalité de la plage tarifée]).

En ce qui concerne la première plage tarifée (18:00 - 22:00), les valeurs tant de B2 que de C2 doivent être ramenée à cette plage, soit : si >06:00 ET <18:00 => 18:00 ; si >22:00 OU <=06:00 => 22:00 ; [leur valeur si >=18:00 et <=22:00]. Si C2>B2, on applique le tarif à (C2-B2)*24 [les heures étant au format horaire].

Pour la deuxième plage tarifée (22:00 - 06:00), les valeurs doivent aussi être ramenée dans la plage, soit : si >06:00 ET <22:00 => 22:00 ; si <=06:00 => la valeur + 1 (+24 heures, puisqu'on sera le lendemain) ; la valeur si >=22:00. Si C2>B2, on applique le tarif à (C2-B2)*24 (comme pour l'autre plage).

Ces considérations devraient aboutir à la formule suivante (si je n'ai rien loupé) :

=SI(SI(OU(C2>22/24;C2<=6/24);22/24;SI(ET(C2<18/24;C2>6/24);18/24;C2))>SI(OU(B2>22/24;B2<=6/24);22/24;SI(ET(B2<18/24;B2>6/24);18/24;B2));SI(OU(C2>22/24;C2<=6/24);22/24;SI(ET(C2<18/24;C2>6/24);18/24;C2))-SI(OU(B2>22/24;B2<=6/24);22/24;SI(ET(B2<18/24;B2>6/24);18/24;B2));0)*24*50+SI(SI(ET(C2>6/24;C2<22/24);22/24;SI(C2<=6/24;C2+1;C2))>SI(ET(B2>6/24;B2<22/24);22/24;SI(B2<=6/24;B2+1;B2));SI(ET(C2>6/24;C2<22/24);22/24;SI(C2<=6/24;C2+1;C2))-SI(ET(B2>6/24;B2<22/24);22/24;SI(B2<=6/24;B2+1;B2));0)*24*100

Bon courage

nb: La scinder offrant plus de visibilité, on pourrait mettre:

en D2: =SI(OU(C2>22/24;C2<=6/24);22/24;SI(ET(C2<18/24;C2>6/24);18/24;C2))-SI(OU(B2>22/24;B2<=6/24);22/24;SI(ET(B2<18/24;B2>6/24);18/24;B2))

en E2: =SI(ET(C2>6/24;C2<22/24);22/24;SI(C2<=6/24;C2+1;C2))-SI(ET(B2>6/24;B2<22/24);22/24;SI(B2<=6/24;B2+1;B2))

en F2: =SI(D2>0;D2*24*50;0)+SI(E2>0;E2*24*100;0)

ninda
 Posté le 20/04/2011 à 16:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

j'ai opté pour la formule scinder car je la comprends

merci beaucoup ferrand

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
199,99 €Pack de 2 disques durs Seagate NAS Iron Wolf 4 To à 199,99 €
Valable jusqu'au 18 Avril

Cdiscount propose le pack de 2 disques durs Seagate IronWolf 4 To à 199,99 €. Ces disques durs 3.5 pouces SATA III sont adaptés aux NAS et ordinateurs qui fonctionnent 24h/24. On les trouve ailleurs autour de 120 € l'unité. 


> Voir l'offre
54,36 €Montre connectée Xiaomi MI Watch Lite à 54,36 €
Valable jusqu'au 18 Avril

Amazon fait une une belle promotion sur la toute nouvelle montre connectée Xiaomi MI Watch Lite qui passe à à 54,36 € au lieu de 69 €. La livraison est gratuite. 

Elle dispose d'écran couleur de 1,4 pouce affichant une définition de 320 x 320 pixels et ne pèse que 35 g. Cinq cadrans sont proposés par défaut, pour varier le style en fonction de votre envie. Du côté des fonctionnalités, vous trouverez le suivi du sommeil, l'analyse de la fréquence cardiaque, des exercices de respiration et un GPS précis capable d'indiquer l’altitude et la pression atmosphérique de votre environnement. 

Elle fait également office de coach sportif en traquant le nombre de pas, la distance parcourue ou encore les calories brûlées et reconnait jusqu'à 11 activités sportives : la course en extérieur, le tapis roulant, le cyclisme extérieur et intérieur, le trekking, la natation, le yoga, etc. D'autres informations sont disponibles sur la Mi Watch Lite, comme l’affichage des notifications avec les emojis, la météo ou encore l'alarme de votre réveil. Il est également possible de prendre des appels entrants, contrôler sa musique et rechercher son téléphone.

Côté autonomie, comptez 9 jours en utilisation standard et 10 heures en mode sport avec le GPS activé en continu. 


> Voir l'offre
259 €PC Ankermann (Intel Pentium Dual Core, 8Go RAM, SSD 480Go, Win 10 + Office 2019) à 259 € livré
Valable jusqu'au 18 Avril

Amazon fait une promotion sur l'ordinateur de bureau Ankermann Silent PC Work à 259 € livré. Le PC est équipé d'un processeur Intel Pentium dual core à 2.7 GHz, de 8 Go de RAM, d'un SSD de 480 Go, d'un lecteur DVD, d'un lecteur de carte mémoires et tourne sous Windows 10 Pro 64 bits. Microsoft Office 2019 Pro en français est également fourni.

Ajoutez un écran (comme cet écran 24 pouces ViewSonic VA2418 (FullHD, IPS, 75 Hz) à 99,99 €) et un pack clavier souris (comme ce pack filaire Logitech MK120 à 17,99 €) et vous avez un PC complet à l'aise en bureautique et Internet. Garantie 2 ans.


> Voir l'offre

Sujets relatifs
Formule excel 2007
Formule Excel 2007
excel 2007 formule
formule excel 2007 ou autres
formule excel 2007
Excel 2007 formule somme dont 2 chiffres ds cellul
Créer une formule de calcul avec excel 2007
Formule pour un tableau excel 2007
HELP => Formule conditionnelle dans Excel 2007
Excel 2007 résultat formule dans une autre cellule
Plus de sujets relatifs à formule excel 2007
 > Tous les forums > Forum Bureautique