× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Bureautique
 Formule excel permettant de comparer 2 listes
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
magiiiik
  Posté le 18/02/2010 @ 16:29 
Aller en bas de la page 
Nouvel astucien


Bonjour, j'ai besoin de votre aide pour une formule sur excel.

en fait la formule est simple à dire mais dur à trouver lol

En fait j'aimerai trouvé via une formule le nombre de bonne reponse d'un éléve par rapport au résultat.


ex :
Eleve 1 Résultat

Question 1 a a
Question 2 B B
Question 3 B a
Question 4 B a


Donc la, j'aimerai trouver une formule permettant de me mettre à coté de l'eleve 1
le nombre de bonne reponse qu'il à eu ( en pourcentage si possible lol
donc ici 50%


Merci d'avance pour votre aide

Adrien

Publicité
1000cbr
 Posté le 18/02/2010 à 18:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Message original par magiiiik


Bonjour, j'ai besoin de votre aide pour une formule sur excel.

en fait la formule est simple à dire mais dur à trouver lol

En fait j'aimerai trouvé via une formule le nombre de bonne reponse d'un éléve par rapport au résultat.


ex :
Eleve 1 Résultat

Question 1 a a
Question 2 B B
Question 3 B a
Question 4 B a


Donc la, j'aimerai trouver une formule permettant de me mettre à coté de l'eleve 1
le nombre de bonne reponse qu'il à eu ( en pourcentage si possible lol
donc ici 50%


Merci d'avance pour votre aide

Adrien

Salut

Tu peux t'en sortir avec des SOMMESI().

Tu affectes une valeur 1 a chaque bonne réponse par élève.

Tu détermines une table par élève qui d'ailleurs pourra te servir à entrer les noms des élèves avec un ascenseur.

Ensuite tu fais un SOMMESI() pour chacun de tes élèves sur la zone dans laquelle tu as mis un 1.

Ceci dit Excel est tellement puissant qu'il y a peut-être une formule existante dans les statistiques qui serait plus élégante mais je ne vois pas.



Modifié par 1000cbr le 18/02/2010 18:27
magiiiik
 Posté le 18/02/2010 à 21:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

OUi merci , mais la j'ai bien un exemple j'ai beaucoup plus de question donc somme si sa risque de faire juste pour ce que je recherche.

merci en entendant d autres propositions

Adrien

sam²
 Posté le 18/02/2010 à 21:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Slt,

Sans trop compliquer, tu rajoutes une colone et tu y mets la formule : "=SI(B4=C4;1;0)"

En fin de tableau, tu fais le calcule : "=SOMME(D4:D11)/NB(D4:D11)*100" où D4:D11 est la plage calculer précédement.

magiiiik
 Posté le 19/02/2010 à 12:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Oui merci pour la premiere formule ^^

Par contre pour la deuxieme j'ai des questions ou l 'eleve n'a pas repondu, car la question était facultative donc elle ne doit pas influencé son résultat, et donc votre deuxieme formule considere donc cette non reponse comme fausse donc sa influence sur le taux de bonne réponse juste de cette éleve.

C'est assez compliqué oui surtout qu'il y à beaucoup d'eleves et beaucoup de questions

Par contre les questions ont une liste deroulante ; " rien" si l 'eleve n' a pas choisi cette question

"a"

"b"

ou "C"

j'espere que vous comprenez mon probleme .

Je vous remercie pour votre aide

sam²
 Posté le 19/02/2010 à 21:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Slt,

Forcément, tu n'avais pas préciser qu'il y avait des questions facultatives... Sa commence doucement à ce compliquer, le mieux pour continuer le travail serait de mettre un excemple de fichier en ligne, cela pourra permettre de mieux comprendre...

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
28,99 €Carte mémoire microSDXC UHS-I SanDisk Ultra 200 Go à 28,99 €
Valable jusqu'au 12 Août

Amazon fait une promotion sur la carte mémoire microSDHC UHS-I SanDisk Ultra 200 Go qui passe à 28,99 € livrée gratuitement. On la trouve ailleurs à partir de 40 €. Cette carte mémoire offre des vitesses jusqu'à 90 Mo/s.


> Voir l'offre
19,71 €Prise connectée Wi-Fi TP-Link HS100 à 19,71 €
Valable jusqu'au 11 Août

Amazon fait une promotion sur la prise intelligente Wi-Fi TP-Link HS100 qui passe à 19,71 € alors qu'on la trouve habituellement autour de 35 €. Cette prise peut être contrôlée à distance en utilisant l'app gratuite KASA sur votre smartphone (iOS ou Android). Vous pouvez créer des planifications horaires pour allumer ou éteindre automatiquement et quand vous le souhaitez, l'appareil qui y est branché. Pour en savoir plus, n'hésitez pas à lire notre dossier pratique Contrôler une prise électrique à distance.


> Voir l'offre
44,99 €Clavier Logitech G213 Prodigy RVB à 44,99 €
Valable jusqu'au 09 Août

Boulanger fait une promotion sur le clavier Logitech G213 Prodigy RVB qui passe à 44,99 € livré gratuitement alors qu'on le trouve ailleurs à partir de 69 €. Ce clavier RVB à membranes est conçu aussi bien pour le jeu que pour l'activité professionnelle, résiste aux liquides, aux miettes et à la saleté pour un nettoyage aisé.


> Voir l'offre

Sujets relatifs
Comparer 2 listes
macro pour comparer 2 listes
Formule excel 2007
formule excel
Formule excel
Report résultat formule Excel
Formule EXCEL
Excel 7 aide sur formule svp
Formule Excel 2007
Formule Excel
Plus de sujets relatifs à Formule excel permettant de comparer 2 listes
 > Tous les forums > Forum Bureautique