× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Bureautique
 Formule pour éviter l'erreur #DIV/0Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
delta70
  Posté le 26/08/2013 @ 18:46 
Aller en bas de la page 
Petit astucien

Bonjour,
Pour calculer la moyenne générale des 3 trimestres, j’utilise la formule MOYENNE. Mais cette formule affiche ERREUR (#DIV/0) quand les cellules contenant les valeurs des 3 trim sont vides, Alors j'ai besoin d'une autre formule (si cela est possible) qui donne la valeur 0 au-lieu (#DIV/0) sans donner 0 a chaque trim,
Merci pour vos aides.
Cordialement



Modifié par delta70 le 29/08/2013 15:02
Publicité
DjiDji59430
 Posté le 26/08/2013 à 19:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

tout est dit dans ta question !

en D1 =SI(ESTERREUR(MOYENNE(A1:C1));"0";MOYENNE(A1:C1))

ou

=SI(ET(A2=0;B2=0;C2=0);0;MOYENNE(A2:C2))

ou

=SI(SOMME(A3:C3)=0;0;MOYENNE(A3:C3))



Modifié par DjiDji59430 le 26/08/2013 19:32
delta70
 Posté le 26/08/2013 à 19:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
DjiDji59430 a écrit :

tout est dit dans ta question !

en D1 =SI(ESTERREUR(MOYENNE(A1:C1));"0";MOYENNE(A1:C1))

ou

=SI(ET(A2=0;B2=0;C2=0);0;MOYENNE(A2:C2))

ou

=SI(SOMME(A3:C3)=0;0;MOYENNE(A3:C3))

ça marche tès bien. Merci DJIDJI

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
GratuitJeu PC Borderlands : The Handsome Collection gratuit
Valable jusqu'au 04 Juin

Epic Game Store offre actuellement l'excellent jeu PC Borderlands : The Handsome Collection. Dézinguez à tours de bras en explorant le monde chaotique de Pandore dans BORDERLANDS 2 et la folie lunaire de BORDERLANDS: THE PRE-SEQUEL dans BORDERLANDS: THE HANDSOME COLLECTION.


> Voir l'offre
60 €Abonnement un an de Deezer Premium + carte fnac+ à 60 €
Valable jusqu'au 01 Juin

Fnac fait une promotion sur l'abonnement un an de Deezer Premium qui passe à 60 € au lieu de 99 €. Deezer Premium vous permet d'écouter toute votre musique en illimité, sans publicité, même sans réseau. La carte Fnac+ vous est également offerte (livraison gratuite et illimitée, caisse prioritaire en magasin, ....)


> Voir l'offre
89,99 €Disque dur externe portable Seagate Expansion 4 To USB 3.0 à 89,99 €
Valable jusqu'au 01 Juin

Boulanger fait une promotion sur le disque dur externe portable Seagate Expansion d'une capacité de 4 To à 89,99 € alors qu'on le trouve ailleurs à partir de 120 €. Ce disque dur externe portable au format 2,5 pouces dispose d'une interface USB 3.0 compatible USB 2.0. Une excellente affaire pour ce disque dur qui offre des débits de 115 Mo/s. Il n'est pas soudé et est donc démontable si vous souhaitez le réutiliser ailleurs (console, NAS, PC).


> Voir l'offre

Sujets relatifs
formule pour éviter les doublons dans une colonne
Eviter message d'erreur si textbox vide
Excell 2007: erreur dans formule
beson d'aide pour une formule
Aide pour formule excel 2011
Formule de calcul pour questionnaire
Recherche formule pour les jours de la semaine
une formule pour fixer
Formule pour remplacer une valeur négative par la valeur 0
qu ajouter dans ma formule pour un chiffre negatif = 0 ??
Plus de sujets relatifs à Formule pour éviter l''erreur #DIV/0
 > Tous les forums > Forum Bureautique