> Tous les forums > Forum Windows 10
 Formule somme avec des heuresSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Zia7
  Posté le 18/01/2021 @ 14:29 
Aller en bas de la page 
Petite astucienne

Bonjour

J'essai de créer une formule qui additionnera les heures travaillées dans une journée. Si la somme est supérieure à 0, elle doit soustraire 0.5h. Le problème est que si les cases restent vides, la formule soustrait tout de même 0.5h, tel qu'indiqué dans mon tableau. Comment faire pour que si les cases D6 et E6 sont vides, que le calcul reste vide également?

Merci de votre aide! :)

[Configuration automatique à compléter]
Windows 10
Autre 5.0

Publicité
Anonyme
 Posté le 18/01/2021 à 14:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

bonjour

Et comme cela ?:

=SI(F6="";"";E6-D6-0,5)

Zia7
 Posté le 18/01/2021 à 14:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Bonjour!

Non malheureusement ça n'a pas fonctionné, mais j'ai réussi à trouver grâce à votre formule SI! Moi j'essayais SOMME.SI. Voici le résultat

=SI((E6-D6+(E6<D6))*24=0;"";(E6-D6+(E6<D6))*24-0,5)

MERCI DE VOTRE AIDE!

poussebois
 Posté le 18/01/2021 à 16:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Bonjour ,

Je te propose une autre formule :

En F6 : =SI(OU(D6<>"";E6<>"");24*(E6-D6)-0,5;"")

@ +

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
64,99 €Microphone USB Razer Seiren X à 64,99 €
Valable jusqu'au 18 Octobre

Amazon fait une promotion sur le microphone USB Razer Seiren X qui passe à 64,99 € au lieu de 99 € ailleurs. Au moyen d'un mode de captation supercardioïde, le son est enregistré avec un angle plus petit. Le bruit de fond indésirable est alors supprimé, ce qui permet à votre audience de vous entendre clairement et de ne jamais rater un seul de vos messages. 


> Voir l'offre
19,99 €Fire TV Stick Lite à 19,99 €
Valable jusqu'au 18 Octobre

Amazon fait une promotion sur la clé HDMI Amazon Fire TV Stick Lite qui passe à 19,99 € au lieu de 29,99 €. Cette clé HDMI à brancher sur votre TV possède un processeur quadricoeur, 1 Go de RAM et 8 Go d'espace de stockage, le WiFi et le bluetooth. Avec elle, vous allez pouvoir voir facilement Prime Video, Netflix, Disney+, YouTube, Spotify sur votre TV Full HD. Cette nouvelle version 2020 est compatible Alexa. Une télécommande est fournie. Notez qu'il est possible de coupler un casque bluetooth avec le Fire TV Stick afin de regarder tranquillement la TV sans déranger vos proches.


> Voir l'offre
29,99 €Switch Gigabit Netgear GS308E 8 ports administrables à 29,99 €
Valable jusqu'au 18 Octobre

Amazon fait une promotion sur le switch Gigabit Netgear GS308E 8 ports administrables qui passe à 29,99 € alors qu'on le trouve ailleurs à partir de 38 €. Ce switch est manageable : vous pouvez créer des sous réseaux isolés VLAN, limiter la bande passante par port, etc. La livraison est gratuite.


> Voir l'offre

Sujets relatifs
Aucun sujet pertinent lié trouvé
 > Tous les forums > Forum Windows 10