> Tous les forums > Forum Windows 10
 Formule somme avec des heuresSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Zia7
  Posté le 18/01/2021 @ 14:29 
Aller en bas de la page 
Petite astucienne

Bonjour

J'essai de créer une formule qui additionnera les heures travaillées dans une journée. Si la somme est supérieure à 0, elle doit soustraire 0.5h. Le problème est que si les cases restent vides, la formule soustrait tout de même 0.5h, tel qu'indiqué dans mon tableau. Comment faire pour que si les cases D6 et E6 sont vides, que le calcul reste vide également?

Merci de votre aide! :)

[Configuration automatique à compléter]
Windows 10
Autre 5.0

Publicité
Anonyme
 Posté le 18/01/2021 à 14:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

bonjour

Et comme cela ?:

=SI(F6="";"";E6-D6-0,5)

Zia7
 Posté le 18/01/2021 à 14:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Bonjour!

Non malheureusement ça n'a pas fonctionné, mais j'ai réussi à trouver grâce à votre formule SI! Moi j'essayais SOMME.SI. Voici le résultat

=SI((E6-D6+(E6<D6))*24=0;"";(E6-D6+(E6<D6))*24-0,5)

MERCI DE VOTRE AIDE!

poussebois
 Posté le 18/01/2021 à 16:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Bonjour ,

Je te propose une autre formule :

En F6 : =SI(OU(D6<>"";E6<>"");24*(E6-D6)-0,5;"")

@ +

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
Ecran 22 pouces AOC E2270SWHN (FullHD, sans contour, 75 Hz) à 79,99 €
79,99 € 99,99 € -20% @Cdiscount
Micro clé USB 3.1 Sandisk Ultra Fit 256 Go à 27,64 € livrée
27,64 € 42 € -34% @Amazon Allemagne
Ecouteurs intra-auriculaires sans fil Bluetooth Jabra Elite 3 à 44,03 € livrés
44,03 € 79,99 € -45% @Amazon Allemagne
Chaussures PUMA Smash V2 mixte à 23,95 €
23,95 € 49,95 € -52% @Amazon
Ecran 27 pouces AOC 27B2H (FullHD, IPS, 75 Hz, sans contour) à 114,99 €
114,99 € 150 € -23% @Cdiscount
Enceinte bluetooth Anker Soundcore Motion Boom à 74,99 €
74,99 € 99,99 € -25% @Amazon
Jean femme Only Onlroyal High Waist Skinny à 10,59 €
10,59 € 30 € -65% @Amazon
Kit de 16 Go (2 x 8 Go) de mémoire DDR4 Kingston Fury Beast 3200 MHz à 51,31 €
51,31 € 70 € -27% @Amazon
-20% sur une sélection d'articles reconditionnés Amazon
-20% @Amazon
Club Dorothée : Les 35 ans (5 CD) à 15,04 €
15,04 € 18,99 € -21% @Amazon

Sujets relatifs
Aucun sujet pertinent lié trouvé
 > Tous les forums > Forum Windows 10