> Tous les forums > Forum Windows Vista
 Foxmail par defaut
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
le_duq
  Posté le 11/08/2007 @ 01:40 
Aller en bas de la page 
Astucien

hello

depuis des années, j'utilise foxmail ...

je suis passé depuis peut sous vista, j'ai installé foxmail, mais le probleme est que je n'arrive pas à faire comprendre a Vista que je souhaite qu'il soit utilisé comme client mail par defaut

quand je vais dans "Programmes par defaut", Foxmail n'apparait pas dans la liste des programmes

comment faire ?

merci

Publicité
ML56
 Posté le 11/08/2007 à 02:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir le_duq,

Quand tu as ouvert pour la première fois Foxmail après l'avoir installé dans Vista, il ne t'a pas demandé si tu voulais qu'il soit le client-mail par défaut ? Sinon, tu dois pouvoir trouver et cocher cette option dans les préférences générales du programme.

A+

le_duq
 Posté le 11/08/2007 à 02:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

il me l'a demandé, j'ai répondu que oui, mais rien n'y fait

quand je clique sur Démarrer / Programmes par défaut

il n'apparait pas dans la liste des programmes

du coup quand je clique, par exemple, sur un lien Mailto, ça m'ouvre Windows Mail

ML56
 Posté le 11/08/2007 à 03:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re,

Et dans les préférences, onglet Général, la case "Vérifier si Foxmail est le client-mail par défaut" est bien cochée ? Il faut peut-être indiquer à Windows Mail de ne pas être la messagerie par défaut avant, dans Outils/Options/Général, tu vérifies bien tout en bas que c'est bien marqué "Cette application n'est PAS le gestionnaire de courrier par défaut".

A+

le_duq
 Posté le 11/08/2007 à 09:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

hello ML56

merci pour ton aide

j'ai bien verifié, dans foxmail, preferences "verifier si foxmail et le client mail par defaut" est bien cochée.

dans windows mail, outils, options il est ecrit "cette application n'est PAS le gestionnaire de courrier par defaut".

je tourne en rond ... il doit y avoir, dans la base de registre, une clé pour ça, mais je ne sais ou

ML56
 Posté le 11/08/2007 à 13:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re,

Bigre, l'affaire se corse ! Je vais essayer de voir si, effectivement, on peut changer ça en passant par la BdR...

A+

ML56
 Posté le 11/08/2007 à 13:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re,

Au fait, tu as installé quelle version (la dernière est apparemment la 6 beta 5) ? Car voici ce que j'ai trouvé dans la FAQ de Foxmail (en français) :

Q: Quand je clique sur une URL mailto:moi@home.fr?subject=toto Foxmail ne s'ouvre pas...
R: C'est aussi un bug récurent des versions 4.1 et antérieures :Il est dû au fait que Foxmail ne sait pas retrouver son chemin, qu'il inscrit au format "noms longs" de Windows suivi de %1 dans la base de registre en HKEY_CLASSES_ROOT\mailto\shell\open\command, lorsque l'utilisateur décide d'en faire le client mail par défaut.
Pour remédier au problème, corriger la clé pré-citée avec un nom court DOS suivi de %1
par exemple : C:\PROGRA~1\FOXMAIL\FOXMAIL.EXE %1 et empécher Foxmail de devenir "client mail par défaut" de lui même...
ou utiliser le patch
foxmailto.exe qui fera cette manipulation automatiquement...
Cette manipulation devrait assurer le support des liens "
mailto:" dans toute application Windows, tous navigateurs compris (sauf pour Mozilla/Netscape installés avec leur propre client de mail/news).
Pour Opera, on peut toutefois forcer l'utilisation d'un client mail spécifique en indiquant dans les préférence/courrier électronique d'Opera un chemin (là aussi en nom court DOS) du type C:\Progra~1\FoxMail\Foxmail.exe
mailto:%
Ce bug est corrigé sur la version 4.2 ...

Peut-être s'agit-il de ce bug...

A+



Modifié par ML56 le 11/08/2007 14:11
ML56
 Posté le 11/08/2007 à 13:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re,

Peux-tu vérifier aussi dans "Panneau de configuration"/"Réseau et Internet"/"Options Internet"/onglet "Programmes"/"Définir les programmes" (en bas)/"Définir les paramètres par défaut de l'accès aux programmes de l'ordinateur" (encore en bas)/"Personalisée" (ouvre la double flèche à droite)/"Choisir un programme de messagerie par défaut :" si le nom de Foxmail apparaît et si il est bien choisi ? Si oui, la case "Activer l'accès à ce programme" en face est-elle cochée ? Sinon, si c'est Windows Mail qui est choisi, il faut certainement modifier cela.

A+
ML56
 Posté le 11/08/2007 à 13:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re,

Sinon, tu n'es hélas pas le seul à avoir ce problème (lire ici), c'est apparemment un bug de Foxmail avec Vista

A+

Publicité
ML56
 Posté le 11/08/2007 à 14:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re,

Bon, ça se recoupe, lorsqu'un client de messagerie n'apparait pas dans la liste par défaut, on peut le rajouter manuellement dans la BdR comme ceci :

Démarrer>Exécuter>Tape Regedit>OK

Déroule les clés HKEY CLASSES ROOT, mailto, shell, open, command.

Double clique sur la clé nommée "par défaut". Tape alors, entre guillemets, le chemin d'accès complet de ton logiciel de messagerie, suivi de %1. Valide par OK.

Redémarre.

Le chemin par défaut devrait donc être un truc du genre : "C:\Program Files\Foxmail\Foxmail.exe" %1 (à vérifier bien sûr là où tu l'as installé).

Fais une sauvegarde de la ligne originale de la BdR avant, au cas où...

A+



Modifié par ML56 le 11/08/2007 14:07
ML56
 Posté le 11/08/2007 à 14:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re,

Sinon, il y a peut-être l'explication sur le site officiel : http://fox.foxmail.com.cn/

Mais bon... C'est du chinois, pour moi

A+

ML56
 Posté le 11/08/2007 à 14:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re,

Au pire (et même au mieux), et pour ne pas trop te dépayser, tu pourras de tourner vers DreamMail, entièrement compatible Vista, et qui est, en fait, un Foxmail amélioré puisqu'il reprend son code en y ajoutant plus de fonctionnalités et une interface personnalisable plus conviviale. Il a l'air bien sympa.

Quand à moi, je retourne à mes transferts manuels d'e-mails Windows Mail vers Thunderbird, quelle galère...

A+



Modifié par ML56 le 11/08/2007 14:45
le_duq
 Posté le 12/08/2007 à 00:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

hello ML56

dis moi tu es super productif pour un samedi ;-)

en tous cas, merci pour ton aide

alors pour resumer

j'ai la derniere version de foxmail, ce n'est donc pas le bug de la 4.1

dans le choix des programme par defaut de IE, ce n'est pas ecrit en toute lettre Foxmail, juste client mail actuel

pour la cle dans la BDR, je viens d'aller voir, tout est deja ecrit comme il se doit

four ce qui est du site officiel, je ne comprend pas non plus le chinois

quand a dreammail, j'ai deja essayé, mais je n'arrive pas a me detacher de foxmail

et enfin pour le lien que tu me donne pour aller voir ce qui est dit de ce Bug foxmail/vista, il ne fonctionne pas, en tout cas pour l'heure

tampis, je vais rester avec ce bug, tout en continuant a essayer de le resoudre

si je decouvre une solution, j'en ferais part ici

encore merci pour ton aide

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
FOXMAIL
Restaurer depuis une image par défaut de l'usine vista
impossible de mettre l'imprimante en "imprimante par defaut"
internet explore - moteur de recherche par défaut
FOXMAIL,mails n'arrivent pas!
Explorer n'est plus dans mes programmes par défaut
recois pas mes mails sur foxmail!via zimbra
retirer veille prolongee par defaut
modifier une police étrangère par défaut
Imprimante par défaut
Plus de sujets relatifs à Foxmail par defaut
 > Tous les forums > Forum Windows Vista