× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum des Webmasters
 gros problème d'affichage de mon site sous firefoxSujet résolu
Ajouter un message à la discussion
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]
pommekiwi
  Posté le 03/04/2011 @ 09:50 
Aller en bas de la page 
Petite astucienne

Bonjour,

j'ai crée un site récement et j'ai un gros problème sous firefox.

Sur les pages des catégories, quand la liste des produits doit s'afficher, il en affiche 5 ou 6 puis plus rien(sur 65 produits), le dernier n'ayant même pas les boutons "voir détails" et "ajouter au panier". et rien pour passer à la page suivante.

sous IE pas de souci.

mon site www.le-coffre-a-bijoux.com

avez-vous une petite idée de ce qui se passe, et comment le résoudre?

Bonne journée

MJ



Modifié par pommekiwi le 03/04/2011 09:53
Publicité
Dreamer
 Posté le 03/04/2011 à 10:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Salut

Je suis sou FF4 et je ne vois rien de particulier dans l'affichage des catégories ni des produits ..

Il y a 8 produits par page et c'est complet ( description, photo, Voir produit, Ajouter au panier )!!

Si tu as un lien de page ...

Belle boutique Prestachop !!

kalinka
 Posté le 03/04/2011 à 10:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucienne

tu parles de quelle page exactement ? parce que je vois bien tous les produits de la catégorie bijoux feminins ( 65 produits sur 9 pages) avec les boutons ajouter au panier et voir le produit avec ff4

ps: tres beau site par ailleurs seul reproche c'est que le zoom de l'image ne sert pas a grand chose puisqu'il a le même grossissement que l'image normale en outre une description un peu plus fournie du bijou serait la bienvenue par exemple pour la bague elegance de l'emeraude tu precises or, emeraude et diamants 0,55 carat mais sans preciser si c'est l'émeraude, les diamants ou le tout qui fait 0,55 carat

pommekiwi
 Posté le 03/04/2011 à 10:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Sérieusement!

Merci, alors si ça se trouve, je galère depuis 15 jours pour trouvez la solution, et ça serait mon Firefox à moi qui bug! ça ça serait génial! merci de ce nouvel eclairage! je vais essayer de réinstaller firefox!

voici un lien direct vers une des pages qui poserai problème (comme tu m'as demandé). reconfirme moi.

http://www.le-coffre-a-bijoux.com/category.php?id_category=6

pommekiwi
 Posté le 03/04/2011 à 10:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Bon bah alors super génialissime!!!!!!

merci beaucoup d'avoir résolu mon problème (et je note les remarques,merci)!

griggione
 Posté le 03/04/2011 à 18:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Bonjour pommekiwi


Désolé mais sur cette page il y a problème : http://www.le-coffre-a-bijoux.com/category.php?id_category=6

Il n'y a que deux produits, pas de bannière, pas de pied de page, pas de colonne droite.

Autre chose, la grosseur de police pour tes tags est trop importante, plus que le texte des produits
Pour un site de bijoux, ça manque d'élégance, de même pour les tutres, menus, tags, une lettre à patins (anglaise) serait de bon aloi.

Dreamer
 Posté le 03/04/2011 à 18:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Je pense qu'elle a du faire une erreur quand elle a mis le dernier produit, ça décale tout l'ensemble ..

Je pense à du HTML qui a été ajouté dans le desciptif ..

griggione
 Posté le 03/04/2011 à 18:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

RE

A part la page d'accueil, c'est tout le reste qui a des problèmes.

Alors ce que j'ai dit au-dessus avec FF 3.1.6
Avec IE8, Opéra, Chrome, il manque la colonne de droite et je sais pas si il y a la aussi le flash ???

pommekiwi
 Posté le 03/04/2011 à 19:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

bonjour,

merci pour tes remarques, c vrai que la colonne tag trop imposante me dérange aussi mais je n'y m'étais pas encore trop préoccupée. je vais donc dès que possible chercher comment la modifier, ainsi que les polices.

Pour le bug firefox, ça change tout le temps, un coup une page marche pas, puis une autre...je ne comprends pas. Par contre sous IE, de chez moi ça a l'air ok.

ah oui, et puis mon fond d'écran n'apparait plus sous firefox, aussi!

donc mon pb n'est pas si résolu que ça finalement

je suis toujours preneuse pour des suggestions...

Merci

MJ



Modifié par pommekiwi le 03/04/2011 19:04
Publicité
pommekiwi
 Posté le 03/04/2011 à 19:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

A propos de HTML dans le descriptif, il y a effectivement le bouton "partager" que j'ai insérer sur chaque description d'article. est ce que ça peut être ça?

griggione
 Posté le 03/04/2011 à 19:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien
griggione a écrit :

Alors ce que j'ai dit au-dessus avec FF 3.1.6
Avec IE8, Opéra, Chrome, il manque la colonne de droite et je sais pas si il y a la aussi le flash ???

RE

Allons bon, par moment ça passe ?????

Ce doit être la redirection, vous êtes tellement à vous appeler le-coffre-a-bijoux.com/

pommekiwi
 Posté le 03/04/2011 à 19:11 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

enfin, c pas que ça passe, c plutot que ça empire! des pages marchaient tout à l'heure et maintenant non. enfin je crois!

pommekiwi
 Posté le 03/04/2011 à 19:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

Bon alors j'ai retester. (j'ai modifier le tri des produits car ça avait l'air de mieux marcher ce matin avec le tri par prix, que j'ai donc remis)

sur chrome pour moi c ok, sous ie aussi. et sous firefox, j'ai récuperer mon fond d'écran, mais certaines catégories plantent encore (a part bijoux pour bébés)



Modifié par pommekiwi le 03/04/2011 19:21
griggione
 Posté le 03/04/2011 à 19:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

RE

Effectivement par moment il y a du mieux .....

Faudra que je regarde la source demain.

pommekiwi
 Posté le 03/04/2011 à 19:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

je te remercie

griggione
 Posté le 04/04/2011 à 08:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Bonjour tous

C'est un peu le grand bazar ce code source, il y a un mélange de html+javascript+xml (on dirait)

Déjà c'est quoi ce code qu'on retrouve de partout : <script...</a></p>
Jamais vu, je sais pas ce que ça veut dire.

Ensuite ça commence à la ligne 569 et 570, c'est quoi ce code qui ferme la div Bague Power Men ???

// <![CDATA[
var a2a_config = a2a_config || {};...</a></p>
</div>

pommekiwi
 Posté le 04/04/2011 à 09:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

bonjour,

je n'ai pas touché au code. j'ai juste installé prestashop puis changé quelques images du thèmes pour les couleurs des blocs, puis utiliser le back office pour rentrer mes données. j'ai juste insérer le code du bouton partager dans les descriptifs des produits. sinon, je n'ai rien touché!

je n'y connais presque rien en code, et je ne m'aventure pas dedans.

merci, c vraiment sympa en tout cas d'essayer de m'aider!

MJ

Publicité
pommekiwi
 Posté le 04/04/2011 à 11:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

re-bonjour ,

dans quel dossier sur mon FTP il faut que j'aille pour voir/modifier ces codes? saurais-tu par quoi les remplacer? je pense supprimer le code que tu m'as signalé après la div bague power men.

merci

griggione
 Posté le 04/04/2011 à 13:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

RE

Le FTP n'a pas de dossier, c'est une application qui permet de transiter d'un endroit à un autre des fichiers ou répertoires.

Et je te conseille de rien supprimer sans demander avant.
Tu devrais aller sur un forum de presta pour demander, car ces codes sont là surement pour quelque chose.

pommekiwi
 Posté le 04/04/2011 à 13:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

j'ai posté des messages depuis 15j sur presta mais je n'ai eu aucune reponse.

merci quand même.

bonne journée

griggione
 Posté le 04/04/2011 à 13:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

RE

Alors sans garanti, on dirait qu'il manque la balise de fermeture, donc deux solutions, soit en sigle soit en unicode.
Parce que ailleurs il y a le mélange de fait pour les même balises, c'est vraiment bizzare (en plus il manque un guillemet on dirait)

ou

var a2a_config = a2a_config || {};..."></a></p>

ou

var a2a_config = a2a_config || {};..."& gt;</a></p> (sans espace entre & et gt;)

Si ça marche pas essaie aussi sans le "

De toute façon tu risques rien, au plus tu reviens comme avant.
Rapatrie avec filezilla de ton serveur vers le pc cette page, modifie avec ton éditeur de texte et renvoie vers le serveur.

Ouuupppsssss ligne 570



Modifié par griggione le 04/04/2011 13:46
griggione
 Posté le 04/04/2011 à 13:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

RE

pommekiwi , en cas que tu ais lu entre-temps, regarde j'ai modifié le post au-dessus à cause de cet éditeur de m

pommekiwi
 Posté le 04/04/2011 à 13:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

j'ai juste un truc qui m'handicape vraiment c que je ne sais pas ou je peux trouver cette page dans mon FTP. quel fichier dans quel dossier? j'affiche bien le code source de la page en ligne (comme toi j'imagine) mais je ne sais pas à quoi ce code correspond, où le retrouver et comment le modifier.

désolée de te prendre tant de temps...

griggione
 Posté le 04/04/2011 à 16:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

RE

Ben apparement cette page doit s'appeler category.php

pommekiwi
 Posté le 04/04/2011 à 18:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne

rien dans le dossier category.php. j'ai cherché dans plein de dossier mais je n'ai pas trouvé ce code...

je suis en train de retirer mes boutons partager car apparement le truc DATA a2a ... dont tu m'as parlé viendrait d elà.(c un peu long, j'ai 375 produits à modifier un par un dans le Back office)...

j'espère au moins que c ça!

par cotnre, je veux bien que tu m'expliques comment on trouve le nom du dossier qu'on doit modifier quand on a le code source. ça me permettrais de changer mes polices et mes tags...

merci, je retourne à mon travail de fourmi!

griggione
 Posté le 04/04/2011 à 18:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

RE

category.php n'est pas un dossier mais un fichier et il est présent c'est sur.
Une fois sur ce fichier il est fort possible que tu es des includes, ce qui te ramenera ou il faut.

Pour tes modifs, avec notepad++ tu peux modifier tous les fichiers en un clic.
Et si c'est FC qui a ce code, ça veux dire que tu as déjà modifier 375 fois ???

Publicité
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
4,24 €Adaptateur Aukey HDMI -> VGA à 4,24 €
Valable jusqu'au 30 Octobre

Amazon fait une promotion sur l'adapteur Aukey HDMI vers VGA qui passe à 4,24 € au lieu de 7,99 €. Cet adaptateur vous permettra de connecter un ordinateur ou une console avec un port HDMI sur un écran ou un projecteur possédant une interface VGA. 


> Voir l'offre
49,99 €Office 365 Famille - 6 utilisateurs - Abonnement 1 an à 49,99 €
Valable jusqu'au 27 Octobre

Amazon fait une promotion sur Office 365 Famille qui passe ainsi à 49,99 €, en téléchargement légal alors qu'on le trouve habituellement à 99 €. Vous pourrez télécharger et installer les dernières versions d'Outlook, Word, Excel, PowerPoint et OneNote sur 6 PC, Mac ou tablettes (iOS ou Android) pendant 1 an. Vous bénéficierez également d'un espace de stockage en ligne sur OneDrive de 1 To pour chaque utilisateur (6x1 To).


> Voir l'offre
71,76 €Carte mémoire Samsung 512 Go MicroSDXC Evo Select U3 (100 Mo/s) à 71,76 € livrée
Valable jusqu'au 29 Octobre

Amazon Allemagne fait une promotion sur la toute nouvelle carte mémoire Samsung 512 Go MicroSDXC Evo Select U3 qui passe à 67,24 € (avec la TVA ajustée). Comptez 4,52 € pour la livraison en France (gratuite en Belgique) soit un total de 71,76 € livrée. Une bonne affaire pour cette carte que l'on trouve ailleurs à partir de 115 € et qui offre des vitesses de 100 Mo/s en lecture et 90 Mo/s en écriture.  Elle est idéale pour les téléphones, caméras et appareils photo 4K. Elle est étanche, anti-choc et résiste aux rayons X et aux champs magnétiques.


> Voir l'offre

Sujets relatifs
Affichage de mon site web différent sous Firefox
problème site sous firefox
Problème d'affichage de Script sous Firefox
probleme d'affichage sous firefox
problème d'affichage sous firefox
Probleme d'affichage sur page d'accueil de mon SITE
Pb d'affichage de mon site avec FireFox
Problème d'affichage sur mon site
Problème Iframe Amazon sous Firefox (pas sur IE6)
Problème d'affichage sous IE8
Plus de sujets relatifs à gros problème d''affichage de mon site sous firefox
 > Tous les forums > Forum Forum des Webmasters