× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Linux
 Icônes énormes après installation de Gnome 3.16.0
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Mimile
  Posté le 13/04/2015 @ 13:27 
Aller en bas de la page 
Astucien

Bonjour,

Contexte : Archlinux + Gnome

Dimanche dernier, j'ai fait une mise à jour complète (énorme : 171 paquets - 2280 Go à télécharger) et j'ai arrêté mon PC vers 17 h.

Gnome est passé à la version 3.16.0 au cours de cette mise à jour.

Au démarrage suivant, je constate que toutes mes icônes sont devenues énormes.

Avec Nautilus (fichier > préférence > vues > réglage par défaut de la vue en icônes > indiquer "petit" - idem pour la vue en liste) , j'ai pu rendre leurs tailles normales aux icônes indiquées dans gnome-tweak-tool :

En revanche, les icônes des différents lanceurs que j'ai installé sur mon bureau sont devenues beaucoup plus grandes : exemple avec mon lanceur de radio :

A gauche, l'icône telle qu'elle apparaît maintenant, à droite telle qu'elle est réellement.

Quand je fais clic droit et que j'opte pour "redimensionner l'icône", j'ai beau essayer de la réduire, elle reste telle quelle.

Je précise que j'ai essayé de réduire l'icône originale (32x32 pixels) en 24x24 pixels mais ça ne change rien.

Auriez-vous une idée pour rendre aux icônes des lanceurs leurs tailles normales (car étant agrandies, elles sont beaucoup moins nettes que les originales) ?

Merci d'avance.



Modifié par Mimile le 13/04/2015 14:18
Publicité
Slyvester
 Posté le 13/04/2015 à 15:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour Mimile,

As-tu essayé la solution apportée par Clapas aujourd'hui à 13:45 ? : https://forums.archlinux.fr/viewtopic.php?t=16737

De toute façon, cela semble être un problème récurrent avec ArchLinux & Gnome (lien en anglais) : https://bbs.archlinux.org/viewtopic.php?id=188502

Ou encore ici = solution qu'il m'est impossible de tester (je n'ai pas d'OS Archlinux) ... : http://www.jeoffrey54.com/tag/gnome3#.VSvJ2Tdq9hg



Modifié par Slyvester le 13/04/2015 16:26
Mimile
 Posté le 13/04/2015 à 16:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

J'ai créé tous mes raccourcis comme indiqué par clapas.

Exemple :

#!/usr/bin/env xdg-open

[Desktop Entry]
Version=1.0
Type=Application
Terminal=false
Icon[fr_BE]=eid-viewer
Icon=/usr/share/icons/eid-viewer.png
Name[fr_BE]=Beid-viewer
Name=Eid-viewer
Exec=eid-viewer
Comment[fr_BE]=lecteur carte d'identité
Comment=lecteur carte d'identité

Les liens auxquels tu renvoies ne m'ont pas permis de résoudre ce problème.

Dans le premier cas, où ceci est suggéré :

Editez le fichier /usr/share/gnome-shell/js/ui/dash.js, et cherchez y la ligne suivante :

let iconSizes = [ 16, 22, 24, 32, 48, 64 ];

Supprimez le dernier chiffre, comme ceci :

let iconSizes = [ 16, 22, 24, 32, 48 ];

Enregistrez, et rechargez Gnome Shell :

Malheureusement, je ne trouve pas le fichier indiqué (/usr/share/gnome-shell/js/ui/dash.js)

Dans le second cas, dans le fichier /usr/share/icons/gnome/index.theme, j'ai remplacé (en ce qui concerne les applications) Fixed par Scalable en espérant qu'ainsi je pourrais réduire la taille des icônes.

Reboot : pas de résultat. Retour dans le fichier index-theme qui a annulé ma modification (remis sur Fixed)

Alors il faudra que je subisse ces bêtes icônes :

Clic pour agrandir

Et voilà à quoi ça ressemblait avait la mise à jour :

C'était quand même plus agréable à l'oeil

Logicien
 Posté le 14/04/2015 à 00:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Mimile, si tu veux que tes icônes soient plus nettes, il faut choisir une résolution plus élevée en gardant la même taille des icônes. Par exemple, si tu as 32x32, choisi 48x48 ou 64x64, voir 128x128 s'il le faut. Se peut-il que la résolution de l'écran et/ou le pilote vidéo ai(en)t changé(s)?



Modifié par Logicien le 14/04/2015 00:51
Slyvester
 Posté le 14/04/2015 à 11:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Logicien a écrit : " ... choisir une résolution plus élevée ..;" est la première chose qui m'est venue à l'esprit. En cherchant sur le net - en anglais : Icons+big size+archlinux, j'ai trouvé ceci (ne pas zapper le "warning" ou avertissement):

XDG specification : This method applies to both X11 and Wayland cursor themes.

For user-specific configuration, create or edit ~/.icons/default/index.theme. For system-wide configuration, one can edit /usr/share/icons/default/index.theme, but this file is owned by libxcursor and changes to it will be overwritten on update.

Define the theme directory name:

~/.icons/default/index.theme
[icon theme] 
Inherits=theme-name
Warning: Creating a symbolic link with ln -s /usr/share/icons/theme-name/ ~/.icons/default is not sufficient for a consistent cursor theme.

Then, create a symbolic link to the respective cursor directory (in case of a system-wide theme):

ln -s /usr/share/icons/theme-name/cursors ~/.icons/default/cursors

Re-login for the changes to take effect.

Lien : https://wiki.archlinux.org/index.php/Cursor_themes.

Je sais que ton anglais est suffisant. Tu ne risques rien d'essayer !



Modifié par Slyvester le 14/04/2015 11:24
Mimile
 Posté le 18/04/2015 à 15:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Logicien a écrit :

Mimile, si tu veux que tes icônes soient plus nettes, il faut choisir une résolution plus élevée en gardant la même taille des icônes. Par exemple, si tu as 32x32, choisi 48x48 ou 64x64, voir 128x128 s'il le faut. Se peut-il que la résolution de l'écran et/ou le pilote vidéo ai(en)t changé(s)?

Salut Paul,

La résolution de mon écran n'a pas changé (19" - 16x10 - 1440x900).

J'utilise le driver graphique "nouveau" et j'ignore s'il a été modifié (comment le vérifier ?)

En ce qui concerne les icônes, je ne vois pas bien comment choisir une résolution plus élevée en gardant la même taille.

Avec Gimp, j'avais réduit la taille d'une des icônes (32x32 à l'origine) à 24x24 mais sur le bureau, ça n'a rien changé : toujours cette même grosse icône un peu floue.

Décidément, depuis la grosse mise à jour de dimanche dernier, je ne rencontre que des (petits) problèmes sans grande gravité mais qui sont agaçants : plus d'activation automatique du pavé numérique, un paquet mystérieusement disparu (numlockx), icônes affreuses, logiciel de capture d'écran passé en anglais, l'option "redémarrer" plante parfois et probablement d'autres qui apparaîtront au fur-et-à-mesure ...

J'en suis d'autant plus énervé que depuis que je suis sous Arch, je n'ai pas arrêté d'en vanter les qualités ...

Slyvester a écrit :

Bonjour,

Logicien a écrit : " ... choisir une résolution plus élevée ..;" est la première chose qui m'est venue à l'esprit. En cherchant sur le net - en anglais : Icons+big size+archlinux, j'ai trouvé ceci (ne pas zapper le "warning" ou avertissement):

XDG specification : This method applies to both X11 and Wayland cursor themes.

For user-specific configuration, create or edit ~/.icons/default/index.theme. For system-wide configuration, one can edit /usr/share/icons/default/index.theme, but this file is owned by libxcursor and changes to it will be overwritten on update.

Define the theme directory name:

~/.icons/default/index.theme
[icon theme] 
Inherits=theme-name
Warning: Creating a symbolic link with ln -s /usr/share/icons/theme-name/ ~/.icons/default is not sufficient for a consistent cursor theme.

Then, create a symbolic link to the respective cursor directory (in case of a system-wide theme):

ln -s /usr/share/icons/theme-name/cursors ~/.icons/default/cursors

Re-login for the changes to take effect.

Lien : https://wiki.archlinux.org/index.php/Cursor_themes.

Je sais que ton anglais est suffisant. Tu ne risques rien d'essayer !

Il est vrai que je ne me débrouille pas trop mal en anglais (écrit) mais sauf erreur de ma part, le lien auquel tu renvoies concerne les curseurs et non pas les icônes des lanceurs.

ou me trompé-je ?



Modifié par Mimile le 18/04/2015 15:10
Logicien
 Posté le 18/04/2015 à 15:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Mimile,

si tu regardes dans le répertoire /usr/share/icons est ses sous-répertoires, tu vas voir que les icônes sont classées selon leur résolution. C'est vrai qu'il peut être impossible de garder la même taille en changeant de résolution, mais essai d'utiliser une résolution plus élevée d'icônes.

Pour savoir quel pilote vidéo utilis Xorg, il faut regarder dans le fichier /var/log/Xorg.0.log. Je ne peux pas t'aider plus que ça. Je fais ma mise-à-jour ce soir de la Arch, je n'ai pas de problème, milou32 non plus a-t-elle dit.

milou32
 Posté le 18/04/2015 à 16:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucienne

Paul, Mimile, Slyvester

Je confirme aucun problème depuis la mise à jour que j'ai faîte il y a deux jours

Slyvester
 Posté le 18/04/2015 à 18:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir,

Je sais que cela ne fera pas avancer le "schmilblick", mais c'est ce genre de problèmes que je crains/craignais qui a fait que je ne me suis pas dirigé vers Manjaro ou pire (!) vers ArchLinux. J'ai pourtant bien eu envie d'effectuer ce choix, mais modestement mes connaissances linuxiennes ne permett(ai)ent pas - à juste titre - de le faire.

J'ai plutôt choisi d'installer deux "forks" ou "dérivés de Debian, l'une version "testing" et l'autre "stable" : SparkyLinux & Watt OS R8. Que du bonheur, du moins jusqu'à présent ! Grâce à ce post qui apporte de l'eau à mon moulin, ma prochaine installation sera certainement la Debian "Testing" Jessie, mais après le 25 avril 2015.

Courage, Mimile, en espérant que tu y arrives ....



Modifié par Slyvester le 19/04/2015 09:12
Publicité
Logicien
 Posté le 19/04/2015 à 01:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Dans Gnome-tweak-tool sous l'onglet Apparence on peut changer le thème du bureau et le jeu d'icônes. La solution est peut-être là.

Mimile
 Posté le 19/04/2015 à 11:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

@ Logicien : voici le contenu de /var/log/Xorg.0.log

[ 194.971] _XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
[ 194.971] _XSERVTransMakeAllCOTSServerListeners: server already running
[ 194.971] (EE)
Fatal server error:
[ 194.971] (EE) Cannot establish any listening sockets - Make sure an X server isn't already running(EE)
[ 194.971] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 194.971] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 194.971] (EE)
[ 194.971] (EE) Server terminated with error (1). Closing log file.

Un peu trop de failed et de error à mon goût.

Gnome-tweak-tool n'offre aucune possibilité au niveau des icônes, si ce n'est leur apparence (gnome, kde4, adwaita, etc.)

Pour le surplus, changer de résolution des icônes des lanceurs ne résout en rien le problème : toujours ces grosses icônes désagréablement floues.

Seules les icônes qu'on peut afficher avec gnome-tweak-tool (home, partitions montées et poubelle) ont pu être réduites à un gabarit normal en utilisant Nautilus (fichier > préférences > tailles des icônes > petites).

On peut les agrandir mais pas les réduire à un format inférieur.

Ce sont uniquement les icônes de mes lanceurs qui restent non modifiables (sauf deux icônes que voici) :

taille attribuée :

Taille réduite :

Ce sont des lanceurs qui ouvrent avec nautilus la collection des albums Astérix et Gaston Lagaffe (fichiers *.pdf).

Pour les autres icônes, rien à faire ...



Modifié par Mimile le 19/04/2015 11:43
Logicien
 Posté le 19/04/2015 à 12:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Mimile,

ton /var/log/Xorg.0.log affiche le message du serveur qui plante. Tu sembles avoir un problème d'affichage quelque part. Fait

ls /var/log

Si tu peux afficher le contenu de la commande

dmesg

ça serait utile pour savoir si le framebuffer nouveau fonctionne au niveau du noyau Linux. S'il ne fonctionne pas, le pilote nouveau d'Xorg ne fonctionnera pas non plus. Xorg va utiliser le pilote vesa ou fbdev ce qui pourrait expliquer tes icônes dilués.

Quand tu es sur ton bureau, alors affiche le contenu du fichier /var/log/Xorg.0.log. Xorg doit fonctionner pour que tu puisses être sur ton bureau.

Mimile
 Posté le 19/04/2015 à 16:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Voici ce que renvoie ls /var/log :

[okapi@Archie ~]$ ls /var/log
btmp hp openvswitch teamviewer Xorg.1.log
btmp.1 httpd pacman.log wtmp Xorg.1.log.old
cups journal pm-powersave.log wtmp.1 Xorg.2.log
faillog lastlog samba Xorg.0.log
gdm old speech-dispatcher Xorg.0.log.old

le contenu de /var/log/Xorg.0.log

[okapi@Archie Bureau]$ cat /var/log/Xorg.0.log
[ 194.971] _XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed
[ 194.971] _XSERVTransMakeAllCOTSServerListeners: server already running
[ 194.971] (EE)
Fatal server error:
[ 194.971] (EE) Cannot establish any listening sockets - Make sure an X server isn't already running(EE)
[ 194.971] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 194.971] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[ 194.971] (EE)
[ 194.971] (EE) Server terminated with error (1). Closing log file.
[okapi@Archie Bureau]$

Pour le dmesg, il est interminable.

J'ai essayé d'utiliser pastebin pour que tu puisse le consulter via son URL, mais ça ne passe pas.

Peut-être la taille du fichier (*.txt) est-elle supérieure à ce qui est admis.

EDIT : Voici les lignes relatives à "nouveau" extraites de dmesg :

[ 0.636474] nouveau [ DEVICE][0000:01:00.0] BOOT0 : 0x0c1000a1
[ 0.636479] nouveau [ DEVICE][0000:01:00.0] Chipset: GF108 (NVC1)
[ 0.636482] nouveau [ DEVICE][0000:01:00.0] Family : NVC0
[ 0.764085] nouveau [ VBIOS][0000:01:00.0] using image from PRAMIN
[ 0.764151] nouveau [ VBIOS][0000:01:00.0] BIT signature found
[ 0.764153] nouveau [ VBIOS][0000:01:00.0] version 70.08.ad.00.01
[ 0.764420] nouveau [ PMC][0000:01:00.0] MSI interrupts enabled
[ 0.764446] nouveau W[ PFB][0000:01:00.0][0x00000000][ffff8800d8545000] reclocking of this ram type unsupported
[ 0.764448] nouveau [ PFB][0000:01:00.0] RAM type: DDR3
[ 0.764449] nouveau [ PFB][0000:01:00.0] RAM size: 1024 MiB
[ 0.764450] nouveau [ PFB][0000:01:00.0] ZCOMP: 0 tags
[ 0.765716] nouveau [ VOLT][0000:01:00.0] GPU voltage: 900000uv
[ 1.587202] tsc: Refined TSC clocksource calibration: 3092.203 MHz
[ 1.830440] nouveau [ PTHERM][0000:01:00.0] FAN control: PWM
[ 1.830458] nouveau [ PTHERM][0000:01:00.0] fan management: automatic
[ 1.830495] nouveau [ PTHERM][0000:01:00.0] internal sensor: yes
[ 1.850551] nouveau [ CLK][0000:01:00.0] 07: core 405 MHz memory 324 MHz
[ 1.850553] nouveau [ CLK][0000:01:00.0] 0f: core 810 MHz memory 667 MHz
[ 1.850689] nouveau [ CLK][0000:01:00.0] --: core 405 MHz memory 324 MHz
[ 1.853725] [TTM] Zone kernel: Available graphics memory: 2003196 kiB
[ 1.853726] [TTM] Initializing pool allocator
[ 1.853729] [TTM] Initializing DMA pool allocator
[ 1.853735] nouveau [ DRM] VRAM: 1024 MiB
[ 1.853742] nouveau [ DRM] GART: 1048576 MiB
[ 1.853744] nouveau [ DRM] TMDS table version 2.0
[ 1.853745] nouveau [ DRM] DCB version 4.0
[ 1.853746] nouveau [ DRM] DCB outp 00: 01000302 00020030
[ 1.853747] nouveau [ DRM] DCB outp 01: 02000300 00000000
[ 1.853748] nouveau [ DRM] DCB outp 02: 08011392 00020020
[ 1.853749] nouveau [ DRM] DCB outp 03: 04022310 00000000
[ 1.853750] nouveau [ DRM] DCB conn 00: 00001030
[ 1.853752] nouveau [ DRM] DCB conn 01: 00002161
[ 1.853753] nouveau [ DRM] DCB conn 02: 00000200
[ 1.854287] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[ 1.854288] [drm] Driver supports precise vblank timestamp query.
[ 1.859342] nouveau [ DRM] MM: using COPY0 for buffer copies
[ 1.964666] nouveau [ DRM] allocated 1440x900 fb: 0x60000, bo ffff8800d87f9400
[ 1.964813] fbcon: nouveaufb (fb0) is primary device
[ 2.042087] Console: switching to colour frame buffer device 180x56
[ 2.043688] nouveau 0000:01:00.0: fb0: nouveaufb frame buffer device
[ 2.043689] nouveau 0000:01:00.0: registered panic notifier



Modifié par Mimile le 19/04/2015 16:32
Logicien
 Posté le 19/04/2015 à 17:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Pour le pilote nouveau côté noyau, les messages sont bons. Que retourne la commande

find /etc/X11 -iname *xorg.conf*

Mimile
 Posté le 19/04/2015 à 17:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

La réponse :

[okapi@Archie ~]$ find /etc/X11 -iname *xorg.conf*
/etc/X11/xorg.conf.d
[okapi@Archie ~]$

Accessoirement :

[okapi@Archie ~]$ cd /etc/X11/xorg.conf.d
[okapi@Archie xorg.conf.d]$ ls -l
total 24
-rw-r--r-- 1 root root 232 18 oct 2014 00-keyboard.conf
-rw-r--r-- 1 root root 197 17 oct 2014 10-keyboard-layout.conf
-rw-r--r-- 1 root root 161 18 jun 2013 10-keyboard-layout.conf~
-rw-r--r-- 1 root root 186 16 jun 2013 10-keyboard-terminate.conf
-rw-r--r-- 1 root root 94 16 jun 2013 10-monitor.conf
-rw-r--r-- 1 root root 72 18 jun 2013 20-nouveau.conf

Et enfin :

[okapi@Archie xorg.conf.d]$ cat 20-nouveau.conf
Section "Device"
Identifier "nvidia card"
Driver "nouveau"
EndSection
[okapi@Archie xorg.conf.d]$

J'ajoute que selon le man de nouveau, ma carte graphique est bien prise en charge par nouveau.



Modifié par Mimile le 19/04/2015 17:32
Logicien
 Posté le 19/04/2015 à 17:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Ce que je ne comprend pas c'est ton Xorg.0.log. Il dit que le serveur se termine mais tu es devant ton bureau sous Xorg.

Logicien
 Posté le 19/04/2015 à 17:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Quel est le contenu du fichier

/etc/X11/xorg.conf.d/10-monitor.conf

Publicité
Mimile
 Posté le 20/04/2015 à 01:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

monitor.conf

[okapi@Archie xorg.conf.d]$ cat 10-monitor.conf
Section "Monitor"
Identifier "Monitor0"
Option "PreferredMode" "1024x768"
Endsection

Les valeurs "PreferredMode" ne sont pas celles de mon écran (1440x900).

Je modifie et teste.

Je reviens de suite.

....

EDIT : valeurs modifiées dans 10-monitor.conf : pas de changement. Icônes des lanceurs toujours aussi grosses et non redimensionnables ...

Bon, ici, il se fait tard (01:40 AM) et je vais dormir.

Bonne soirée à toi.

Amicalement



Modifié par Mimile le 20/04/2015 01:41
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
69,99 €Disque dur Toshiba P300 3 To à 69,99 €
Valable jusqu'au 28 Septembre

Amazon propose actuellement le disque dur Toshiba P300 3 To à 69,99 € livré gratuitement. On le trouve ailleurs à partir de 90 €. Ce disque dur interne de 3 To est SATA 6 Gbps, possède 64Mo de cache et dispose d'une vitesse de rotation de 7200 tpm.


> Voir l'offre
13,79 €Adaptateur USB 3.0 Ethernet Gigabit TP-Link UE300 à 13,79 €
Valable jusqu'au 28 Septembre

Amazon fait une promotion sur l'adaptateur USB 3.0 Ethernet Gigabit TP-Link UE300 qui passe à 13,79 € au lieu de 20 €. Cet adaptateur vous permettra de rajouter une prise Ethernet Gigabit à votre ordinateur portable (ou votre tablette via un adaptateur OTG) qui en est dépourvu.


> Voir l'offre
21,91 €Souris sans fil Logitech M280 à 21,91 €
Valable jusqu'au 27 Septembre

Amazon fait une petite promotion sur la souris sans fil Logitech M280 qui passe à 21,91 €. On la trouve ailleurs à partir de 30 €. Sa forme profilée est adaptée aux droitiers. Son autonomie est de 18 mois (pile AA que vous pourrez remplacer).


> Voir l'offre

Sujets relatifs
Pas de connexion Wifi après installation Linux Mint 17.1
Erreur après l'installation de Conky
bureau XFCE4 rempli d'icônes GNOME (Slim)
Montage d'un DD ajouté après installation K-10.04
RESOLU pas de menu après l'installation
Ubundu Problem aprés installation
PAS de windows aprés installation d'ubuntu
Boot trop long apres installation Linux
Probleme après installation de Whax 3.0
Pas d'affichage après installation linux
Plus de sujets relatifs à Icônes énormes après installation de Gnome 3.16.0
 > Tous les forums > Forum Linux