× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Internet et Réseaux
 Imprimante réseau XP et 7 incompatible?Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
gee4960
  Posté le 01/07/2014 @ 03:49 
Aller en bas de la page 
Petit astucien

Bonjour à tous, voici ma situation: j'ai un pc qui fonctionne sous XP et une imprimante par usb sur ce pc que je voudrais bien partager avec mes autres pc qui eux sont tous sur Windows 7. après avoir lu que cela était possible de partager le tout je me suis donc lancé sans succès, j'ai essayé tout ce que j'ai pu trouver comme documentation la dessus mais non... pourtant mes pc ont le même nom de groupe de travail, ils sont tous configurés pour partager cette imprimante.

Ils sont tous branchés sur le modem, mais si je lance "ajouter une imprimante" niet! Windows la voit je choisis imprimante réseau, il essaie de l'installer mais le message "Windows ne peut pas communiquer avec cette imprimante" et ce que je trouve bizarre c'est qu'il voit mon imprimante Wi-Fi que je me sers avec mon portable....ben voyons donc!!!!!

Donc si je récapitule: je suis sous réseau domestique partout, même nom de groupe de travail partout, lors de la tentative d'installation le bon nom d'imprimante est la avec le bon pc sous XP, je le sélectionne mais rien à faire.... ou ai-je manqué? J'aimerais avoir l'avantage de deux imprimantes bien sur, toujours pratique avec 2 personnes qui impriment régulièrement...sur ce je vous souhaite une bonne soirée et au plaisir de vous lire!

Publicité
qmike549
 Posté le 01/07/2014 à 06:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

bonjour

Je n'ai pas retrouver les caractéristiques de l'imprimante dans ton post

Titus68
 Posté le 01/07/2014 à 07:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Cà doit être normal car lors de l'installation de l'imprimante sur W7, W7 va chercher les pilotes de l'imprimante sur XP mais ceux-ci n'existent sans doute pas pour W7.

Il faudrait peut-être essayer d'installer le pilote sur W7 comme si l'imprimante était locale (sur LPT1) puis rattacher manuellement au niveau de W7 cette imprimante sur le port de l'imprimante XP.

Attention également si XP est en 32 bits alors que W7 est en 64 bits.



Modifié par Titus68 le 01/07/2014 07:44
ZenJP
 Posté le 01/07/2014 à 09:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

ou passer par un serveur d'impression

Titus68
 Posté le 01/07/2014 à 13:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour tout le monde,

Pour le serveur d'impression, il y a un tuto pas mal fait là (pour l'installation) :

http://adminsys.raphalon.fr/2011/09/05/windows-partager-une-imprimante-en-tcpip-lpd/

N'installer le serveur d'impression que sur l'XP.

Par contre il n'indique pas la connexion entre XP et W7 ... C'est pas le port 515 avec l'adresse IP (du XP) qu'il faudra prendre ?

gee4960
 Posté le 01/07/2014 à 17:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour tout le monde! Tout d'abord qmike 549 c'est une Canon MX320séries fax. Pour Titus68 et ZenJP, j'ai effectivement installer le pilote nécessaire autant sur le pc avec XP et celui sur 7, tous en 32 bits. Le pilote est bon pour XP/Vista/7/8 32 bits selon Canon.

Si je branche physiquement l'imprimante sur le pc avec 7, tout fonctionne bien je peux imprimer par contre sur 7 je reçois le message qu'il faudrait activer l'option bi directionnel...je veux bien mais dans propriétés de l'imprimante, que ce soit avancé ou sécurité je ne trouve pas!

Est-ce possible que malgré le fait que l'imprimante fonctionne sous 7 sans réseau, le pilote de Canon aurait un manque en quelque part??? Je croyais que l'option bi directionnel s'appliquait aux anciens ports parallèles seulement... je viens peut-être d'apprendre quelque chose!!

Pour ce qui est du serveur d'impression je vais aller voir le lien que tu me proposes Titus! Merci encore à vous tous pour vos réponses, j'apprécie! Au moins je suis rassuré que mon imprimante fonctionne sous 7....reste à voir pour le réseau!

Bonne journée

ZenJP
 Posté le 01/07/2014 à 17:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Rassure-moi elle est bien branchée en usb ?

Blague à part, tu es sous W7 32 ou 64 bits ?



Modifié par ZenJP le 01/07/2014 17:23
ZenJP
 Posté le 01/07/2014 à 17:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Zut je viens de voir message précédent que tu parlais de 32 bits, donc :

http://www.canon.fr/Support/Consumer_Products/products/Fax__Multifunctionals/InkJet/PIXMA_MX_series/PIXMA_MX320.aspx?type=download&softwaredetailid=tcm:79-987026&os=Windows%207&language=FR

Déconnecte ton imprimante avant d'installer ce pilote.

gee4960
 Posté le 01/07/2014 à 19:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour ZenJP, c'est exactement ce pilote que j'ai installé autant sur XP que sur 7 et oui elle est branché USB!!!! Je vais voir pour le lien que Titus me propose afin de monter un serveur d'imprimante vu que mon réseau ne semble pas vouloir accepter que j'imprime de mon sous-sol!!!

Bonne journée à toi

Publicité
ZenJP
 Posté le 01/07/2014 à 19:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

gee4960 a écrit :

Bonjour ZenJP, c'est exactement ce pilote que j'ai installé autant sur XP que sur 7 et oui elle est branché USB!!!! Je vais voir pour le lien que Titus me propose afin de monter un serveur d'imprimante vu que mon réseau ne semble pas vouloir accepter que j'imprime de mon sous-sol!!!

Bonne journée à toi

si c'est une manière de me dégager, je te rappelle que 1) tu n'as pas donné le lien de ton pilote donc il fallait vérifier et que 2) l'idée du serveur d'impression c'était moi (lien donné par titus)

sur ce,

qmike549
 Posté le 01/07/2014 à 19:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

ZenJP +1

Titus68
 Posté le 01/07/2014 à 21:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir,

Il se passe quoi du coup ? Est-ce que l'imprimante partagée du XP est visible depuis W7 et si on imprime il y a un message d'erreur ?

Banzaiii
 Posté le 02/07/2014 à 06:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Message original par gee4960

Donc si je récapitule: je suis sous réseau domestique partout, même nom de groupe de travail partout, lors de la tentative d'installation le bon nom d'imprimante est la avec le bon pc sous XP, je le sélectionne mais rien à faire.... ou ai-je manqué?

Slt

Quels parefeux et logiciels antivirus sont installés sur ces pc ?

Mets nous :

une copie d'écran du résultat de la commande net share tapée dans une invite de commande (cmd) sur le PC XP

Une copie d'écran de la fenêtre d'installation sous Seven au moment du blocage

Désactive (quitte) le groupe résidentiel sous Seven

Aucune raison d'installer un serveur d'impression, il y tout ce qu'il faut sous Windows pour partager une imprimante.

Ps : Il est étonnant que tu aies installé le pilote manuellement sous Seven, celui-ci étant commun XP et Seven, il s'installe automatiquement sous Seven.

Ton problème semble purement Réseau local Windows



Modifié par Banzaiii le 02/07/2014 07:27
gee4960
 Posté le 02/07/2014 à 19:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour à tous, bien oui ZenJP que tu as avancé l'idée du serveur en premier, Titus après a partager un lien ( que je n'ai pas encore eu le temps d'aller voir, trop débordé côté travail...hé oui! ) mais je compte bien aller jeter un œil promis!!! Titus, j'ai répondu ceci un peu plus tôt:

"Bonjour tout le monde! Tout d'abord qmike 549 c'est une Canon MX320séries fax. Pour Titus68 et ZenJP, j'ai effectivement installer le pilote nécessaire autant sur le pc avec XP et celui sur 7, tous en 32 bits. Le pilote est bon pour XP/Vista/7/8 32 bits selon Canon.

Si je branche physiquement l'imprimante sur le pc avec 7, tout fonctionne bien je peux imprimer par contre sur 7 je reçois le message qu'il faudrait activer l'option bi directionnel...je veux bien mais dans propriétés de l'imprimante, que ce soit avancé ou sécurité je ne trouve pas!

Est-ce possible que malgré le fait que l'imprimante fonctionne sous 7 sans réseau, le pilote de Canon aurait un manque en quelque part??? Je croyais que l'option bi directionnel s'appliquait aux anciens ports parallèles seulement... je viens peut-être d'apprendre quelque chose!!

Pour ce qui est du serveur d'impression je vais aller voir le lien que tu me proposes Titus! Merci encore à vous tous pour vos réponses, j'apprécie! Au moins je suis rassuré que mon imprimante fonctionne sous 7....reste à voir pour le réseau!

Bonne journée "

Maintenant Banzaiii, sur tous mes pc pare-feu Windows et Microsoft Security Essentiel, j'ai essayé plusieurs autres anti-virus, AVG, Norton, Avast mais ça ralentissait trop à mon goût, surtout celui en XP et je me dis que même le meilleur anti-virus au monde ne protège pas à 100%, c'est de la façon qu'on navigue qui est encore la meilleure solution...avant de cliquer sur n'importe quoi je vérifie et si ça me parait louche alors bye bye! J'ai des ordinateurs depuis 1995 ( ça ne me rajeunis pas... ) et 2 fois j'ai eu des virus assez solide...et si ma mémoire est fidèle j'étais sous windows98!!! et aussi moins prudent en naviguant que maintenant. Je prends note de ce que tu m'a répondu en te remerciant, moi aussi je crois bien que c'est une simple question de réseau, reste à me trouver du temps pour continuer à essayer de corriger le tout!

J'ai décidé d'installer le pilote le plus à jour sur chaque pc afin de mettre toutes les chances sur mon bord et éviter des conflits de pilotes...

Bon l'heure du lunch étant terminée, je retourne au boulot mais dès qu'il y a du nouveau je viens vous faire part de mon succès ou non...

Bonne journée.

Banzaiii
 Posté le 03/07/2014 à 05:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Ok mais tu as bien quitté le groupe résidentiel ?

Et les copies d'écran demandées?

gee4960
 Posté le 04/07/2014 à 14:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour à tous, Banzaiii voici mes copies d'écran demandées. Pas eu le temps de vraiment encore essayer de corriger le problème mais au moins j'ai pris les captures d'écran! bon allons au travail, bonne journée. Que j'essaie imprimante 2 ou 3 même résultat.

Banzaiii
 Posté le 04/07/2014 à 17:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Je ne comprends pas, l'imprimante est partagée sur deux PC ?

Quel est le nom du PC XP ?

Publicité
Titus68
 Posté le 04/07/2014 à 20:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir,

Dans plusieurs cas une des solutions consisterait à faire en administrateur sous W7 :

net use LPT2 \\lePCXP\l'Imprimante.

Installer les pilotes de l'imprimante, puis au niveau du port choisir le port LPT2.

Microsoft en parle aussi ici :

http://support.microsoft.com/kb/947236

gee4960
 Posté le 05/07/2014 à 00:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour Banzaiii, le nom du pc XP est GEORGES-97EEB7D, si on voit Canon MX320 dans la liste ( BUREAU-GEORGES... sous W7) c'est simplement que je l'ai installé physiquement sur celui sous W7 afin de m'assurer que l'imprimante fonctionnait vraiment sous W7 et donc que j'avais le bon pilote d'installé partout. Titus je m'en vais voir ton lien si ça peut me dépanner. Mon imprimante est branché en USB sur le pc XP, comme tu vois celui sous W7 localise l'imprimante mais ne peut communiquer avec elle à la fin de l'installation....

Merci à vous tous de prendre le temps de me soumettre vos idées.

Bonne soirée

Banzaiii
 Posté le 05/07/2014 à 07:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

gee4960 a écrit :

Bonjour Banzaiii, le nom du pc XP est GEORGES-97EEB7D, si on voit Canon MX320 dans la liste ( BUREAU-GEORGES... sous W7) c'est simplement que je l'ai installé physiquement sur celui sous W7 afin de m'assurer que l'imprimante fonctionnait vraiment sous W7 et donc que j'avais le bon pilote d'installé partout. Titus je m'en vais voir ton lien si ça peut me dépanner. Mon imprimante est branché en USB sur le pc XP, comme tu vois celui sous W7 localise l'imprimante mais ne peut communiquer avec elle à la fin de l'installation....

Merci à vous tous de prendre le temps de me soumettre vos idées.

Bonne soirée

Non, elle est partagée sur les deux PC

Supprime carrément l'imprimante sur le PC BUREAU-GEORGES et refait l'installation en choisissant "Imprimante2 sur GEORGES-97EEB70"


Le XP c'est une version professionnelle ou une version familiale ?




Modifié par Banzaiii le 05/07/2014 08:46
gee4960
 Posté le 07/07/2014 à 14:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour Banzaiii, j'ai désinstallé l'imprimante locale sur le pc W7(Bureau Georges), réessayer l'installation sans succès, toujours le même message à la fin de l'installation, il détecte bien CanonMx320 sur le pc XP fait son installation mais rien à faire à la fin leW7 ne peut pas communiquer avec l'imprimante installé sur le pc XP. J'ai beau regarder dans la configuration des 2 pc et lire tout ce que je trouve sur le sujet, je ne mets pas le doigt sur le bobo.

Édition XP Pro, service pack3...donc j'essaie la solution proposé par Titus68 soit de monter un serveur d'impression et si jamais le tout ne fonctionne toujours pas, j'installerai une carte Wi-Fi dans W7 et me servirai de mon autre imprimante...ce n'est pas exactement ce que je voulais mais il faut savoir faire des compromis.

Ce qui est frustrant quelquefois avec les ordis, c'est qu'ils nous tiennent tête!!!! Le pire la dedans c'est que probablement c'est une "niaiserie" qui empêche l'installation finale...malgré mes connaissances + toute l'aide reçue ici par vous tous avec vos judicieux conseils j'ai soit un fichu d'ordi tête dure ou un réseau qui ne veut pas "réseauter" à 100%!!!! Mis à part ce désagrément tout le reste est impeccable, ça me console.... merci encore à vous tous, je reviens plus tard.

Bonne journée

gee4960
 Posté le 07/07/2014 à 17:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Profitant d'une journée de pluie ici au Québec, donc pas de travail aujourd'hui, j'ai eu le temps d'essayer de monter un serveur d'impression sans succès...pourquoi? ça je l'ignore, j'ai suivi à la lettre le tuto suggéré par Titus68 mais rien à faire mon pc W7 refuse de communiquer avec l'imprimante comme toutes mes autres tentatives....donc installation d'une carte Wifi, installation de mon autre imprimante Wifi HP, vif succès!

Un immense MERCI à vous tous de m'avoir accompagné, c'est ce que j'aime du forum, des gens agréables qui partagent leurs connaissances et expériences.

À une prochaine fois!

Georges

Titus68
 Posté le 07/07/2014 à 20:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Merci pour le retour et bonne continuation.

Banzaiii
 Posté le 08/07/2014 à 07:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

gee4960 a écrit :

Bonjour Banzaiii, j'ai désinstallé l'imprimante locale sur le pc W7(Bureau Georges), réessayer l'installation sans succès, toujours le même message à la fin de l'installation, il détecte bien CanonMx320 sur le pc XP fait son installation mais rien à faire à la fin leW7 ne peut pas communiquer avec l'imprimante installé sur le pc XP.

Pas de raison que ça ne marche pas

Tu as bien quitté le groupe résidentiel sur W7 ? (Je t'ai posé 2 fois la question, tu n'as jamais répondu)

il détecte bien CanonMx320 sur le pc XP

???? Pourtant l'imprimante n'est pas partagée sous ce nom sur le PC XP¨mais sous Imprimante2

Dans le Centre de réseau et partage du Pc Seven, le réseau est bien de type "Domestique" ?

Tu peux encore tenter de faire la connexion manuellement

Quand tu es dans la fenêtre de parcours du réseau sous Seven, clique sur 'L'imprimante que je veux n'est pas répertoriée" et entre dans le chemin comme ci-dessous et clique sur Suivant :

Enfin il y a ce lien Microsoft qui semble correspondre à ton problème http://support.microsoft.com/kb/947236/fr

Procédure à exécuter sur le PC XP



Modifié par Banzaiii le 08/07/2014 10:39
Publicité
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
199 €Kit 5.1 Logitech Speaker System Z906 à 199 €
Valable jusqu'au 28 Novembre

Amazon fait une promotion sur le kit 5.1 Logitech Speaker System Z906 qui passe à 199 € livré gratuitement alors qu'on le trouve ailleurs à partir de 250 €. Avec une puissance de diffusion de 500 watts (RMS), ce système 5.1 certifié THX produit un son de qualité cinéma. Profitez d'un contrôle total sur votre système multimédia grâce à ses entrées numériques et analogiques, un pupitre de commande facile à lire et empilable et une télécommande sans fil.


> Voir l'offre
849,90 €Ultrabook HONOR MagicBook Pro 16.1 (Ryzen 5 4600H, 16Go, 512 Go SSD) à 849,90 € (code AFRPROMO50)
Valable jusqu'au 27 Novembre

HONOR fait une promotion sur son ultrabook HONOR MagicBook Pro 16.1 qui passe à 849,90 € au lieu de 929 € grâce au code promo AFRPROMO50. Cet ordinateur portable possède un écran 16.1 pouces Full HD IPS 100% sRGB, un processeur AMD Ryzen 5 4600H à 6 coeurs (avec chip graphique Vega 6), 16 Go de mémoire DDR4, un SSD 512 Go PCIe NVME, le WiFi5 / Bluetooth 5.0, un lecteur d'empreintes, une webcam, un clavier rétro éclairé, une batterie 56 Wh (jusqu'à 11h d'autonomie et recharge rapide) et ne pèse que 1,7 kg. Il fonctionne sous Windows 10. Une très bonne affaire pour une machine compacte et puissante. Vous pourrez également choisir un cadeau gratuit parmi une enceinte bluetooth, une souris bluetooth ou un sac à dos de transport.


> Voir l'offre
-25%Milka, Lu, Oreo, Hollywood : jusqu'à -25% sur une sélection de biscuits, chocolats et chewing-gum
Valable jusqu'au 27 Novembre

Amazon offre actuellement jusqu'à 25% de remise immédiate sur une sélection de biscuits, chocolats et chewing-gum des marques Lu, Milka, Oreo, Hollywood, ... Notez que certaines offres sont aussi cumulables avec le programme Prévoyez et Economisez qui vous permet de bénéficier jusqu'à 15% supplémentaires en vous abonnant pour une réception régulière (tous les mois, 2 mois, 3 mois, etc). Ces abonnements peuvent être arrêtés quand vous voulez.


> Voir l'offre

Sujets relatifs
imprimante non reconnu sur réseau local par cpl
Imprimante en reseau
Problèmes d'imprimante en réseau.
wifi avec livebox fibre mon imprimante perd le réseau wifi si j'éteins PC
Help ! Relier imprimante usb a la box pour réseau
imprimante reseau , pas d'impression
connexion refusee imprimante XP-405 epson et vista sur le reseau
Installation imprimante sur pc portable en reseau
Imprimante Brother 135C en reseau
Imprimante en réseau
Plus de sujets relatifs à Imprimante réseau XP et 7 incompatible?
 > Tous les forums > Forum Internet et Réseaux