> Tous les forums > Forum Forum des Webmasters
 Integration d'un bouton flash dans une page HTML
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Evangelius
  Posté le 26/08/2009 @ 23:09 
Aller en bas de la page 
Petit astucien

Bonsoir,

J'ai fabriqué un bouton flash mais je n'arrive pas a l'integrer voici mon code html :

<object class="boutonFlash" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0">
<param name="SRC" value="images/boutonFlash/BoutonNews1.swf">
<param name="QUALITY" value="high">

<embed src="images/boutonFlash/BoutonNews1.swf" pluginspage="http://www.macromedia.com/shockwave/download/" type="application/x-shockwave-flash width="200px" height="100px" quality="high" >
</embed>
</object>

Le bouton s'affiche correctement mais pas en taille réelle et un rectangle blanc en fond. Est ce que j'ai mal codé coté html ? est ce que je suis censé modifier quelquechose du coté du fichier swf ?

Arthur.

Publicité
Evangelius
 Posté le 26/08/2009 à 23:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Comme personne n'a l'air de vouloir répondre je vais rajouter des élements.

J'ai tenter de refaire mon bouton mais même schéma.

J'ai crée 4 images JPEG correspondant aux differents état de mon bouton.

J'ouvre macromedia, je fais new, je change les propriétés du document pour qu'il fasse la taille du mon bouton. Ensuite j'ouvre ma première jpeg avec macromedia, je fais un copier, je la colle dans mon fichier deja ouvert, je fais convert symbole, j'insere la framekey sur les trois autres états dans la sequence, avec des copiers collé je met mes differentes Jpeg, je test le bouton dans le menu controle, ça me crée un fichier en .swf et voila...

Deja premier pépin quand j'ouvre mes jpeg avec macromedia... les tailles ne sont plus les mêmes les boutons ont l'air beaucoup plus petit... je ne comprends pas pourquoi.. et ensuite quand je l'intègre dans ma page web j'ai toujours un rectangle blanc autour. J'augmente le width hop un coté du rectangle blanc a disparu sous le bouton mais va savoir pourquoi en hauteur la marge blanche a augmenté... et inversement...

ça m'énerve :p

Dreamer
 Posté le 27/08/2009 à 00:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Salut

Si ton bouton est sur fond blanc , c'est normal , car c'est un *.jpg , pour avoir une transparence , ce sera soit un *.gif ou un *.png

Par contre au niveau du flash , je ne serais d'aucune utilité !!

Evangelius
 Posté le 27/08/2009 à 00:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

le bouton flash est basé sur des images jpeg mais au final c'est une animation en swf je comprends pas

Dreamer
 Posté le 27/08/2009 à 06:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Evangelius a écrit :

le bouton flash est basé sur des images jpeg mais au final c'est une animation en swf je comprends pas

Ton animation va sur un fond , donnes donc la couleur de ce fond pour le fond de tes boutons !!

Evangelius
 Posté le 27/08/2009 à 10:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

j'ai trouvé.... les choses les plus bizarres proviennent des erreurs les plus simples... après plusieurs tentatives a tripatouiller le with et le heigt je me suis rendu compte que seul l'un des deux fonctonnait.. en effet la syntaxe était incorrecte :

Ancienne version :

<object class="boutonFlash" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0">
<param name="SRC" value="images/boutonFlash/BoutonNews1.swf">
<param name="QUALITY" value="high">

<embed src="images/boutonFlash/BoutonNews1.swf" pluginspage="http://www.macromedia.com/shockwave/download/" type="application/x-shockwave-flash width="200px" height="100px" quality="high" >
</embed>
</object>

Nouvelle :

<object class="boutonFlash"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,0,0">
<param name="SRC" value="images/BAzote.swf">
<param name="QUALITY" value="high">
<embed src="images/BAzote.swf"
pluginspage="http://www.macromedia.com/shockwave/download/"
type="application/x-shockwave-flash" width="200px" height="57x" quality="high" >
</embed>
</object>

Il manquait juste une guillement qui faisait que les propriétés étaient décalés et donc la dernière non reconnu...

Juste une dernière chose, je peux pas utiliser un bouton en image de fond ? parceque la j'ai un bouton sans texte, si j'ai 6 boutons a faire je vais devoir me rattaper les 6 animations a faire ? ( et les 24 jpeg avec 4 état par animation ). Je peux pas juste utiliser la vierge et coller un texte par dessus en html ? :p

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Probleme video flash dans page html
Affichage d'une page html dans un cadre flash
Bouton dans une page HTML pour copier un texte
affichage flash dans page HTML
pb bouton flash dans page php
pb bouton flash dans page php
Bouton RSS automatique dans page annonce Google site
Bouton PayPal dans site flash
Bouton Facebook dans sites Flash
Panorama 360° en swf dans une page en HTML
Plus de sujets relatifs à Integration d''un bouton flash dans une page HTML
 > Tous les forums > Forum Forum des Webmasters