> Tous les forums > Forum Linux
 Interdire l’accès réseau lors de la mise en veille
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
blobloblo
  Posté le 28/08/2015 @ 13:00 
Aller en bas de la page 
Petit astucien

Bonjour

Je suis sous Opensuse 13.2 , kde, quel logiciel me permettrait d' interdire l’accès réseau quand le pc est en veille et reconnecter automatiquement à la sortie de veille ?

Merci.



Modifié par blobloblo le 28/08/2015 13:09
Publicité
Logicien
 Posté le 28/08/2015 à 14:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

je pense qu'en regardant du côté de l'ACPI tu pourrais avoir un script qui s'exécuterait quand la mise-en-veille se lancerait et un autre lors de la restauration. Ça dépend surtout si la mise-en-veille et la restauration sont des événements captés par la norme ACPI.

Dépendant des outils que tu utilises, tu peux faire exécuter un script. Avec laptop-mode-tools c'est possible.

blobloblo
 Posté le 28/08/2015 à 18:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Il y aurait pas de programmes simple ou il y aurais juste quelques cases à cocher ?

Logicien
 Posté le 29/08/2015 à 03:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Les réseaux filiaires et sans fil sont des points sensibles lorsqu'on parle d'économie d'énergie. Si actuellement, ton réseau fonctionne aussi bien après la mise-en-veille qu'avant, tu peux songer à désactiver le réseau lors de la mise en veille.

Je me demande un peu pourquoi désactiver le réseau pendant la mise en veille puisque pendant cette période, personne n'accède à l'ordinateur. À moins que ce soit pour ne pas permettre aux processus actifs d'accéder au réseau.

Regarde dans la Configuration du Système de Kde. Il y a une section sur l'économie d'énergie. Peut-être qu'il est possible d'arrêter le réseau d'une manière quelconque. Si tu y arrives, il reste à savoir si le réseau pourra se réactiver de lui même sans problème.

blobloblo
 Posté le 29/08/2015 à 11:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Dans le gestion de l’énergie, j'ai une option scripte en bas, mais je sais pas du tout comment ça marche:

http://hpics.li/db5ee3f

Mon problème c'est que depuis une semaine mon pc fait planter ma box tv quand il se met en veille, gèle d'image ou écran noir, il y'a qu'en l' éteignant que je peux résoudre le problème.

Sur ce même switch j'ai également un pc sous Windows 7 et j'ai pas ce genre de désagrément quand il est en veille.

On m'a conseillé de trouver une solution pour désactiver le réseau lors de la mise en veille.



Modifié par blobloblo le 29/08/2015 12:28
Logicien
 Posté le 29/08/2015 à 12:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Es-tu certain que la plantage de ta box tv est lié au réseau? Ce pourrait être aussi un problème d'affichage. Comme je ne suis pas français, la box ne me dit pas grand chose. Je sais qu'il y a des paramètres qui peuvent être passés au module vidéo Linux pour supporter ou non la sortie TV. Quelle carte graphique as-tu?

Je ne peux pas t'aider avec certitude. Il faudrait que tu fasses des recherches sur Linux et ta configuration matérielle.

blobloblo
 Posté le 29/08/2015 à 13:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Ma carte graphique est une Geforce Gt520, je dispose du pilote libre, Gallium 0.4 on NVD9 , je ne veux plus du propriétaire car ils m' a causé trop de problèmes.



Modifié par blobloblo le 29/08/2015 13:16
Logicien
 Posté le 29/08/2015 à 15:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Le module nouveau du côté du noyau Linux a deux paramètres qui concernent la sortie tv:

modinfo -p nouveau
tv_norm:Default TV norm.
Supported: PAL, PAL-M, PAL-N, PAL-Nc, NTSC-M, NTSC-J,
hd480i, hd480p, hd576i, hd576p, hd720p, hd1080i.
Default: PAL
*NOTE* Ignored for cards with external TV encoders. (charp)
vram_pushbuf:Create DMA push buffers in VRAM (int)
nofbaccel:Disable fbcon acceleration (int)
tv_disable:Disable TV-out detection (int)
ignorelid:Ignore ACPI lid status (int)
duallink:Allow dual-link TMDS (default: enabled) (int)
pstate:enable sysfs pstate file, which will be moved in the future (int)
config:option string to pass to driver core (charp)
debug:debug string to pass to driver core (charp)
noaccel:disable kernel/abi16 acceleration (int)
modeset:enable driver (default: auto, 0 = disabled, 1 = enabled, 2 = headless) (int)
runpm:disable (0), force enable (1), optimus only default (-1) (int)
agpmode:AGP mode (0 to disable AGP) (int)

Si tu ne trouves pas la norme qui est la tienne avec le paramètre tv_norm, il est possible de désactiver la détection de la sortie TV pour l'affichage avec le paramètre tv_disable . À toi de choisir. Je ne garantie rien. Côté Xorg, le module nouveau n'a pas de paramètre concernant la TV.

blobloblo
 Posté le 30/08/2015 à 11:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Pas de changement. avec la commande: modinfo -p nouveau:

modinfo -p nouveau

tv_norm:Default TV norm.

Supported: PAL, PAL-M, PAL-N, PAL-Nc, NTSC-M, NTSC-J,

hd480i, hd480p, hd576i, hd576p, hd720p, hd1080i.

Default: PAL

*NOTE* Ignored for cards with external TV encoders. (charp)

tv_disable:Disable TV-out detection (int)

ignorelid:Ignore ACPI lid status (int)

duallink:Allow dual-link TMDS (default: enabled) (int)

nofbaccel:Disable fbcon acceleration (int)

agpmode:AGP mode (0 to disable AGP) (int)

vram_pushbuf:Create DMA push buffers in VRAM (int)

config:option string to pass to driver core (charp)

debug:debug string to pass to driver core (charp)

noaccel:disable kernel/abi16 acceleration (int)

modeset:enable driver (default: auto, 0 = disabled, 1 = enabled, 2 = headless) (int)

runpm:disable (0), force enable (1), optimus only default (-1) (int)



Modifié par blobloblo le 30/08/2015 11:14
Publicité
Logicien
 Posté le 30/08/2015 à 12:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

La commande 'modinfo -p' ne modifie rien à la configuration. Elle ne fait qu'afficher les différents paramètres d'un module, ici le module nouveau et les valeurs possibles que peuvent prendre chaque paramètre. Ce n'est qu'une commande informative comme son nom l'indique: module information.



Modifié par Logicien le 30/08/2015 12:27
blobloblo
 Posté le 30/08/2015 à 17:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Dans l'info, tv est déjà sur Disable, donc il y a rien a faire ?

sinon, c'est pas grave je repasse en cpl, j'avais mis en Ethernet pour palier a un autre problème.

Logicien
 Posté le 30/08/2015 à 19:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Pour voir la valeur actuelle de chacun des paramètres du module nouveau, tu fais

sudo more /sys/module/nouveau/parameters/*

et tu fais Entrée pour voir la valeur du paramètre suivant, ainsi de suite jusqu'à la fin des paramètres.



Modifié par Logicien le 30/08/2015 20:00
blobloblo
 Posté le 31/08/2015 à 11:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

voici se que ca donne: http://hpics.li/8bbcee8

mais une fois trouvé, je n'arrive pas à ouvrir, je clic sur entrée, puis une autre ligne s’affiche ainsi de suite:



Modifié par blobloblo le 31/08/2015 11:34
Logicien
 Posté le 31/08/2015 à 15:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Le répertoire /sys contient le système de fichiers virtuel sysfs. Les paramètres des modules ne peuvent pas être modifiés dynamiquement. Pour se faire, il faut passer les valeurs au noyau Linux dès le démarrage. Si tu veux continuer et désactiver le support de la sortie TV pour le module nouveau, il faudrait que tu affiches la sortie de la commande

sudo grep -ir nouveau /etc/modprobe.d/*

Avec cette sortie, on pourra savoir si le module nouveau a déjà ses paramètres configurés. C'est nécessaire de le savoir avant toute nouvelle modification des paramètres du module nouveau.

blobloblo
 Posté le 02/09/2015 à 13:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

La commande [sudo grep -ir nouveau /etc/modprobe.d/*] me donne rien.



Modifié par blobloblo le 02/09/2015 13:15
Logicien
 Posté le 03/09/2015 à 03:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Alors, ça veut dire que seules les options par défaut du module nouveau sont utilisées. Pour faire simple, exécute les commandes suivantes:

sudo echo 'options nouveau modeset=1 tv_disable=1' > /etc/modprobe.d/nouveau.conf

sudo update-initramfs -k $(uname -r) -u

Après avoir redémarré, assure-toi que les paramètres modeset et tv_disable du module nouveau sont à 1 en exécutant comme précédemment la commande

sudo more /sys/module/nouveau/parameters/*

Si oui, alors essai la mise-en-veille. C'est la seule possibilité de solution que j'ai à te proposer pour l'instant.



Modifié par Logicien le 03/09/2015 03:47
blobloblo
 Posté le 08/09/2015 à 10:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Désolé pour le temps de réponse, un problème technique, je n'avais plus internet depuis un certain temps.

- La première commande ne m'a rien donné

- La deuxième commande ne passe pas, j'ai ce message: If 'update-initramfs' is not a typo you can use command-not-found to lookup the package that contains it, like this:

cnf update-initramfs

J'ai cherché sur google cette commande, je ne l'ai pas trouvé, il n y a t-il pas une erreur ?



Modifié par blobloblo le 08/09/2015 11:15
Publicité
Slyvester
 Posté le 08/09/2015 à 11:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Sans vouloir marcher sur les plates-bandes de Logicien, j'utilise personnellement la commande suivante : sudo update-initramfs -u -k all

https://doc.ubuntu-fr.org/plymouth



Modifié par Slyvester le 08/09/2015 11:57
Logicien
 Posté le 08/09/2015 à 16:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je me suis complètement mépris. Je pensais que tu utilisais Linux Mint. Avec OpenSuse il se peut que ce soit la commande dracut qui génère un initramfs. Comme je ne suis pas familier avec OpenSuse, le fichier créé /etc/modprobe.d/nouveau.conf va pouvoir être utilisé lorsque le noyau Linux sera mis à jour ou au mieux, après un redémarrage.

Entre temps, fait une recherche sur la méthode qu'utilise OpenSuse pour générer/mettre à jour un initramfs. Je vais voir de mon côté aussi. Je précise que ce n'est qu'un essai. L'économie d'énergie sous Linux ce n'est pas une ciné-cure dans plus d'un scénario.



Modifié par Logicien le 08/09/2015 16:41
blobloblo
 Posté le 08/09/2015 à 16:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

avant d'installer, pour pas qu'il y ai de problèmes, je suis pas sur Mint mais Opensuse, je peux y aller, ou il y a une autres méthode ou quelque chose qui est déjà installé sur Opensuse ?

Logicien
 Posté le 08/09/2015 à 18:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Tu as lu mon message avant que je le corrige. Je me suis mépris, j'ai pensé que tu étais sous Linux Mint. Il faut relire mon avant dernier message.

blobloblo
 Posté le 09/09/2015 à 13:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

voici ce que ça donne:

update-dracut -u -k all

If 'update-dracut' is not a typo you can use command-not-found to lookup the package that contains it, like this:

cnf update-dracut

Publicité
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Ubuntu / Window 7 Plus de mise en veille.
Arch : pb de mise en veille de la souris
problème de grub lors de la mise à niveau 11.04
Mise en veille - Hibernation
Mise en veille
Pavé numérique et mise en veille sous Ubuntu
Probleme lors de la mise a jour de kubuntu
Problème hibernation et mise en veille kubuntu
Mise en veille PC sous Mandriva 2006
Mise en veille DD
Plus de sujets relatifs à Interdire l’accès réseau lors de la mise en veille
 > Tous les forums > Forum Linux