> Tous les forums > Forum Bureautique
 interdire une valeur dans une cellule en fonction d'une autre celluSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
valpat35
  Posté le 27/10/2013 @ 19:37 
Aller en bas de la page 
Petit astucien

Bonjour

dans Excel 2010

De la cellule A30 à A39 j'ai une liste de 10 personnes représenté par une lettre (A, C ,V, etc..)

De la cellule D30 à D39, je rentre la lettre des personnes absentes.

Comment faire pour interdire de rentrer des personnes absentes de la cellules B30 à B39 (liste des personnes présentes)

je me sert de cette liste (b30 à b39) pour la validation des données dans mon tableau

merci pour votre aide

Publicité
ferrand
 Posté le 27/10/2013 à 19:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

Pas très clair. Un modèle serait bienvenu.

valpat35
 Posté le 27/10/2013 à 21:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Pardon ,quand on est plongé dans son fichier cela semble évident.

voici le lien pour le fichier http://cjoint.com/?CJBvjhImy7w

j'ai trouvé partiellement une solution en appliquant une MFC sur les doublons pour les détecter.

il y a t'il une autre solution?

ferrand
 Posté le 27/10/2013 à 22:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je pensais que les présents (B) devaient obligatoirement figurer dans la liste en A. Mais ce ne semble pas être le cas si l'on peut mettre un présent qui ne figure pas en A ?

DjiDji59430
 Posté le 27/10/2013 à 23:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

C'est pas plus simple en mettant une croix derrière le nom dans la colonne "présent", les absents étant ceux qui ne sont pas présents ???

ferrand
 Posté le 28/10/2013 à 02:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

DjiDji59430 a écrit :

C'est pas plus simple en mettant une croix derrière le nom dans la colonne "présent", les absents étant ceux qui ne sont pas présents ???

Sur le principe c'est certainement le mieux ! On peut sans doute étoffer selon ce qu'on veut obtenir, ou inverser ("les présents sont ceux qui ne sont pas absents"), à voir selon l'ordre de saisie et les particularités éventuelles...

valpat35
 Posté le 28/10/2013 à 06:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour

les présents doivent effectivement être présent en liste A (la lettre P rentré dans la liste des présents est une erreur )

je préfère les lettres au croix car cela colle de plus près a l'ancien tableau physique (les habitudes ont la vie dure).

ferrand
 Posté le 28/10/2013 à 10:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Si la référence est la liste de départ (A30:A39), vu la constitution de ton tableau, le plus simple est de respecter cette liste au niveau des lignes :

• On considère que les médecins de la liste sont présents tant qu'ils ne sont pas notés absents : en B30, formule :

=SI(ET(A30<>"";D30="");A30;"") à étendre jusqu'en B39.

Ainsi les médecins listés en A sont portés présents et disparaissent de la liste des présents lorsqu'on les porte absents.

A compléter par une formule de validation pour les absents de façon qu'on ne porte pas un autre nom sur la ligne :

Sélectionner D30:D39 > Données > Validation des données > Autoriser: choisir Personnalisé > Formule: taper =A30=D30 > Valider. (Seule la valeur en A sera acceptée à la saisie).

• On peut inverser : considérer que les médecins de la liste sont absents tant qu'ils ne sont pas portés présents... Le principe est le même.

• Si l'on veut continuer à saisir les présents et les absents, sans respecter l'alignement avec la liste A, on peut empêcher de porter deux fois le même nom tant en présent qu'en absent par une formule de validation :

A partir d'une sélection B30:B39 et D30:D39, la formule personnalisée : =NB.SI($B$30:$B$39;B30)+NB.SI($D$30:$D$39;B30)=1 empêchera de saisir deux fois le même nom.

• Autres méthodes en utilisant des macros évènementielles...

valpat35
 Posté le 28/10/2013 à 14:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci beaucoup, cela fonctionne à merveille.

c'est exactement ce que je cherchais

bonne journée et à + sur le Forum

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Effacer cellule par rapport a la valeur d'une autre
Recopie cellule dans un autre classeur
afficher une cellule en fonction d'une autre cellule
Calculer date en fonction d'une valeur dans une plage de cellules
Excel: valeur cellule impliquée dans calcul ailleurs -> connexions
copier une cellule dans un autre classeur
rechercher une valeur de cellule suivant une autre
affecter une valeur calculée dans une cellule
EXCEL MAJImpacter valeur cellule sur autre cellule
Excel 2007 résultat formule dans une autre cellule
Plus de sujets relatifs à interdire une valeur dans une cellule en fonction d''une autre cellu
 > Tous les forums > Forum Bureautique