> Tous les forums > Forum Bureautique
 les divers numéros qu'on retrouve dans une plageSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
williamsss
  Posté le 01/12/2014 @ 20:34 
Aller en bas de la page 
Petit astucien

Bonjour,

Avec Excel sans utiliser les macros, comment peut on faire apparaître dans des cellules à la suite (gauche à droite) les divers numéros qu'on retrouve dans une plage (b24:f31) sans qu'ils apparaissent en double ??

Merci

Williams

Publicité
DjiDji59430
 Posté le 01/12/2014 à 21:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Comme toujours, essayer de joindre un fichier exemple (ou pas) avec le résultat à atteindre et les commentaires.


Ce que j'ai ==>ce que je voudrais.


A la limite, pourquoi ?


Cela aide beaucoup à la compréhension de la question.

Aller sur http://www.cjoint.com/ par exemple pour uploader le fichier et redonner ici le lien obtenu.

La personne qui désire intervenir n'est pas obligée de recréer le fichier !

williamsss
 Posté le 01/12/2014 à 21:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Voici un exemple : http://cjoint.com/?0LbvIS5HoEe

Il y a une liste à gauche avec une plage en jaune comme exemple. La ligne à droite est ce que je tente de faire suite à une formule c'est à dire que cela recherche et nous donne les numéros dans la plage en jaune sans redonner les numéros en double ou... comme le 2, 20... qui y sont 2 fois. Ainsi en tirant les cellules (la ligne de droite) cela me calculerait tout concernant la plage de 9 lignes décalées vers le bas c'est à dire à la ligne 38 la plage B24:F32 etc.

Et ceci il faudrait que cela puisse le calculer sans macro.

Merci

Williams

ferrand
 Posté le 02/12/2014 à 07:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Une solution en ligne 35 (qui ne répond pas tout à fait à la question, car elle classe les valeurs en ordre décroissant).

En G (mais peut être mis n'importe où), calcul du nombre de valeurs différentes à lister :
=SOMMEPROD(--(1/NB.SI($B$23:$F$31;$B$23:$F$31)))

En H, la plus grande valeur à lister : =MAX($B$23:$F$31)

En I (à tirer jusqu'en AT ou au-delà) : =SI(COLONNES($H$35:H35)<$G$35;GRANDE.VALEUR($B$23:$F$31;NB.SI($B$23:$F$31;">="&H35)+1);"")

http://cjoint.com/?DLchNUr7ALv

williamsss
 Posté le 02/12/2014 à 13:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
ferrand a écrit :

Bonjour,

Une solution en ligne 35 (qui ne répond pas tout à fait à la question, car elle classe les valeurs en ordre décroissant).

En G (mais peut être mis n'importe où), calcul du nombre de valeurs différentes à lister :
=SOMMEPROD(--(1/NB.SI($B$23:$F$31;$B$23:$F$31)))

En H, la plus grande valeur à lister : =MAX($B$23:$F$31)

En I (à tirer jusqu'en AT ou au-delà) : =SI(COLONNES($H$35:H35)<$G$35;GRANDE.VALEUR($B$23:$F$31;NB.SI($B$23:$F$31;">="&H35)+1);"")

http://cjoint.com/?DLchNUr7ALv

Bonjour Ferrand,

Je te remercie bp

En enlevant les $ avant les chiffres représentant les lignes tout fonctionne bien car en tirant la ligne vers le bas cela calcule tout en décalant d'une ligne la plage.

Comme tu dis cela classe les valeurs en décroissant ce qui est pas trop grave, mais juste au cas est-ce qu'avec une petite modification (peut-être de signe ">" ou...) il serrait possible d'avoir le même résultat en ordre croissant ??

Merci

Williams

williamsss
 Posté le 02/12/2014 à 13:39 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Je viens de voir que pour faire que cela apparaît en ordre croissant et non décroissant il suffirait de modifier les 2 formules :

En H : =MIN($B23:$F31) au lieu de =MAX($B23:$F31)

Puis en I et les autres cellules : =SI(COLONNES($H35:H35)<$G35;PETITE.VALEUR($B23:$F31;NB.SI($B23:$F31;"<="&H35)+1);"") donc mettre PETITE.VALEUR au lieu de GRANDE.VALEUR et mettre < au lieu de > à la fin de la formule.

merci

Williams

ferrand
 Posté le 02/12/2014 à 17:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

En effet, pour ordre croissant...

Si tu tires vers le bas au lieu de tirer latéralement, il faut adapter !

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
nb de liens dans une plage appartennant à la même ligne Horiz. ou verti...
trier numéros dans plusieurs colonnes
Calculer date en fonction d'une valeur dans une plage de cellules
Excel: Chercher l'emplacement de la valeur maximale dans une plage
une seule lettre dans la cellule dans plage B:F
comment inserrer les numeros romains dans word
utiliser résultat formule dans réf. plage cellules
copier plage excel 2003 coller dans word + m en p
activer une plage de celluel dans excel
numéros de pages non mis à jour dans sommaire *.do
Plus de sujets relatifs à les divers numéros qu''on retrouve dans une plage
 > Tous les forums > Forum Bureautique