> Tous les forums > Forum Bureautique
 LibreOffice Calc Formule en SISujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
molo2003
  Posté le 05/01/2019 @ 10:19 
Aller en bas de la page 
Petit astucien

Bonjour et Bonne année 2019 à vous tous.

je suis sous LibreOffice identique à OpenOffice j'espère.

Je viens ici poser une question basique pour afficher la date de jour et surtout la figer sur un tableur.
Je vous explique mon cas basique en décrivant le contenu de mes cellules et le résultat que je veux atteindre.
Cellule 1 (A1) Cellule 2 (B1) Cellule 3 (C1)
Format date Format nombre Format texte
"Formule en =SI ..." N° Chéque Nom

Vous avez compris: en A1 je veux inscrite la date de saisie automatique (par =SI(...) quand j'ai entré le N° de chèque mais je voudrais figer cette date car la formule en A1 que je rentre
est: =SI(B1>0;AUJOURDHUI();"") Avec cette formule, [b]chaque jour que j'ouvre mon classeur la date est remise à jour alors que je voudrais figer la date d'inscription de l'enregistrement de l'adhésion pour notre petite association. Mon idée serait une formule en A1 dont l'expression serait "Si B1>0 et C1<>"", afficher la date du jour sinon "ne rien faire"
Formule que j'ai écrite =SI(ET(B1>0;C1="");AUJOURDHUI();;) Cette formule là, provoque 'ERR 504
L'action "ne rien faire " n'est pas prévue dans l'expression du SI. Il fait quelque chose suivant le test VRAI ou FAUX.


Vous vous savez la formule adéquate. Eviter de passer par une macro.

Merci d'avance de votre aide

Publicité
poussebois
 Posté le 05/01/2019 à 10:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour ,

Calc de LibreOffice et d'OpenOffice, c'est identique. Idem avec Excel d'ailleurs pour ce qui concerne ce problème bien connu.

Sans passer par une macro : je vois 2 possibilités, mais les 2 nécessitent une manipulation.

  • 1. Tu gardes ta formule avec AUJOURDHUI(), puis après avoir rempli une ligne (ligne 3 par exemple), en A3, tu fais un copie/collage spécial ou tu ne prends que la valeur et non la formule.
  • 2. Le plus simple à mon avis : après avoir rempli une ligne (ligne 3 par exemple), en A3, tu appuies simultanément sur "Ctrl" et ";". La date du jour s'affiche et reste figée.

@ +

pouyou
 Posté le 05/01/2019 à 15:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci poussebois pour le "ctrl" et ";" que je ne connaissait pas.

pouyou

molo2003
 Posté le 05/01/2019 à 19:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir a vous;

En effet trés bonne proposition de poussebois.

CTRL et ; un raccourci qu'il faut connaître

Grand merci a toi poussebois;

poussebois
 Posté le 05/01/2019 à 20:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonsoir ,

Alors, si tu es satisfait et considère ton problème réglé, tu peux mettre ton sujet en RESOLU.

@ +

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Formule LibreOffice.Calc
LibreOffice Calc: affichage de date
In-serrer un titre avec LibreOffice calc
LibreOffice 5.3.7.2 Calc : pas de menu insertion champ
Affichage dans libreoffice calc
Libreoffice calc couleur de caractère
Feuille calc LibreOffice
Isérer des liens avec LibreOffice Calc
Formule dans Openoffice Calc
OpenOffice Calc et formule
Plus de sujets relatifs à LibreOffice Calc Formule en SI
 > Tous les forums > Forum Bureautique