> Tous les forums > Forum des Webmasters
 lien qui fonctionne avec IE7 et pas avec Firefox
Ajouter un message à la discussion
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]
mm91
  Posté le 05/10/2010 @ 15:51 
Aller en bas de la page 
Astucien

Bonjour,

Sur le site de notre club :

http://psucvollibre.free.fr/

sur la page d’accueil un visiteur qui utilise Firefox me dit que les 3 photos à gauche ne sont pas visibles, et surtout que le lien « Eole (récit de vols) » conduit à une erreur 404.

Pour lui le lien direct http://psucvollibre.free.fr/Eole/ fonctionne, mais ne fonctionne pas depuis la page d’accueil.

Depuis la page d’accueil il me dit que ce lien donne «….Eole\ » au lieu de « …Eole/ »

Depuis chez moi, avec IE7, tout fonctionne parfaitement (avec « / » et avec « \ »)

Que peut-il se passer ?

Publicité
griggione
 Posté le 05/10/2010 à 17:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Bonjour mm91


Tout marche bien

Demande lui quelle version de FF il a.

griggione
 Posté le 05/10/2010 à 17:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

RE

Et pour IE passe trés bien avec : 5.5, 6, 7 et 9

Pour le 8 j'ai pas l'affichage, voir avec quelqu'un d'autre.



Modifié par griggione le 05/10/2010 17:27
elle
 Posté le 05/10/2010 à 18:02 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

Pas de problème pour IE8 non plus.

mm91
 Posté le 05/10/2010 à 19:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Merci pour vos réponses.

Il utilise firefox 3.0.5

elle
 Posté le 05/10/2010 à 19:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

Il serait temps qu'il fasse une mise à jour! On en est à la version 3.6.10.

mm91
 Posté le 06/10/2010 à 16:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je vous mets ci-dessous le dernier échange de mail avec mon copain, ce sera plus simple.

Je lui ai suggéré de continuer la discussion ici.

Vos commentaires et suggestions bienvenues.

- lui (le pleignant) en noir

- moi (le webmaster) en bleu

> Ok, l'assistance informatique de l'XXXX m'a dit avoir testé l'accès au

> site avec les versions 3.5.5, 3.6.6 et 3.5.8 (celle qui est proposée aux

> utilisateurs), avec le même problème rencontré. la phrase "version 3.0.5"

> s'affiche sur mon écran en cliquant sur "?" et "à propos de firefox", mais

> du coup je ne sais pas si c'est bien cette version que j'utilise, ou une

> autre plus récente.

Ce n'est pas très clair !

Quand tu cliques sur "?" dans n'importe quel logiciel c'est obligatoirement la version qui s'affiche que tu utilises.

Comment pourrait-il en être autrement ? Ce N° de version étant gravé dans la version elle-même.

Il serait bien étonnant (et surtout parfaitement illégal) que ton assistance Informatique (XXXX=grande entreprise publique) s'amuse à "cracker" un logiciel pour y mettre un faux N° de version !!

> Quoi qu'il en soit, il semble que l'accès au site, quand il a été

> enregistré sous ie7, ne soit pas compatible avec firefox (ce navigateur a

> été retenu à l'XXXX, et aussi entre autre par les impôts, pour des

> raisons de sécurité et d'utilisation sous linux).

> Peux-tu envisager de changer de navigateur, et remettre à jour le site ?!

Encore une fois le navigateur n’y est pour rien dans l’écriture ou les modifications d’un site Internet.

A aucun moment le site n’est « enregistré sous IE7 ».

Le navigateur n’intervient qu’à la lecture (chez l’hébergeur) du site.

Il est possible que cette lecture soit légèrement différente suivant les navigateurs.

A mon avis, soit à cause de la configuration faite par l’utilisateur ou éventuellement à cause d’une version obsolète de son navigateur.

Donc, si je change de navigateur il est possible que je vois le site (chez l'hébergeur) un peu différemment, mais en aucun cas cela changera quelque chose sur le site et la façon dont le voient les autres Internautes.

Lorsque j’écris sur le site je n’utilise aucun navigateur.

J’utilise seulement le langage html et un ftp (File Zilla) pour transférer sur site.

Je n'essaye absolument pas de me débarrasser du problème en rejetant la faute sur ton navigateur.

Je dis simplement ceci:

Il est tout à fait possible que certains codes html que j'utilise soient mal reconnus par certains navigateurs.

Comme toujours en informatique il faut chercher des deux côtés.

De mon côté je ne trouve pas, actuellement, de moyens de savoir quels sont les codes éventuellement en cause(*)

De ton côté il subsiste quelques suspicions:

- version obsolète de ton navigateur ? (en général l'évolution des versions va dans le sens d'une meilleure lecture de tous les code html, il ne faut donc pas s'en priver en cas de problème)

- configuration (personnelle ou par ta boîte) de ton navigateur (voir notamment dans "outils / options Internet": il y a des tas de filtrages possible)

- filtrage par ton entreprise (moins probable puisque ça ne marche pas non plus chez ta copine avec firefox (quelle version chez ta copine ?))

(*) à ce propos, lorsque tu lis la page d'un site Internet tu peux afficher le codage html ("Affichage / source"); un bon informaticien de ton assistance informatique peut peut-être y jeter un oeil et y repérer des défauts ?

Enfin, pour être tout à fait honnête, je rajoute ceci:

Le site a été fait par Denis.

Quand il m'a refilé le bébé, il ne m'a pas fourni l'outil de création/gestion de site utilisé par lui.

Pour les légères mises à jour que j'y fais, je fais donc:

- soit des modif directement en html (uniquement des modif de texte, pas de modif de code)

- soit des modif sous Word et en faisant ensuite "enregistrer sous html"

et c'est peut-être là que le bas blesse: les informaticiens vont lever les bras au ciel sur cette méthode qui conduit à des codes html très lourds (peut-être la cause de nos problèmes ?).

La solution que j'envisage est de refaire moi-même complètement le site avec un outil de création de site (celui de Denis ou un autre, mais je préfère choisir moi-même).

Mais en attendant on essaye de se débrouiller et surtout de comprendre (c'est ce qui m'intéresse)

griggione
 Posté le 06/10/2010 à 16:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

RE

Houlala tu confonds tout là.

Les versions données ce matin sont les versions de internet explorer.
Toujours est-t-il que nous sommes plusieurs à bien voir le site, accueil et lien proposé, donc si de son coté il voit mal, c'est de son coté qu'il faut regarder.
Et regarder coté navigateur, donc FF, qu'il passe à la dernière version.

cebe
 Posté le 08/10/2010 à 07:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Certes FF d'une version antérieure peut être coupable, cependant il faut vérifier le code de la page aussi. Un espace, une majuscule, par exemple et FF interprête à sa façon un signe que les autres navigateurs voient d'une autre manière !

Publicité
elle
 Posté le 08/10/2010 à 08:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

cebe a écrit :

Certes FF d'une version antérieure peut être coupable, cependant il faut vérifier le code de la page aussi. Un espace, une majuscule, par exemple et FF interprête à sa façon un signe que les autres navigateurs voient d'une autre manière !

Oui, mais comme nous on voit très bien la page avec Firefox...

cebe
 Posté le 08/10/2010 à 08:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour Elle, et les autres,

Certes,

cependant je remarque un "E" dans le nom du dossier Eole, ce qui peut paertuber une vieille version d'un navigateur. Peut-être qu'un test sur le site "http://browsershots.org/" rendrait de fiers services ?

Qu'en pensent les grands pontes de PCA ?

elle
 Posté le 08/10/2010 à 09:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

Ben tiens, je viens de réussir à avoir ça dans Firefox : http://psucvollibre.free.fr/Eole\.

Je le jure, ça fonctionnait avant.

mm91
 Posté le 08/10/2010 à 09:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
elle a écrit :

Ben tiens, je viens de réussir à avoir ça dans Firefox : http://psucvollibre.free.fr/Eole\.

Je le jure, ça fonctionnait avant.

merci de continuer à chercher, mais j'avoue que j'ai de la peine à suivre:

tu nous donnes un lien en nous disant qu'il fonctionnait avant, mais NOUS, ce lien on le lit avec NOTRE navigateur !

De plus ce lien est l'adresse DIRECTE de la page "Eole". Ce lien direct a toujours fonctionné, y compris chez mon copain.

Le problème est le non fonctionnement de ce lien quand on clique sur "Eole" DANS LA PAGE D'ACCUEIL

elle
 Posté le 08/10/2010 à 09:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

mm91 a écrit :

Le problème est le non fonctionnement de ce lien quand on clique sur "Eole" DANS LA PAGE D'ACCUEIL

Ben c'est justement ce qui s'est produit chez moi, avec le \ à la fin de l'adresse : http://psucvollibre.free.fr/Eole%5C.

(C'est l'éditeur de message du forum qui a mal interprété le lien que j'ai mis.)

Donc j'ai réussi à reproduire le problème, mais pourquoi et comment, fouille-moi, ça fonctionnait avant.



Modifié par elle le 09/10/2010 06:25
griggione
 Posté le 09/10/2010 à 06:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

RE

+1 avec elle , vous avez modifié quelque chose.
On voyait tout trés bien et maintenant l'accueil n'a plus d'image ???

elle
 Posté le 09/10/2010 à 06:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

griggione a écrit :

On voyait tout trés bien et maintenant l'accueil n'a plus d'image ???

Exact! Donc je n'ai pas la berlue.

mm91
 Posté le 09/10/2010 à 06:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

je n'ai absolument rien changé depuis le début de ce message.

Il doit y avoir un truc qui un coup passe, un coup ne passe pas ?

Publicité
griggione
 Posté le 09/10/2010 à 07:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien
elle a écrit :
griggione a écrit :

On voyait tout trés bien et maintenant l'accueil n'a plus d'image ???

Exact! Donc je n'ai pas la berlue.

RE

Que tu ais besoin d'un quadruple foyers, bon, mais la berlue NON.

Et puis je pouvais pas laisser elle seule "face à l'adversité"

Dreamer
 Posté le 09/10/2010 à 07:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Salut

Pourquoi des liens comme ceux là :psucvollibre.free.fr/images\VolLibre.jpg et non images/VolLibre.jpg , le second fonctionne mais pas le premier ......

griggione
 Posté le 09/10/2010 à 07:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

RE

Non seulement il y a l'anti-slash (seulement sur le lien de éole) pas trop grave car si en dernier les serveurs corrigent, mais surtout il y a un point et ça c'est du 404

http://psucvollibre.free.fr/Eole\.

Ouupppsss en plus du problème des images comme expliqué par Dreamer



Modifié par griggione le 09/10/2010 07:35
elle
 Posté le 09/10/2010 à 07:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

Il manque le html après le point, en plus... Ou en moins, c'est selon...



Modifié par elle le 09/10/2010 07:36
mm91
 Posté le 09/10/2010 à 08:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

je viens de remettre en page d'accueil ( http://psucvollibre.free.fr/ ) la page originelle telle qu'elle était avant que je ne prenne en main le site.

Est-ce que les trois photos, à gauche, apparaissent ?

Est-ce que le lien "Eole" depuis cette page fonctionne ?

Si ça ne fonctionne pas je ferais quelques bidouille sur les "." et les "\" (merci de me résumer ce qu'il faut y faire).

elle
 Posté le 09/10/2010 à 08:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grande Maîtresse astucienne

Ça fonctionne chez moi.

griggione
 Posté le 09/10/2010 à 08:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

RE

+1

Ouupppsss j'y pense, faut vider les caches de temps en temps.



Modifié par griggione le 09/10/2010 08:25
griggione
 Posté le 09/10/2010 à 08:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien
mm91 a écrit :

Si ça ne fonctionne pas je ferais quelques bidouille sur les "." et les "\" (merci de me résumer ce qu'il faut y faire).

RE

Les \ existent sur le PC pas sur le net.
Et les . pour les extentions, .html, .asp, .php, .css, etc.

mm91
 Posté le 09/10/2010 à 08:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

OK, merci.

Vous pouvez remarquer quand même dans le fichier source qu'il y a aussi un "." après "Eole/"

Mais ce fichier est infiniment plus simple que le précédent !

Il faut donc que je m'y mette et que je refasse le site avec un outil adhoc.

Je pense que l'utilisation de Word (converti ensuite en html) fonctionne bien (c'est ce que je fais sur mon site météo ici: http://icare.cinq.free.fr/meteo/ )

mais si le site a été fait avec un autre outil, il ne faut pas y faire des modifs avec Word (converti ensuite en html).

Qu'en pensez-vous ?

Publicité
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
59,99 €Casque de jeu SteelSeries Arctis 3 à 59,99 €
Valable jusqu'au 27 Septembre

Amazon fait une promotion sur le très bon casque de jeu SteelSeries Arctis 3 qui passe à 59,99 € au lieu de 80 €. Il a été conçu pour jouer partout avec un son, un confort et un style de qualité supérieure sur toutes les consoles de jeu, dont PlayStation 4, Xbox One, Nintendo Switch et appareils mobiles. Vous pouvez aussi le brancher sur PC via les ports jack audio et micro.

Il comporte un micro que vous certifié Discord vous donne une clarté de voix de qualité studio et élimine les bruits de fond en jeu. Il est amovible.


> Voir l'offre
34,99 €Souris sans fil Logitech G603 Lightspeed Gaming à 34,99 €
Valable jusqu'au 28 Septembre

Cdiscount fait une promotion sur la souris sans fil Logitech G603 Lightspeed Gaming qui passe à 34,99 € au lieu de 60 € ailleurs. Dotée du capteur HERO, vous allez connaitre une précision exceptionnelle grâce à sa sensibilité pouvant aller jusqu'à 12 000 dpi.

La G603 est également équipée de la technologie sans fil Lightspeed qui permet des performances sans fil de niveau professionnel et une fiabilité inégalée, surpassant même certaines des meilleures souris gaming filaire. De plus, son design ergonomique est conçu pour s'adapter parfaitement à votre main afin que vous puissiez jouer des heures sans la moindre gêne.La livraison est gratuite.


> Voir l'offre
- 10 €10 € de réduction à partir de 20 € d'achats chez Rakuten pour les nouveaux clients
Valable jusqu'au 10 Octobre

Rakuten propose pour les nouveaux clients une offre de parrainage vous permettant de bénéficier de 10 € de réduction immédiate à partir de 20 € d'achats. Rakuten est une plateforme qui vous permettra d'acheter aussi bien des produits informatiques et Hi-Tech que des livres, des disques ou des jeux vidéos d'occasion.


> Voir l'offre

Sujets relatifs
[résolu] Un JS ne fonctionne pas avec Firefox?
Formulaire qui ne fonctionne pas avec Joomla
Visualiser son site en 3D avec Firefox 11
Pb d'affichage de mon site avec FireFox
CSS ok avec IE mais pas avec Google/Firefox
Son avec Firefox
images tournantes avec lien
police énorme avec firefox et pas avec IE
Problèmes de couleurs avec FireFox...
Affichage incorrect avec firefox
Plus de sujets relatifs à lien qui fonctionne avec IE7 et pas avec Firefox
 > Tous les forums > Forum Forum des Webmasters