> Tous les forums > Forum Linux
 Linux Mint 17 et Cinnamon : activation du pavé numériqueSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Mimile
  Posté le 20/05/2015 @ 11:42 
Aller en bas de la page 
Astucien

Bonjour,

Ma Debian Wheezy étant totalement irrécupérable, je l'ai remplacée par la dernière version de Linux Mint (17-1) et j'ai opté par curiosité pour Cinnamon comme WM.

Sous Gnome, l'activation du pavé numérique était simple : téléchargement de numlockx et ajout de deux ou trois lignes de code dans le fichier /etc/gdm/Init/Default

Quelqu'un pourrait-il me dire comment faire sous Cinnamon vu que le fichier en question n'existe pas ?

Accessoirement, existe-t'il un forum spécifique en français vu que toutes les recherches que j'ai faites avec Google m'amène sur un forum exclusivement british ...

Merci d'avance pour vos réponse.

Publicité
hido
 Posté le 20/05/2015 à 12:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour

taper cette commande

numlockx on

en principe ça activera tout le temps le pavé numérique

Le site fr de linux mint n'existe plus apparemment, j'aimerais bien savoir pourquoi

Il y a une partie en français sur le site officiel : http://forums.linuxmint.com/viewforum.php?f=63

Mimile
 Posté le 20/05/2015 à 12:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut Hido

Merci pour ta réponse mais ... l'activation ne se fait que lorsque j'ai lancé ma session pour laquelle je dois fournir un mot de passe qui contient des chiffres.

De ce fait, je dois moi-même activer le pavé numérique pour entrer mon mot de passe.

Pour voir, avant de valider, j'ai désactiver mon pavé numérique, puis j'ai validé.

Effectivement, lors de l'ouverture de la session, le pavé numérique s'active.

Le fait d'avoir ajouté numlockx aux programmes lancés au démarrage n'a aucun effet.

Ce que je souhaiterais, c'est qu'il s'active AVANT que je ne doive entrer mon mot de passe comme il le fait sous gnome (Debian Jessie et Archlinux).

Je pense qu'il doit être possible de lancer la session en direct sans passer par l'étape "mot de passe", ce qui résoudrait le problème au détriment de la sécurité, ce qui ne me gène pas dans la mesure où je suis le seul utilisateur de mon PC.

En ce qui concerne le forum francophone, il est effectivement intégré au forum anglophone.

Je reviendrai dire si j'ai pu supprimer le passe d'entrée de session avec le mot de passe.

A+



Modifié par Mimile le 20/05/2015 12:46
Mimile
 Posté le 20/05/2015 à 13:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Me revoici : problème réglé.

Dans le menu "administration" > fenêtre de connexion > options > cocher "activer numlock".

Pendant la période de démarrage, le témoin d'activation du pavé numérique s'allume.

On peut aussi cocher l'option "connexion automatique" puis "activer la connexion automatique" ; il faut alors mettre son nom d'utilisateur mais bizarrement, quand je l'indique, il disparaît dès que je coche autre chose si bien qu'au démarrage suivant, je dois non seulement introduire mon mot de passe (plus de problème de pavé numérique) mais auparavant, je dois introduire mon nom d'utilisateur.

Je n'ai donc pas coché cette option si bien que je ne dois introduire que mon mot de passe.

Voilà.

Amicalement

beezapa
 Posté le 20/05/2015 à 13:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
Décrasseur
 Posté le 20/05/2015 à 14:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

effectivement le linux-mint.fr est en maintenance depuis au moins une quinzaine, à se demander si il ne va pas disparaître totalement ce qui serait vraiment dommage car il y avait une très bonne base de données qu l'on va perdre



Modifié par Décrasseur le 20/05/2015 14:25
mchl
 Posté le 20/05/2015 à 14:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

hido a écrit :

Bonjour

taper cette commande

numlockx on

en principe ça activera tout le temps le pavé numérique

Le site fr de linux mint n'existe plus apparemment, j'aimerais bien savoir pourquoi

Il y a une partie en français sur le site officiel : http://forums.linuxmint.com/viewforum.php?f=63

Bonjour

voir ici http://forums.linuxmint.com/viewtopic.php?f=63&t=192141&p=995892

Mimile
 Posté le 20/05/2015 à 16:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

beezapa a écrit :

Salut a tous

Ici une petite info http://www.laurentsanselme.com/activer-son-pave-numerique-au-demarrage/

Merci mais ça ne marche qu'avec gnome ...

J'ai d'ailleurs utilisé la solution du lien avec Debian Wheezy, Debian Jessie et Archlinux.

Toutefois, quand archlinux a installé gnome 3.16, l'activation du pavé numérique a cessé.

Un archer m'a donné la solution :

Depuis la version 3.16, GDM repose sur Wayland. C'est la source des problèmes rencontrés : pavé numérique, langage clavier, multi-écrans, etc. Personnellement, j'ai désactivé le support Wayland et tout est rentré dans l'ordre.

Solution : décommenter la ligne #WaylandEnable=false
dans /etc/gdm/custom.conf

C'est ce que j'ai fait aussi.

Il n'y a pas de fichier /etc/gdm/Init/Default sous Cinnamon.

J'ai toutefois trouvé la solution (indiquée dans ma précédente réponse.

Cordialement à tous



Modifié par Mimile le 20/05/2015 16:34
beezapa
 Posté le 20/05/2015 à 20:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Ok j'en prend bonne note.

Publicité
Sil33
 Posté le 21/05/2015 à 10:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour tous.

Effectivement sous certains environnements de bureau (Xfce par exemple), ces fichiers et dossiers ne sont pas présents comme indiqué: /etc/X11/gdm/Init/Default ou /etc/mdm/Init/Default.

L'astuce est d'éditer le fichier /etc/lightdm/lightdm.conf et d'inscrire greeter-setup-script=/usr/bin/numlockx on dans la rubrique [SeatDefaults] en ayant pris soin de la décommenter.

@+

Mimile
 Posté le 21/05/2015 à 12:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut !

Pas trace de /etc/lightdm/lighdm.conf dans ma Linux Mint ...

De toute façon, j'ai indiqué la solution dans une réponse que j'ai postée plus haut.

Merci quand même ... ça pourra sans doute servir à d'autres ...

Sil33
 Posté le 21/05/2015 à 20:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir.

Cela dépend tout autant des environnements que des distributions.

J'avais oublié de préciser que je suis en dual-boot (voir configuration) avec deux distributions en Xfce.

Sous Manjaro j'ai appliqué la solution que j'ai indiquée ci-dessus. Sous Mint c'est l'option

if [ -x /usr/bin/numlockx ]; then
exec /usr/bin/numlockx on
fi

que j'ai appliquée dans le fichier /etc/mdm/Init/Default à placer juste avant exit0.

@+

arbaces
 Posté le 06/12/2015 à 16:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Bonjour, merci pour toutes ces indications, j'ai fait mes premiers pas en activant le pavé numérique par numlock que j'ai du d'abord installer, la case n'étant pas active; premier contact réussi avec le Terminal; 17.2 mis à jour est vraiment efficace;

Bonne journée à tous!

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
9,99 €Adaptateur Bluetooth USB TP-Link UB400 à 9,99 €
Valable jusqu'au 13 Avril

Amazon fait une promotion sur l'adaptateur Bluetooth USB TP-Link UB400 qui passe à 9,99 €. Cet adaptateur à brancher sur un port USB va vous permettre d'ajouter le bluetooth à votre ordinateur et d'utiliser ensuite sans fil vos périphériques bluetooth : souris, clavier, casque, manette, téléphone, ...


> Voir l'offre
249,99 €Ecran PC LED 28 pouces Samsung U28E590 (4K UHD, 1 ms, Freesync) à 249,99 €
Valable jusqu'au 14 Avril

Boulanger fait une promotion sur l'écran PC LED 28 pouces Samsung U28E570DS qui passe à 249,99 € au lieu de 299 €. Cet écran au format 16/9 offre une dalle 4K (résolution 3840x2160) avec un temps de réponse de 1 ms. Il est compatible FreeSync. Une très bonne affaire ! La livraison est également offerte.


> Voir l'offre
99,99 €Barre de son 2.1 Samsung HW-T420 (Bluetooth, optique) avec caisson de basses à 99,99 € (via ODR)
Valable jusqu'au 13 Avril

Cdiscount fait une promotion sur la barre de son 2.1 Samsung HW-K335 avec caisson de basses à 99,99 € alors qu'on la trouve ailleurs autour de 150 €. Cette barre de son dispose d'une connectivité complète avec le bluetooth, une prise optique et une prise USB. 


> Voir l'offre

Sujets relatifs
Archlinux : l'activation du pavé numérique ne se fait plus
wifi sous linux mint cinnamon
Petit problème Linux Mint 17 Cinnamon
w8.1 écrasé par linux mint 17 cinnamon
Reconnaissance du pavé numérique sous Linux impossible.
Linux Mint 14 Cinnamon sur clé USB...en anglais
Activation pavé numérique (Debian Etch et Lenny)
Linux mint internet pas reconnu sur un ordinateur
Pas de wi-fi sous linux Mint
Ubuntu ou Linux Mint?
Plus de sujets relatifs à Linux Mint 17 et Cinnamon : activation du pavé numérique
 > Tous les forums > Forum Linux