> Tous les forums > Forum Linux
 Linux Mint Cinnamon "ouvrir comme administrateur"
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
paul74
  Posté le 19/05/2019 @ 18:06 
Aller en bas de la page 
Astucien

Bonjour,

J'ai installé Linux Mint Cinnamon 19 il y a plusieurs jours.

Mais demeure un petit problème : j'utilise assez souvent Krusader pour gérer les fichiers et apporter quelques modifs dans des paramètres (pour un scanner par exemple).

J'ai donc mis un lanceur sur le bureau pour Krusader. celui-ci fonctionne mais j'ai besoin, pour certaines tâches d'être en mode administrateur.

Contrairement à d'autres bureaux (XFCE sous LinuxLite par exemple) le ldanceur de Krusader n'offre pas le choix d'ouvrir comme administrateur.

Pas possible non plus, depuis la barre des menus "outils" de Krusader de passer en mode administrateur, refus après avoir donné le mot de passe.

J'ai modifié la commande dans le lanceur pour utiliser "pkexec", mais cela ne fonctionne pas.

Je tourne la difficulté en passant par le terminal en donnant la commande "sudo -s" puis en lançant Krusader, mais je trouve cela contraignant.

Je pense que j'ai raté quelquechose que smes connaissances encore limitées de Linux ne me permettent pas de résoudre.

J'ai fouillé un peu le forum de LinuxMint mais je n'ai pas trouvé de réponse satisfaisante.

Merci d'avance aux personnes qui voudront bien éclairer ma (sombre) lanterne.

Publicité
R136a1
 Posté le 19/05/2019 à 21:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir

tu as essayé avec gksu (ou gksudo) ? Il faut d'abord l'avoir installé je pense sous Mint.

Excuse, depuis Ubuntu 18.04 gksudo est obsolète. Essaye avec en début de commande : sudo -H



Modifié par R136a1 le 19/05/2019 21:23
paul74
 Posté le 20/05/2019 à 08:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour R136a1,

Merci de ta réponse rapide.

J'avais déja essayé sudo et gksudo, sans succès.

Je ne connaissais pas le parémètre "-H", j'ai donc essayé, mais toujours le même résultat.



Modifié par paul74 le 20/05/2019 10:41
Slyvester
 Posté le 20/05/2019 à 09:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour Paul74,

J'ai donc mis un lanceur sur le bureau pour Krusader. celui-ci fonctionne mais j'ai besoin, pour certaines tâches d'être en mode administrateur.

Essaye en saisissant "sudo krusader" dans ton lanceur.

R136a1
 Posté le 20/05/2019 à 10:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
paul74 a écrit :

Bonjour R136a1,

Merci de ta réponse rapide.

J'avais déja essayé sudo et gksudo, sans succès.

Je ne connaissais pas le parémètre "-H", j'ai donc essayé, mais toujours le même résultat.

Regarde ce sujet : https://forums.linuxmint.com/viewtopic.php?t=272325

Installe kdesu via le ppa indiqué. Il faudra aussi peut-être que tu ajoutes ton utilisateur au groupe wheel.

paul74
 Posté le 20/05/2019 à 14:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

J'avais essayé plusieurs modifs dans le lanceur pour précéder "Krusader" d'une commande "sudo" avec et sans paramètre, ça ne démarre pas du tout0

Entre temps, j'ai essayé de mettre la commande "sudo krusader" dans un script.

Léger progrès !!!

Car le script ouvre automatiquement un terminal pour la demande du mot de passe root, et démarre krusader en mode root dans la foulée........on approche du but.

J'ai vu que la commande kdesu de l'environnement KDE, est l'équivalent de gksudo.

Mais je vais essayer cela plus tard car je suis, pour le moment, sur un autre PC.

Ce qui me semble bizarre c'est que l'option "démarrer en tant qu'administrateur" n'existe pas lorsqu'on clique droit sur un lanceur dans l'environnement Cinnamon....que je trouve attrayant.

Slyvester
 Posté le 20/05/2019 à 16:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

Que donne la commande "sudo krusader" via Terminal ? Une demande de Mot de Passe + ouverture de Krusader ?

paul74
 Posté le 20/05/2019 à 16:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

"sudo krusader" ouvre le terminal et demande le mot de passe, mais donne plusieurs messages, et ouvre Krusader mais avec les paramètres de la précédente session, et si celle-ci n'était pas en mode administrateur, Krusader n'et pas en mode administrateur, mais en allant dans "outils", il est alors possible de passer en mode administrateur.....alors que cela ne fonctionne pas autrement !

Messages :

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'

Trying to convert empty KLocalizedString to QString.

kf5.kio.core: Refilling KProtocolInfoFactory cache in the hope to find "mtp"

kf5.kio.core: Refilling KProtocolInfoFactory cache in the hope to find "mtp"

kf5.kio.core: Refilling KProtocolInfoFactory cache in the hope to find "mtp"

QPainter::begin: Paint device returned engine == 0, type: 2

QPainter::begin: Paint device returned engine == 0, type: 2

QPainter::begin: Paint device returned engine == 0, type: 2

Je n'ai pas ces messages en démarrant depuis le script.

Et en mettant sudo krusader dans le lanceur, ça ne fontionne pas.

Par contre, dans le lanceur de Bleachbit en mode administrateur (généré automatiquement depuis le menu par l'option "ajouter au bureau"), j'ai dans commande "pkexec bleachbit", et ça fonctcionne parfaitement.

Le problème semble le cumul Krusader + mode administrateur + cinnamon (ou Linux Mint 19 ?????)



Modifié par paul74 le 20/05/2019 17:00
Slyvester
 Posté le 20/05/2019 à 18:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

Tous les messages que tu indiques ne sont que des informations qui ne présentent pas beaucoup d'intérêt. Par contre, ce qui semble être le problème, c'est le mot de passe. Si tu ne devais pas le saisir à chaque fois ou plutôt à chaque sollicitation d'ouverture du logiciel, ton problème ne serait-il pas simplifié ? Je ne crois pas que ce soit un problème spécifique à Linux Mint Cinnamon.
En tout cas, sur toutes mes Debian + dérivées (six distributions sur disque dur à ce jour), je désactive cette demande automatique plutôt ennuyeuse. Je me suis d'ailleurs fait tancer par certains astuciens lorsque j'ai divulgué l'astuce/manipulation qui permet de désactiver la demande systématique du MDP sur ces distributions. Si cela t'intéresse, je te l'indiquerai (une ligne à saisir via Nano) ...

D'un autre côté, tu peux saisir dans le raccourci (Propriétés/Entrées de Bureau) la commande : "pxexec krusader" ou encore "sudo krusader" mais tu auras - sans doute & dans les deux cas - la demande de MDP avant que Krusader ne s'ouvre ...

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Epson Stylus SX125 et Linux Mint 18 Cinnamon
Linux Mint 17 et Cinnamon : activation du pavé numérique
wifi sous linux mint cinnamon
Petit problème Linux Mint 17 Cinnamon
w8.1 écrasé par linux mint 17 cinnamon
Linux Mint 14 Cinnamon sur clé USB...en anglais
Linux Mint et Windows 7
Linux Mint : quel logiciel pour modifier un formulaire PDF ?
linux mint et timeshift - pas de partition linux.
MAJ de Linux Mint, Manjaro ne se lance plus.
Plus de sujets relatifs à Linux Mint Cinnamon "ouvrir comme administrateur"
 > Tous les forums > Forum Linux