> Tous les forums > Forum Bureautique
 liste sans vide, avec filtre selon un critère d'une autre colonneSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Boogie Palace
  Posté le 26/01/2018 @ 15:48 
Aller en bas de la page 
Petit astucien

bonjour le forum,

sur Excel 2010, à partir de la liste de gauche, je souhaite obtenir la liste des prénoms qui n'ont pas zéro.
j'arrive à le faire en deux étapes :

1) lister uniquement les prénoms avec valeur différente de zéro (colonne D avec formule matricielle {=SI(B2:B8<>0;A2:A8;"")} )

2) à partir de la liste en colonne D, j'utilise la fonction suivante qui supprime les vides pour obtenir ma liste finale en colonne F :
{=INDEX(D2:D8;PETITE.VALEUR(SI(D2:D8<>"";LIGNE(INDIRECT("1:"&LIGNES(D2:D8))));LIGNES($1:1)))}
(j'ai retiré les $ ici pour plus de lisibilité)

bref, j'aimerais pouvoir faire la même chose en une seule étape plutôt que deux.
je sais le faire avec fonction perso en VBA, mais j'aimerais savoir le faire avec des fonctions Excel natives, tel que dans mes deux étapes.
si cela est possible, merci à ceux qui pourront me montrer comment.


Publicité
ferrand
 Posté le 26/01/2018 à 20:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonsoir,

=SIERREUR(INDEX($A$1:$A$8;PETITE.VALEUR(SI($B$2:$B$8<>0;LIGNE($B$2:$B$8);"");LIGNE(1:1)));"")

Matricielle bien sûr, et tirer vers le bas...

Cordialement.

Boogie Palace
 Posté le 29/01/2018 à 12:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

ferrand t'es le patron

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
formule Excel liste sans doublons avec condition supplémentaire
calculer une colonne par une autre avec pourcentage
colonne avec choix déroulant qui va vers une autre colonne choix déroulant
Liste en cascade réajustable sans vide
copie de colonne vers une autre feuille avec condi
CA mensuel en colonne sur autre feuille avec excel
Liste déroulante avec l'option Données
[Liste déroulante avec formulaires en item de choix]
CALCUL SOMMES COLONNES SELON 1 CRITERE
Afficher une colonne avec libre office
Plus de sujets relatifs à liste sans vide, avec filtre selon un critère d''une autre colonne
 > Tous les forums > Forum Bureautique