> Tous les forums > Forum Linux
 LMDE Gnome-mplayer plante ...Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Mimile
  Posté le 06/11/2011 @ 15:53 
Aller en bas de la page 
Astucien

Salut

Finalement, j'ai viré Wheezy et j'ai installé proprement LMDE (Linux Mint Debian).

Quand je veux visionner un film avec gnome-mplayer, tout va bien.

Quand ce film est accompagné de sous-titres (dans un fichier séparé *.srt), Gnome-mplayer plante avec le message : MPlayer interrupted by signal 6 in module: filter_video

J'ai arpenté le net sans trouver de solution à ce problème.

Quelqu'un aurait-il une idée ?

Petite précision : VLC et Banshee ne rencontrent pas ce problème. En revanche, mplayer n'affiche même pas l'image (rien que le son).

Merci d'avance.

Publicité
Logicien
 Posté le 06/11/2011 à 17:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

man mplayer

...

-dumpsrtsub (MPlayer uniquement)
Convertit les sous-titres donnés (via l'option -sub) au format basé sur le temps SubViewer (SRT). Crée un fichier dump.srt dans le répertoire courant.
NOTE : Certaines mauvaises platines de salons peuvent avoir du mal avec les sous-titres SRT dont les fins de ligne sont Unix. Si vous avez la malchance de posséder un tel matériel, transformez votre sous-titre avec unix2dos ou un programme similaire pour remplacer les fins de lignes avec des fins de ligne DOS/Windows.

...

C'est le seul paragraphe dans la page de manuel française de Mplayer qui traite du mot-clé srt. Je n'ai jamais visionné un film soustitré sur ordinateur. Si une de tes distributions lit bien les films soustitrés avec Mplayer ou une interface qui l'utilise (Gmplayer, Gnome-mplayer, Smplayer, etc), prend en note les options de lancement de Mplayer et de l'interface grâce à la commande ps et compare avec Mint LMDE. Essai toutes les interfaces à Mplayer que tu peux sous LMDE, ensuite Squeeze, etc. Peut-être que tu trouveras un élément de configuration d'Mplayer qui résoudra le problème pour toutes les interfaces graphiques. Sinon, le Net en sait et saura toujours plus que moi.



Modifié par Logicien le 06/11/2011 18:06
Mimile
 Posté le 07/11/2011 à 09:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

RE-

Tout d'abord, petite précision : il ne s'agit pas de lire des DVD mais bien des fichiers *.avi (pour la plupart).

Pour tout dire, je télécharge les *.avi d'une certaine série américaine en V.O. et, si je comprends assez bien l'anglais d'Angleterre, il n'en va pas de même de l'américain. Fort heureusement, il y a un site totalement consacré à cette série qui, dans les deux ou trois jours qui suivent la diffusion aux USA fournissent les sous-titres en français sous différents formats selon la nature du fichier *.avi.

Il suffit de donner au fichier de sous-titres (un simple document texte) exactement le même nom que l'*.avi mais avec l'extension *.srt ou *.sub pour que, en principe, mplayer (gnome-mplayer, smplayer etc... les affiche.

Ca fait des années que ça marche parfaitement quel que soit l'OS que j'utilise (Mandriva 2008, Lenny, Squeeze).

Seuls Wheezy (que j'ai évacué) et LMDE rencontrent ce problème.

Dans la mesure où LMDE est considéré comme étant Wheezy/sid, se pourrait-il que la version de gnome-mplayer soit une version non aboutie ? (à noter que quand je désactive l'option d'affichage des sous-titres, Gnome-mplayer et mplayer fonctionnent correctement).

En ce qui concerne le net, avant de poster, j'ai longtemps arpenté les sujets décrivant le même problème sans qu'aucun soit marqué "résolu" (exception faite d'un site mais je n'ai rien compris aux explications fournies).

Quoi qu'il en soit, je vais essayé de voir quelles différences apparaissent d'un OS à l'autre.

Je reviendrai dire le résultat.

Cordialement,

EDIT 1 : premier essai avec Lenny (et KDE 3.5) : ps donne ceci :

a) smplayer : /usr/bin/mplayer -noquiet -nofs -sub-fuzziness 1 -identify -slave -vo xv -ao alsa - : fonctionne parfaitement
b) gmplayer : /usr/bin/mplayer -noquiet -nofs -sub-fuzziness 1 -identify -slave -vo xv -ao alsa -
à noter que pour une raison inexpliquée, quand je lance gmplayer, il démarre deux fois de sorte que les sous-titres tressautent

EDIT 2 : essai avec Squeeze :

smplayer : /usr/bin/mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo (fonctionne parfaitement)
(à noter que je n'ai pas installer gmplayer) ; Je vais installer smplayer sur LMDE pour voir si ça ne résoudra pas le problème

EDIT 3 : essai avec LMDE

gmplayer : mplayer -af-add export=/tmp/mplayer-af_exportdxwgfg:512 -quiet -slave -noidle -noconsolecontrols -n (plante à tous les coups avec ce message : [AO_ALSA] Unable to find simple control 'PCM',0

smplayer : /usr/bin/mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo xv -ao alsa -no (j'ai désactivé freetype support et l'option "utiliser les librairies SAA/ASS". Maintenant les sous-titres s'affichent correctement

Gnome-mplayer : idem ; les sous-titres s'affichent mais ... en haut de l'image. Il doit y avoir un réglage à faire pour les déplacer.

Finalement, il n'y a plus que gmplayer qui pose problème et à cet égard, le message affiché par ps est totalement différent des autres.

Conclusion, dans la mesure où je peux visionner les films avec sous-titres avec 4 logiciels différents, je peux considérer ce sujet comme résolu.

A moins qu'il te vienne encore une de ces suprenantes suggestions auxquelles tu m'as habitué depuis des années

Amicalement,









Modifié par Mimile le 07/11/2011 10:34
Logicien
 Posté le 08/11/2011 à 04:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je pense que ta référence devrait être Mplayer, le moteur. Dans l'ordre de lecture, sa configuration se fait dans /etc/mplayer, remodelée dans $HOME/.mplayer/config et remodelée de nouveau en ligne de commandes. Je sais que Gmplayer utilise $HOME/.mplayer/gui.conf pour remodeler les paramètres de Mplayer. Ensuite, il exécute Mplayer. L'important c'est que tu places les paramètres fonctionnels pour qu'ils ne soient pas modifiés avant le lancement de Mplayer par l'interface utilisée. Les préférences de l'interface de Gnome-Mplayer, Smplayer et Gmplayer sont probablement le meilleur endroit à moins que tu lances Mplayer en ligne de commandes.



Modifié par Logicien le 08/11/2011 04:06
Mimile
 Posté le 08/11/2011 à 09:24 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Merci pour tes explications Paul.

A tout hasard, j'ai installé smplayer qui fonctionne bien après avoir désactivé deux options (utiliser SAA/ASS) et freetype.

En effectuant les mêmes modifications sous gnome-mplayer, j'ai les sous-titres mais ils s'affichent en haut de l'écran (je crois qu'il est possible de modifier leur emplacement dans les préférences (je l'ai vu à un moment donné de mes recherches) mais je ne retrouve plus la page qui contient cette option.

VLC ne m'a jamais posé de problème.

Banshee fonctionne aussi très bien.

En revanche, rien à faire avec gmplayer qui continue à planter joyeusement (pas d'image du tout, uniquement le son).

Je me contenterai dès lors de smplayer et de VLC (ce dernier étant, à mon avis, le plus perfectionné pour ce qui concerne sa configuration).

Encore merci et à bientôt.

Logicien
 Posté le 08/11/2011 à 20:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Assures-toi sans les Préférences/Vidéo que le pilote vidéo de Gmplayer est xv ou X11 . Exige que l'accélération matérielle 2D et/ou 3D fonctionne(ent)

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
14,99 €McAfee Total Protection 2021 (5 appareils, 1 an) à 14,99 €
Valable jusqu'au 18 Janvier

Amazon fait une promotion sur la suite antivirus McAfee Total Protection 2021 qui passe à 14,99 €. Cette protection intégrale alliant antivirus, protection de l'identité et protection de la confidentialité des données pour tous vos PC, Mac, smartphones et tablettes est valide pour 5 appareils pendant 1 an. La clé d'activation ainsi que le lien de téléchargement vous seront envoyés par email une fois la commande passée. Une bonne affaire.


> Voir l'offre
29,99 €SSD Western Digital Green 240 Go à 29,99 €
Valable jusqu'au 19 Janvier

Cdiscount fait une promotion sur le SSD Western Digital Green 240 Go qui passe à 29,99 € livré gratuitement. On le trouve ailleurs à partir de 33 €. Ce SSD à mémoires SLC et TLC offre des vitesses de 540 Mo/s en lecture et 465 Mo/s en écriture.


> Voir l'offre
60,99 €SSD interne M.2 NVMe Kingston A2000 500 Go à 60,99 €
Valable jusqu'au 19 Janvier

Cdiscount fait une promotion sur le SSD interne M.2 NVMe Kingston A2000 500 Go qui passe à 60,99 € au lieu de plus de 80 € ailleurs. Il offre des vitesses de lecture allant jusqu'à 2200 Mo/s et 2000 Mo/s en écriture.


> Voir l'offre

Sujets relatifs
Comportement bizarre de gnome-mplayer
Icônes énormes après installation de Gnome 3.16.0
Affichage qui plante
Mplayer : problème de lecture des streamingg *.asx
gnome 3.14.1 : clavier azerty passé en qwerty
Youtube-viewer et Smtube: visionner la vidéo Youtube avec Mplayer !
Cinnamon planté
Debian Wheezy + gnome : affreux
linux se plante en erreur 1 au démarrage
Installation de Boot-Repair sur LMDE
Plus de sujets relatifs à LMDE Gnome-mplayer plante ...
 > Tous les forums > Forum Linux