> Tous les forums > Forum Linux
 Mandrake, CNX internet disparue (RESOLU)
Ajouter un message à la discussion
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]
regeditgg
  Posté le 09/01/2005 @ 17:32 
Aller en bas de la page 
Petit astucien

Bonjour à tous Je galère avec des Pbs sur autres posts où tout le monde cherche à m'aider, merci. En voici un petit nouveau ! Depuis que j'ai réinstallé Mandrake 10.0 pour résoudre des Pbs de fichiers corrompus, ma connexion internet, qui s'était configurée toute seule dès que j'avais installé mon routeur freebox, a disparu et je n'arrive pas à la remettre en route !! Auriez vous qqs pistes à me donner car j'ai été fouiller partout où il y aurait logiquement une action, mais rien. Mimile tu m'as dit que tu voguais avec Linux comme avec Windows, et je ne demande qu'à faire pareil. Un p'tit coud' main STP !!! Les autres ne vous sentez pas rejetés, vous êtes bien sur les bienvenus !! @++

Modifié par regeditgg le 12/01/2005 02:29
Publicité
Snowangelic
 Posté le 09/01/2005 à 17:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Tjr moi pour commencer... Bon si ta freebox a marché , aucune raison qu'elle foire. Donc : ta freebox elle est en ethernet ou usb ?
regeditgg
 Posté le 09/01/2005 à 19:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Snowangelic a écrit :
Tjr moi pour commencer...
et sam' plait bien, ne change rien surtout !!
Bon si ta freebox a marché , aucune raison qu'elle foire. Donc : ta freebox elle est en ethernet ou usb ?
Tout à fait d'accord, d'autant qu'elle marche bien en routeur avec mes 2 autres PC XP et 2k, de plus elle fait aussi le téléphone et la TV, pas encore le café !! Elle est en Ethernet votre honneur et marchait bien jusqu'à ce que je réinstalle Mandrake. Il doit manquer un paramètre dans un coin. Alors, par quoi on commence sur Linux puisque c'est ENCORE lui le coupable !! mais on va le mâter ! Over, à toi, merci !
regeditgg
 Posté le 09/01/2005 à 19:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Tant que tu y es Snow (mais non je ne t'abandonne pas Mimile, tu peux te joindre à nous si tu veux !!), peut-être pourras-tu m'expliquer pourquoi, avant d'arriver à l'ouverture de Gnome, j'ai une fenêtre qui me dit : "ajouter pc4 à /etc/hosts sinon Gnome pas OK". 1- pourquoi ce message ? 2- comment résoudre ce Pb ? pc4 est mon pc Linux objet de tant de soucis !! Merci et bon app' car c'est l'heure @+
Mimile
 Posté le 09/01/2005 à 23:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut, Si j'ai bien compris, tu utilises un modem/routeur. Il faut configurer ta connection. Pour cela, étoile jaune > configurez votre ordinateur > [mot de passe root] > réseau et internet > gérer les connections. A ce stade : onglet TCP/IP Protocle : statique adresse IP : l'adresse IP de ton PC masque de sous-réseau : 255.255.255.0 passerelle : l'adresse IP de ton modem/routeur Chez moi, ça donne ça : [IMG]http://img115.exs.cx/img115/8392/scrshot1069be.png[/IMG] L'adresse IP de ton PC doit être dans la même gamme que celle de ton modem/routeur (chez moi : 192.168.2.xyz Il en va de même pour les PC de ton réseau ; si tu veux qu'ils soient intégrés au groupe de travail, il faut qu'ils aient également des adresses IP dans la même gamme. onglet : options cocher la case "lancer au démarrage" la valeur métrique chez moi : 10 Voilà. Amicalement,

Modifié par Mimile le 09/01/2005 23:27
regeditgg
 Posté le 10/01/2005 à 00:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut Mimile, content de te retrouver dans mon nouveau topic .J'en ai quand même 3 qui tournent ce qui montre l'ampleur des dégats !!
Mimile a écrit :
Salut, Si j'ai bien compris, tu utilises un modem/routeur.
VOUI, c'est tout à fait cela
Il faut configurer ta connection. Pour cela, étoile jaune > configurez votre ordinateur > [mot de passe root] > réseau et internet > gérer les connections.
Sachant que mes PC vont de 192.168.0.1 à 4 et mon routeur/modem Free a pour IP 192.168.0.254, voici ce que j'ai, très semblable à toi. [IMG]http://img28.exs.cx/img28/7683/105sj.jpg[/IMG] [IMG]http://img28.exs.cx/img28/3533/202lk.jpg[/IMG] Seul Pb, les DNS indiquées sont celles données par Mandrake et non celles du FAI Free et je n'arrive pas à les changer ??? Alors Mimile, pourquoi kej peupa sortir ???? As-tu la clé de la liberté !!! A tout' (il n'est pas encore 1h30 !!)
dargas
 Posté le 10/01/2005 à 00:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
En tant que root, tu peux modifier tes DNS directement dans /etc/resolv.conf
regeditgg
 Posté le 10/01/2005 à 03:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

dargas a écrit :
En tant que root, tu peux modifier tes DNS directement dans /etc/resolv.conf
merci Dargas, mais comme je ne maitrise pas encore parfaitement la ligne de commande et que ça fait 5 fois que je recommence ... !! j'ai fait sous root vi /etc/resolv.conf je change mes valeurs après avoir tapé i, mais je ne sais plus sauvegarder. je pensais qu'il fallait faire ESC w q mais ça ne marche pas. J'ai du sortir par ALT F4 et je me suis retrouvé avec un /etc/.resolv.conf.swp que j'ai réussi à supprimer Tu peux m'indiquer où est la faute STP ? merci d'avance et à demain
Mimile
 Posté le 10/01/2005 à 06:06 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Utilise kwrite en mode su ; c'est beaucoup plus simple que vim. Ne t'inquiète pas des messages d'erreur qui apparaîtront dans la console, du genre de ceci : Link points to "/tmp/ksocket-root" QPixmap: Cannot create a QPixmap when no GUI is being used QPixmap: Cannot create a QPixmap when no GUI is being used Link points to "/tmp/kde-root" QPixmap: Cannot create a QPixmap when no GUI is being used QPixmap: Cannot create a QPixmap when no GUI is being used kbuildsycoca running... Pour enregistrer et sortir du fichier après modif, tu cliques sur Fichier > quitter et à ce moment apparaîtra une boîte de dialogue te demandant si tu veux sauvegarder tes modifs, ce à quoi tu réponds évidemment oui. Voilà @+

Modifié par Mimile le 10/01/2005 06:34
Publicité
Shaika-Dzari
 Posté le 10/01/2005 à 06:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien
À titre d'info pour vi en console: entrée en insertion--> i ou ESC + a revenir en mode commande--> ESC Quitter--> :q! Quitter et sauvegarder--> :wq! Signifie :write and quit! [smile] @+
regeditgg
 Posté le 10/01/2005 à 11:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Shaika-Dzari a écrit :
À titre d'info pour vi en console: entrée en insertion--> i ou ESC + a revenir en mode commande--> ESC Quitter--> :q! Quitter et sauvegarder--> :wq! Signifie :write and quit! [smile] @+
c'est pourtant ce que je faisais (ou du moins le croyé-je), j'ai du faire une connerie, suite à l'heure avancée de la nuit, il était 3h du mat'. Je réessaierai après avoir testé le truc de mimile, merci Shaika-Dzari @+
regeditgg
 Posté le 10/01/2005 à 11:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Mimile a écrit :
Utilise kwrite en mode su ; c'est beaucoup plus simple que vim.
effectivement mimile y'a pas photo. J'introduis cette commande en lettres d'or dans le manuel que je me fais de tout ce que j'apprends sur ce forum. Modif réussie MAIS toujours pas d'accès à internet ??? d'autres idées ?? là ça commence à me gonfler cette histoire. Je ne comprends pas pourquoi ça a marché sans rien faire lorsque j'ai installé mon routeur et que maintenant ça ne marche plus après avoir réinstallé Mandrake ??? HELP !!!!!!!!!!!!!!!!!!!!!!!!!!!
regeditgg
 Posté le 10/01/2005 à 11:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

dargas a écrit :
En tant que root, tu peux modifier tes DNS directement dans /etc/resolv.conf
merci, c'est fait, mais no change, pas d'accès à internet. Des idées sur ce Pb "qui a marché" ???
regeditgg
 Posté le 10/01/2005 à 12:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Hello mimile, dargas, snow et les autres (tiens ça me rappelle qq chose !) la source de mes Pbs ne viendrait-elle pas de ceci : type de connexion : lan état : non connecté [IMG]http://img42.exs.cx/img42/9601/17kp.jpg[/IMG] et si oui, comment activer ce fichu lan qui en principe a tous les paramètres (sauf erreur ou omission comme on dit). Merci pour votre aide car je commence à désespérer ... de Linux. Faut dire que j'ai pas de bol, la totale quoi !!! [IMG]http://img143.exs.cx/img143/476/25qy.jpg[/IMG]

Modifié par regeditgg le 10/01/2005 12:36
Mimile
 Posté le 10/01/2005 à 13:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Décidément, c'est laborieux hein ? Reprenons en comparant. Chez moi : L'adresse IP de mon modem/routeur est 192.168.2.1 ; c'est cette valeur que j'ai indiquée pour la passerelle pour dire à mon PC d'aller chercher l'accès au net à cette adresse. J'ai donc configuré mon réseau de sorte que chacun des trois PC qui le composent ait une IP dans la série 192.168.2 (mon PC = 192.168.2.2, celui de mon fils = 192.168.2.3 et celui de ma fille = 192.168.2.4). En ce qui concerne ma fenêtre "accès à internet", la voici : [IMG]http://img107.exs.cx/img107/2636/scrshot1083ia.png[/IMG] Tu constateras que le DNS principal = l'IP de mon modem/routeur. Chez toi : Es-tu absolument certain que la valeur que tu indiques pour ta passerelle (192.168.0.254) est bien l'adresse IP de ton mode/routeur ? Tu dois vérifier ce point qui est essentiel. Pour les valeurs DNS, comment as-tu déterminé les valeurs que tu y indiques ? (212.27.32.176 et 177). A mon avis, elles ne servent pas à grand'chose en l'espèce. Amicalement, P.S. Tu n'as qu'une seule carte réseau dans ton PC je suppose ?

Modifié par Mimile le 10/01/2005 13:18
regeditgg
 Posté le 10/01/2005 à 13:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Ach so !! merci amigo mimile de me faire remarquer que je fais une erreur E N O R M E en mettant comme DNS celui de free. En effet cette adresse n'est pas le Pb du PC mais du routeur. Tu viens de me redonner un grand E S P O I R. Je te réponds avant même d'essayer tant je le sens bien !! merci mimile pour ta patience et tes compétences, j'ai beaucoup appris avec toi, mais ne vendons pas la peau de l'ours .... je vais aux essais et te tiens au courant
regeditgg
 Posté le 10/01/2005 à 14:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Ah là là mimile, la déception est à la hauteur des espoirs suscités !! Mais reprenons calmement. Je suis désormais tout comme toi. Rappel : pc1 (w2K) = 192.168.0.1 pc4 (linux) = 192.168.0.4 routeur = 192.168.0.254 je te joins la fenêtre windows qui lui fonctionne sans Pb. Les DNS sont ceux de Free, mais je ne suis pas sur que ça serve car ils sont déjà dans le routeur [IMG]http://img151.exs.cx/img151/9929/win0mp.jpg[/IMG] voici la correspondance linux [IMG]http://img69.exs.cx/img69/4558/12pf.jpg[/IMG] [IMG]http://img52.exs.cx/img52/903/22fv.jpg[/IMG] Tout est comme toi (à nouveau sauf erreur de ma part), mais au moins là c'est bon et on progresse. J'en reviens donc à ma question précédente : pour atteindre le routeur il faut passer par le LAN, et si tu regardes au-dessus : type de connexion LAN état : non connecté !!! et c'est ça qui m'intrigue. Qu'en penses-tu ? Je t'abandonne pour cet d'après-midi car j'ai des trucs à faire. A ce soir mimile. J'espère qu'on va y arriver car je sens qu'on n'est pas loin du but !! @+ PS : oui je n'ai qu'une seule carte réseau par PC

Modifié par regeditgg le 10/01/2005 16:25
Publicité
Snowangelic
 Posté le 10/01/2005 à 15:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Bandes de laches , vous profitez que je sois reparti sur les bancs pour poster comme des fous. Ca ne se passera pas comme ca !!! Les représailles seront terribles [feroce] lol Helolo tout le monde et content d'être de retour parmi vous après une première journée consacréé presque exclusivement aux corrections d'examen (seul le prof de français a dérogé a là règle pour faire une...dictée [crazy] ) Je n'ai pas free (et pour cause je suis belge) mais bon... Le non connecté du lan semble être a première vue le problème... Donc voila. Je tient a présiser que sur de nombreux sites , les "pro" déconseillent de mettre lan ; en effet une connexion "lan" signifie que tu as un réseau de ce type : Freebox connectée a un PC. Second PC connecté surle premier MAIS PAS a la freebox. Une connexion "lan" permet au second PC de se connecter a internet en passant par le premier. (si les deux sont allumés et que le premier est lui même connecté , évidemment). Or ton réseau est de ce type si je comprend bien : Freebox connectée a un routeur sur lequels se connectent les autres PC. l'option "lan" me semble donc erronnée. Essaie de modifier ce paramètre et choisi a la place "DHCP" ce qui signifie que tu te connecte a un routeur qui t'assignera une ip et qui "s'arrangera pour que tout marche"... Si effectivement ton routeur est "DHSP" alors c'est logique qu'il ne comprenne pas le language (protocol) "lan". Si DHCP ne marche pas , essaie encore PPPoE C'est un autre protocol utilisé encore par free dans certaines zones (je ne sais jamais si c'est dégroupé ou non) Je ne peu malheureusement pas t'aider plus car : 1) Je n'ai ni free ni routeur (direct sur l'adsl moi) 2) Je suis sous fedora core 3 et pas sous mandrake (donc pour le clique la dessus et met ça a cet endroit là , c'est foutu) En espérant avoir (un peu) fait avancer les choses. Note : tes paramètre d'IP sont corrects , a mon avis il faut seulement changer "lan" en "dhcp" Bien a vous (tous) Snowangelic
regeditgg
 Posté le 10/01/2005 à 16:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Snowangelic a écrit :
Bandes de laches , vous profitez que je sois reparti sur les bancs pour poster comme des fous
Eh oui c'est la vie .... d'étudiant !!
Le non connecté du lan semble être a première vue le problème... Donc voila. Je tient a présiser que sur de nombreux sites , les "pro" déconseillent de mettre lan ; en effet une connexion "lan" signifie que tu as un réseau de ce type : Freebox connectée a un PC. Second PC connecté surle premier MAIS PAS a la freebox. Une connexion "lan" permet au second PC de se connecter a internet en passant par le premier. (si les deux sont allumés et que le premier est lui même connecté , évidemment). Or ton réseau est de ce type si je comprend bien : Freebox connectée a un routeur sur lequels se connectent les autres PC.
Exactly
l'option "lan" me semble donc erronnée. Essaie de modifier ce paramètre et choisi a la place "DHCP"
je vais essayer, mais j'étais comme cela avant que mimile ne me suggère le contraire. De plus, ce "fameux" mimile fonctionne comme cela et ça marche. Enfin, dans mon cas pour atteindre le routeur il faut bien que je passe par le LAN ?! n'est-il pas ... comme disent les Anglais ! Autre piste, il faudra peut-être que j'essaie ce soir (car je ne suis pas chez moi en ce moment) sans firewall, en effet, j'ai tout décoché pour ce firewall. Voilà, je continue à tatonner. Ce qui me fait rager, c'est que ça a déjà marché sans rien faire. Mais au moins là j'apprends et c'est précieux. Allez @+ snow et vive la Belgique libre ! (je déconne bien sur !)

Modifié par regeditgg le 10/01/2005 16:40
Mimile
 Posté le 10/01/2005 à 16:38 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut Snow J'ai un système semblable à celui de notre ami, savoir une connection à l'ADSL via un modem/routeur sur lequel les trois PC de mon réseau sont connectés. Cela dit, sur mon PC, j'ai deux cartes réseau ethernet. Pour une raison trop longue à expliquer ici, j'utilisais uniquement jusqu'à un passé récent la 2ème carte (eth1) qui fonctionnait sous DHCP sans problème. Malheureusement, après installation d'une carte USB 2.0 (cadeau du Père Noël), un conflit d'IRQ a surgi, s'est amplifié au fil de mes interventions foireuses pour essayer de régler le problème, au point que finalement, je me suis retrouvé dans l'impossibilité de booter ! J'ai donc neutralisé ma carte réseau n° 2 et j'ai ré-activé ma carte réseau n° 1 (qui a une autre IRQ) ce qui m'a permis de restaurer Mandrake (une résintall complète). J'ai évidemment configuré ma nouvelle connection comme elle l'était avec l'ancienne, en utilisant DHCP. Résultat : pas moyen de me connecter ! C'est finalement en adoptant une IP statique (voir mes screenshots) que j'ai réglé le problème et que j'arrive maintenant à me connecter. C'est pourquoi je n'ai pas suggéré à notre ami d'utiliser DHCP jusqu'à présent. Cela étant, s'il n'arrive pas à se connecter avec un IP statique, il lui faudra bien essayer DHCP comme tu le lui suggères, en espérant que cela réglera son problème. Je me demande quand même si Mandrake n'est pas un peu caractériel par moments... (DHCP qui marche sur une carte et par sur l'autre, c'est quand même bizarre ...) Voilà. Amicalement, @+
Snowangelic
 Posté le 10/01/2005 à 16:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
Ah je suis désolé mais j'ai relu tout les post avec grande attention et nulle part notre Mimilme nationnal ne te suggère de mettre lan (ou alors c'est dans un autre post ou des messages privés) De plus , après a reregardé , que vois-je ? ceci :
Mimile a écrit :
En ce qui concerne ma fenêtre "accès à internet", la voici : [IMG]http://img107.exs.cx/img107/2636/scrshot1083ia.png[/IMG]
Regarde bien le type de connexion de Mimile : Ethernet ( et non pas lan) Ethernet est le "joli" nom de PPPoE , la seconde option que je te propose : J'explique : D'après mes recherches , free utilise deux techniques : le DHCP ou le PPPoE (dit aussi Ethernet) selon que les gens sont en zone dégroupée ou non. Je le redis , je ne sais jamais si la zone dégroupée à DHCP ou PPPoE et inversément. Comme je ne sais pas non plus si tu es en zone groupée ou dégroupée , je te conseille simplement d'essayer les deux et de prier pour que l'un marche. Je sais qu'actuellement le DHCP a tendance a supplanter le PPPoE , voila pourquoi je te le proposait en premier choix. Si tu veu réaliser une copie parfaite de la connexion de Mimile en l'adaptant aux IP de ton réseau , garde tes IP comme ca et change juste lan en ethernet (PPPoE)... Voilaaaaaaaaaaaaaaaaaaa [dent]
regeditgg
 Posté le 10/01/2005 à 17:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Mimile a écrit :
Salut Snow Cela étant, s'il n'arrive pas à se connecter avec un IP statique, il lui faudra bien essayer DHCP comme tu le lui suggères, en espérant que cela réglera son problème. Je me demande quand même si Mandrake n'est pas un peu caractériel par moments... (DHCP qui marche sur une carte et par sur l'autre, c'est quand même bizarre ...)
OK mimile j'essaie ce soir, mais je crains le pire car sur mes PC windows lorsque j'ai mis DHCP, ils n'ont plus fonctionné en réseau local et suis donc repassé en statique (voir mon screenshot) et ça marche très bien (en Windows !!) LAN + accès internet. De plus mon routeur est DHCP. Donc d'après moi, lorsque je l'appelle pour accéder à internet, il va m'octroyer une adresse ip pour tout le temps de la connexion, mais ça m'amène une question : je lui ai donné comme plage la plage d'adresse de mes PC et il va donc taper là-dedans au hasard et risque peut-être d'entrer en conflit avec mes PC qui transfèrent en LAN avec leur propre adresse. Ne vaudrait-il pas mieux que je lui donne une plage différente de mes PC pour éviter lesdits conflits et prendre par ex: 192.168.0.10 à 192.168.0.20 Qu'en pensez-vous les chefs à plume ?? on sort un peu du cadre de linux pour entrer dans celui du réseau, mais je crois que c'est intéressant de maitriser toute la chaine. @+
regeditgg
 Posté le 10/01/2005 à 18:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Snowangelic a écrit :
Regarde bien le type de connexion de Mimile : Ethernet ( et non pas lan) Ethernet est le "joli" nom de PPPoE , la seconde option que je te propose Si tu veu réaliser une copie parfaite de la connexion de Mimile en l'adaptant aux IP de ton réseau , garde tes IP comme ca et change juste lan en ethernet (PPPoE)... Voilaaaaaaaaaaaaaaaaaaa [dent]
Alors là snow chapeau, j'étais passé complètement à côté et je reprends espoir. J'ai hâte de rentrer chez moi pour essayer. Les bancs de l'école t'ont redonné du tonus et surtout une grande capacité d'analyse !! Tu vois, tu as rattrapé le train malgré tes posts de retards. Ta vengeance a été somme toute ... plutôt sympa. Merci et à tout' après essais !!!
Snowangelic
 Posté le 10/01/2005 à 19:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien
regeditgg a écrit :
De plus mon routeur est DHCP. Donc d'après moi, lorsque je l'appelle pour accéder à internet, il va m'octroyer une adresse ip pour tout le temps de la connexion, mais ça m'amène une question : je lui ai donné comme plage la plage d'adresse de mes PC et il va donc taper là-dedans au hasard et risque peut-être d'entrer en conflit avec mes PC qui transfèrent en LAN avec leur propre adresse. Ne vaudrait-il pas mieux que je lui donne une plage différente de mes PC pour éviter lesdits conflits et prendre par ex: 192.168.0.10 à 192.168.0.20 Qu'en pensez-vous les chefs à plume ?? on sort un peu du cadre de linux pour entrer dans celui du réseau, mais je crois que c'est intéressant de maitriser toute la chaine. @+
Exellente question !!!!!! (Et très bonne idée d'essayer de tout capter) Ton raisonnement est très logique au vu de tes connaisssances mais faux dans l'absolu (Désolé [triste]) Je vais maintenant essayer de t'expliquer les notions qui te sont encore inconnues (si ya qqc que tu piges pas , dis le !!!) Tu sais sans doute déjà qu'une IP est une sorte d'adresse. Chaque PC a une adresse (IP) et quand on veu envoyer des données a un PC on l'envoie a son adresse et tout va pour le mieu. Logiquement on se dit 1 PC = 1 IP et 1 IP = 1 PC Lorsqu'on veu faire simple pour expliquer a un débutant , on dit ca et tout le monde est content. En fait c'est faux... Un PC a plusieurs IP : Prenons un PC "normal" relié a un petit réseau d'entreprise et connecté a internet. (Une situtation tout a fait normale et comparable a celle de ton PC). Ce PC a 3 IP : Une IP "selon internet" Une IP "selon le réseau" Une IP "selon lui même" <-- TOUT les PC l'ont Ton IP "selon internet" t'est donnée par free Ton IP "selon le réseau" tu te l'est donnée : 192.168.0.1 Ton IP "selon toi même" : 127.0.0.1 : c'est la même pour tout le monde. Pour organiser cela il éxistae bien sur des conventions : ainsi l'IP 127.0.0.1 est toujours associé a un PC comme étant "lui même" et la plage 192.168.x.y comme étant "réseau". De cette façon , aucun provider ne fournira jamais 192.168.0.1 comme adresse internet a qqn et il est très fortement déconseillé de choisir comme adresse réseau 81.240.13.76 (qui est une pure adrese internet (la mienne en ce moment pour être précis)). Tu peu faire le test sous windows : si tu veu connaitre ton adresse internet , passe simplement sur : www.whatismyip.com Il te dira ton adresse internet. Ton adresse IP est donc différente selon les point de vue par rapport auxquels on se place : le PC lui même , le réseau et internet. Ton provider ne peut te donner qu'une adresse "selon internet" mais ton adresse "selon le réseau" ne changera pas. Que fais ton routeur ? En fait lorsque tu te connectes , ton provider t'envoie une adresse IP. Ton routeur va mémoriser cette adresse internet et faire le lien avec ton adresse réseau. Ainsi si par exemple ton adresse réseau est 192.168.0.1 et que ton provider t'envoie l'adresse IP internet 81.240.13.76 , ton routeur l'intercepte et devient donc officiellement le dépositaire de cette adresse lorsque ton routeur recevra des données pour 81.240.13.76 il va dire "Ok merci , je transmet a 192.168.0.1" Et c'est bien toi qui recoit les données. Voila C'est un peu flou....
regeditgg
 Posté le 10/01/2005 à 21:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

je ne puis répondre à snow car PC Astuce plante. Je ressaie en message nouveau

Modifié par regeditgg le 10/01/2005 21:47
regeditgg
 Posté le 10/01/2005 à 21:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Snowangelic a écrit :
Exellente question !!!!!! (Et très bonne idée d'essayer de tout capter) Ton raisonnement est très logique au vu de tes connaisssances
merci, merci !! c'est trop !!
mais faux dans l'absolu (Désolé [triste]
Ahhhhhhhhhh ! shit alors ! mais ne sois pas désolé, au contraire car au regard de tes explications claires et limpides j'ai tout compris, et surtout ce fameux 127.0.0.1 que je retrouve partout et qui doit être d'après ce que j'ai lu ailleurs le loop-back (l'auto connexion très égocentrique !!)
Je vais maintenant essayer de t'expliquer les notions qui te sont encore inconnues
Tu as fait mieux que d'essayer, tu as R E U S S I, j'ai tout pigé car c'était crystal clear. Effectivement je comprends maintenant que je me suis pris les pieds dans le tapis !!!
suite sur post suivant
Voila C'est un peu flou....[/quote] pas du tout, juste un peu fou ... comme Perrier ! (rien à voir, désolé !) MAIS, j'ai "tout bien fait comme mimile", Allo mimile, t'es là, allo, allo !! et n'arrive pas à avoir marqué Ethernet, le plus approchant est ADSL et se rapproche le plus de PPPoE. Voici mon approche d'installation. mimile (je le remets en course sinon il va bouder !) comment as-tu fait pour avoir marqué Ethernet là où j'avais lan, j'vois pas comment t'as fait, tu peux m'éclairer ? je vous joins donc mes screenshots sur le post suivant (car là c'est trop lourd et ça passe pas) pour qu'on se comprenne bien et encore merci snow pour cette longue et passionante explication. Tu as une vocation d'enseignant) @+ à vous deux

Modifié par regeditgg le 10/01/2005 21:55
Publicité
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Javascript, plugins Mandrake 10.0 [Résolu]
connection internet sous mandrake 9.2???
HELP ! Mandrake 10.1 ne démarre plus ... [résolu]
Skype pour Linux - RPM pour Mandrake 10.1 [résolu]
Mandrake Linux 10.1 - édition spéciale [résolu]
Big Problem Mandrake + Windows XP ?? [Résolu]
Mandrake 10.0 KDE [RESOLU]
Probleme cd1 Mandrake 10.1(RESOLU)
skype et mandrake 10.1 : probleme [resolu]
barre des fenetres actives disparue (resolu)
Plus de sujets relatifs à Mandrake, CNX internet disparue (RESOLU)
 > Tous les forums > Forum Linux