> Tous les forums > Forum Linux
 Mettre fire fox en FrançaisSujet résolu
Ajouter un message à la discussion
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]
dernonde
  Posté le 30/03/2019 @ 18:57 
Aller en bas de la page 
Petit astucien

Bonjour,

Je commence avec Linux Mint(32 bits) version la pus légère ;comme navigateur il y a fire fox en Anglais que je ne maîtrise pas très bien, comment mettre en Français la version existence

ou alors télécharger une version en Français qui écrasera la version installée ..Dans les "options" du menu il y a la possibilité de changer la langue,mais rien n'y fait.Merci de vos suggestions.

Publicité
Sil33
 Posté le 30/03/2019 à 19:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir.

Recherchez dans votre menu > Système (normalement) le gestionnaire de paquets Synaptic, ouvrez-le, tapez firefox dans la recherche et déroulez la liste jusqu'à tomber sur firefox qui s'accompagne de son paquet de francisation (locale). En principe libellé firefox-l10n-fr.

Sélectionnez et installez. Tout devrait rentrer dans l'ordre.

Si, par contre il l'est déjà, regardez si des locales autres ne le sont pas pas également et désinstallez-les. Sinon, je ne vois pas pour le moment.

@+

aug
 Posté le 30/03/2019 à 19:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

à tous,

Voici le paquet indiqué par Sil33:

dernonde
 Posté le 30/03/2019 à 20:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir,

Merci à vous deux pour la réponse.

J'ai bien trouvé le paquet en question,mais je reçois la réponse: W:échec de la récupération de.........etc.Ne parvient pas à résoudre <<packages linuxmint.com>>

Mais ne dois je pas d'abord désinstaller "firefox-locale-en" qui lui est installé ? comme Sill33 le précise dans sa dernière phrase

Merci de votre patience.

m_n
 Posté le 30/03/2019 à 23:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

dernonde a écrit :

Bonsoir,

Mais ne dois je pas d'abord désinstaller "firefox-locale-en" qui lui est installé ? comme Sill33 le précise dans sa dernière phrase

Merci de votre patience.

oui .. desintalle "firefox-locale-en"

aug
 Posté le 31/03/2019 à 10:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

....

Une question: tu as installé Mint ou tu est sur l'image Iso?

Slyvester
 Posté le 31/03/2019 à 10:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Une question : tu as installé Mint ou tu es sur l'image Iso?

Bonne question. Si tu es sur un C.D. Live (ou clé USB) = image .ISO), tu n'auras pas de sauvegarde des données et donc à l'utilisation suivante ==> retour à la case départ.

Pour mettre Firefox en français : https://www.monsieur-informatique.fr/fr/content/firefox-changer-la-langue-interface-contenu

ou encore : https://www.forum-entraide-informatique.com/support/mettre-mozilla-firefox-francais-t8438.html

aug
 Posté le 31/03/2019 à 11:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Slyvester,

J'ai posé la question, car la remarque sur "packages linuxmint.com" me fait plutôt penser à un problème de non-accès aux dépôts de Mint.

Logique si il est sur l'iso, mais si il a procédé à l'installation il fait ceci: ouvrir synaptic, clic sur configuration (en haut), dépôts, selectionner dépôts officiels, et à droite, clic sur la case en face de "Principal".

tous les serveurs vont être contactés et classés par vitesse. En sélectionner un et cliquer ensuite sur la phrase "Recharger le cache".

Pour ma part, j''ai choisi le serveur remi.lu, car jusqu'à présent, aucun problème rencontré avec ce serveur.

Ensuite, il peut installer le paquet si firefox est toujours en Anglais.

Slyvester
 Posté le 31/03/2019 à 11:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Aug,

Tu as raison. De toute façon, une utilisation en C.D. Live ou via clé USB ne peut être que temporaire : une heure ou deux afin de déterminer si oui ou non l'on va procéder à l'installation sur disquer dur de la distribution Linux envisagée.

Question (qui n'a rien à voir avec le sujet) : tu n'as jamais essayé/testé la Debian Sid Unstable (peu importe l'environnement de bureau) ?. J''envisage de la tester dès que la Debian version 10 sera sortie.

Publicité
aug
 Posté le 31/03/2019 à 12:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

...,

Je l'ai essayé il y a bien longtemps.

Ayant eu quelques problème, j'ai abondonné cette version.

Par rapport à la stable, j'ai essayé la Testing en faisant ce qu'indique Logicien dans ce post:

https://forum.pcastuces.com/sujet.asp?f=8&s=15640

Par contre, je fais "apt-get upgrade" et non "apt-get dist-upgrade" pour ne pas basculer complètement mais pouvoir bénéficier des mises à jour.

dernonde
 Posté le 31/03/2019 à 13:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Merci à tous les intervenants.

Voilà, j'ai désinstallé le pack "en",j'ai relancé l'installation fr ,mais j'ai toujours "échec". J'ai essayé de remettre la version d'origine en reprenant le pack "en" et aussi "échec" .

Je vais devoir essayé autre chose.

Pour répondre aux questions posées. J'ai télécharger l'image "iso" sur un dvd, puis je l'ai installé sur le PC.

En attendant d'autre suggestions. Non je n'ai pas testé la Debian Sid Unstable, pour la simple raison que je commence avec linux et que je ne connais pas cette méthode;

Je ne suis pas un as de l'informatique.,plutôt profane en la matière et surtout avec linux.

Merci de votre aide.

Ce qui est bizarre j'ai redémarrer mon pc(on ne sait jamais). J'ai lancé "firefox" et celui-ci s'ouvre comme avant,rien n'est changé;pourtant le "paquet" "firefox-locale-en"n'est plus coché comme au tout début , avant que je ne le

désinstalle.Si cela peut aider à solutionner mon problème.Merci

aug
 Posté le 31/03/2019 à 14:52 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Fais ce que je t'indique dans mon message de 11:05.

Si tu as l'icône de mise à jour dans le tableau de bord (barre des taches), cliques dessus, dans la fenêtre qui s'ouvre, clic sur Edition (en haut), puis sur source de logiciels, mot de passe peut-être demandé et tu arrives aussi sur la fenêtre des dépôts et fais la suite comme indiqué précedemment.

Je mets copie de cette fenêtre comme elle se présente ici bien que je ne suis pas sur la dernière version de Mint:

Slyvester
 Posté le 31/03/2019 à 15:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re,

Merci, Aug, pour ton lien. Je connais cette procédure que j'appliquerai (+ adaptation : testing => unstable) en cas d'installation de Debian 10 Sid Unstable.

... bien que je ne suis pas sur la dernière version de Mint ...

Aug, tu es en version 18 LTS, mais tu peux bénéficier des mises à jour de Linux Mint 19 en cochant "Composants optionnels/Paquets instables (Roméo)". Tu ne risques rien.

Dernonde,

Tu souhaites obtenir Firefox en Français : ==> ouvre Firefox, clique sur l'onglet "Outils" et ensuite clique sur "Modèles complémentaires" et là, tu choisis le dernier onlet "Langues". Vérifie si tu ne dois pas activer la langue française.

J'ai la version 66.0.1 de Firefox et j'ai dû désactiver beaucoup de langues dont je ne sers pas pour mes recherches. Je n'utilise que deux langues, l'anglais US + le français.



Modifié par Slyvester le 31/03/2019 15:39
aug
 Posté le 31/03/2019 à 15:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

...

Slyvester,

Merci pour ta remarque: j'essaierai cette option.

dernonde
 Posté le 31/03/2019 à 20:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir aug,

Merci pour tes conseils; Voilà j'ai a peu près la même fenêtre que toi,je suis en version 19.1 xfce. Dans miroir j'ai

Principal (tessa) : http://packages.linuxmint.com

Base(bionic) :la même chose que toi. Puis

Sources optionnelles

Dépôts de code source que je peux activer

Symboles de débogage que je peux activer

Paquets instables(romeo) que je peux activer

rétablir les paramètres par défaut

Dans la colonne de gauche:Dépôts officiels

PPA

Dépôts additionnels

Clés d'authenfication

Maintenance

Maintenant que dois-je faire avec tout cela ? Merci

aug
 Posté le 31/03/2019 à 20:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Comme indiqué, tu cliques sur la case devant Principal, c'est à dire sur http://packages.linuxmint.com.

dans la fenêtre suivante, il va contacter tous les serveurs et les classer par vitesse, le premier étant le plus rapide.

Tu cliques sur un serveur pour le sélectionner,son nom va s'afficher à la place de https://packages.linuxmint.com ( chez moi, c'est remi.lu que j'ai choisi)et une phrase va apparaître "recharger le cache" à la place de "aucune action requise"(voir ma capture), il faut alors cliquer sur cette phrase at attendre que la mise à jour du cache se fasse.

Ensuite tu referme tout, tu lances le gestionnaire de paquets synaptique et tu installes le paquet de francisation de firefox.

Vérifier que ce paquet de francisation correspond à la version de firefox qui est installée (66 ou autre).

dernonde
 Posté le 31/03/2019 à 21:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonsoir aug,

J'ai suivi ce que tu m'as expliqué,je n'ai pas cherché j'ai mis comme toi "remi.lu".

Maintenant,quand je suis sur firefox-locale-fr, je sais sélectionner pour installation et ensuite je ne sais plus rien faire d'autre ,sinon "déselectionner" et "propriétés",,tout le reste est grisé .Je ne sais plus lancer l'installation ?

Je commence à désespérer. Merci

Bonne soirée

Publicité
aug
 Posté le 31/03/2019 à 21:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

...

Une fois que tu as sélectionner pour installation, clic sur appliquer en haut. si une fenêtre s'ouvre tu confirme.

dernonde
 Posté le 01/04/2019 à 10:29 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Merci de ta réponse.

En effet j'ai pu lancer la procédure. mais je reçois encore "échec de la récupération de http://mint.remi.lu/pool/upstream/f/firefox/firefox-locale-fr_66.0.1+linuxmint1+tessa_i386.deb

Ne parvient pas à résoudre >>mint.remi.lu>>

Quant il me propose "A installer" avant de cliquer sur "Appliquer"j'ai la possibilité de cocher Ne faire que le téléchargement des fichiers des paquets, dois je cocher cela ?

Merci

dernonde
 Posté le 01/04/2019 à 10:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Re,

Ah ,j'oubliais 66.0.1 est bien ma version de firefox.

aug
 Posté le 01/04/2019 à 11:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

...

Ouvres le gestionnaire de paquets Synaptic, clic sur recharger en haut, ensuite tu refais l'opération de francisation.

Ne coches la phrase.

dernonde
 Posté le 01/04/2019 à 18:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour Slyvester,

Maintenant que le pack Français est chargé l'onglet langue est là,autrement je ne le voyais pas.

Merci pour ton aide.

dernonde
 Posté le 01/04/2019 à 18:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour Slyvester,

Maintenant que le pack Français est chargé l'onglet langue est là,autrement je ne le voyais pas.

Merci pour ton aide.

dernonde
 Posté le 01/04/2019 à 18:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour aug,

Maintenant le pack français s'est bien installé,tout est en ordre,merci encore de ta patience,cela m'a permis d'apprendre beaucoup sur Linux.

Merci aux autres intervenants de leur suggestion.

A bientôt

aug
 Posté le 01/04/2019 à 18:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

C'est bien.

N'hésites pas à venir poser questions si tu en as besoin.

un avis: faire clic droit sur une partie vide du tableau de bord ,ou sur chaque élément qui le compose puis propriétés, car il y a des options ou des choix à faire.

A bientôt.

Slyvester
 Posté le 02/04/2019 à 09:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour Dernonde,

Bonjour Slyvester,

Maintenant que le pack Français est chargé l'onglet langue est là,autrement je ne le voyais pas.

Merci pour ton aide

Je suis content pour toi que tu sois parvenu à tes fins. Je suivais ton sujet mais ne voulais pas faire de l'ombre à Aug, qui est toujours de bon conseil.

Un conseil ou suggestion : tu disposes de Linux Mint 19 LTS => c'est un très bon choix. Tu peux apprendre beaucoup et par toi-même en survolant le forum de Linux Mint. Tu y trouves les problèmes rencontrés par les utilisateurs de Linux Mint :

https://forum-francophone-linuxmint.fr/index.php?sid=42fb936e59e57edb90d41299a3055414

Publicité
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Mettre en français
comment mettre firefox en français
Comment mettre en français une version non-officielle de Ubuntu
mettre opéra 8.5 en français
Mettre la barre des tâches en haut de l'écran Linux Mint 19 !!!
Thunderbird en français
Voudrais mettre Linux Mint sur VirtualBox...
mettre linux sur clé usb.
Comment mettre à jour Bleachbit sous Antergos
Du besoin pour Linux de mettre à zéro un disque dur formaté en Fat
Plus de sujets relatifs à Mettre fire fox en Français
 > Tous les forums > Forum Linux