> Tous les forums > Forum Bureautique
 MFC Excel s'applique aléatoirementSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
NyaH
  Posté le 12/03/2019 @ 15:35 
Aller en bas de la page 
Petite astucienne


Tout d'abord Bonjour à tous et à toutes ! Je suis toute nouvelle sur ce forum, et nouvelle en forum en général...

J'aimerais avoir vos conseils et astuces d'expert pour un problème rencontré sur Excel...

Malgré mes recherches intenses je n'ai pas véritablement trouvé la solution...

Explications :

J'utilise une version Office 16 d'Excel sous Windows 7. J'ai créé un tableau qui contient des MFC.

Ma directrice utilise la même version sous le même système ; mais lorsqu'elle utilise ce tableau, les MFC s'appliquent aléatoirement...

Par exemple : dans mon tableau, si l'on indique la lettre P (pour payé) dans une cellule, toute la ligne correspondante se met en couleur de police noire (à la base en rouge pour les non-payés).

Seulement lorsqu'elle utilise ce tableau, ça fonctionne bien au début mais lorsqu'elle modifie une autre cellule ou lorsqu'elle va sur une autre feuille du même classeur, la MFC saute et tout redevient rouge... Sur mon poste, tout s'affiche et se change bien.

Je n'y comprends rien... en faisant des recherches, j'ai vu que certaines versions antérieures d'Excel n'acceptaient que 3 MFC maximum mais puisque nous avons les mêmes versions...

J'ai fait plein de tests, vérifié les compatibilités, etc. sans soluce...

Bref, si vous avez la solution et/ou l'explication, je suis preneuse

Je ne peux malheureusement pas vous fournir le tableau puisque confidentiel.

Merci par avance

Publicité
poussebois
 Posté le 12/03/2019 à 16:05 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

Bonjour et bienvenue sur PC Astuces ,

Même Système d'Exploitation, même version d'Excel (2016 je suppose ?), même fichier et comportement différent .

Présenté comme cela, ça va être difficile de te répondre.

Il faudrait que tu envoies un fichier exemple avec toutes les données sensibles effacées, mais même ainsi, comment chercher si on constate que tout fonctionne correctement ...

Regarde du côté des options s'il n'y a pas quelque chose de différent qui concernerait les MFC.

Je ne peux en dire plus, d'autant que je n'ai qu'Excel 2007.

@ +

NyaH
 Posté le 12/03/2019 à 16:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne
poussebois a écrit :

Bonjour et bienvenue sur PC Astuces ,

Même Système d'Exploitation, même version d'Excel (2016 je suppose ?), même fichier et comportement différent .

Présenté comme cela, ça va être difficile de te répondre.

Il faudrait que tu envoies un fichier exemple avec toutes les données sensibles effacées, mais même ainsi, comment chercher si on constate que tout fonctionne correctement ...

Regarde du côté des options s'il n'y a pas quelque chose de différent qui concernerait les MFC.

Je ne peux en dire plus, d'autant que je n'ai qu'Excel 2007.

@ +

Merci poussebois !

Je te joins le fichier via le lien ci-dessous, tu verras la colonne ou nous indiquons le P pour payé, certaines lignes se remettent bien en noir et d'autres non... Je viens de m'apercevoir en te préparant le fichier que ça faisait la même chose sur mon poste

https://www.cjoint.com/c/ICmpy1RAVXj

Sans doute mes MFC ? Je vais peut-être devoir toutes les refaire...

J'avoue que je suis novice dans les MFC alors ça vient certainement de là

Merci ! A+

poussebois
 Posté le 12/03/2019 à 17:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

,

Tu dis que "certaines versions antérieures d'Excel n'acceptaient que 3 MFC maximum". j'ignorais ce fait, mais avec mon Excel 2007, je vois toutes tes MFC.

Je les ai épluchées 1 par 1, elles sont (semblent) correctes.

Mais en effet, les lignes 7, 8, 28, 29, 61 à 64 ne fonctionnent pas.

J'ai trouvé une solution par tâtonnement : il faut recopier la mise en forme d'une cellule qui fonctionne correctement sur celles pour qui ce n'est pas le cas et il faut le faire colonne par colonne.

Je n'ai pas d'explication à ce comportement. Un autre astucien peut-être ...

NyaH
 Posté le 12/03/2019 à 17:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne
poussebois a écrit :

,

Tu dis que "certaines versions antérieures d'Excel n'acceptaient que 3 MFC maximum". j'ignorais ce fait, mais avec mon Excel 2007, je vois toutes tes MFC.

Je les ai épluchées 1 par 1, elles sont (semblent) correctes.

Mais en effet, les lignes 7, 8, 28, 29, 61 à 64 ne fonctionnent pas.

J'ai trouvé une solution par tâtonnement : il faut recopier la mise en forme d'une cellule qui fonctionne correctement sur celles pour qui ce n'est pas le cas et il faut le faire colonne par colonne.

Je n'ai pas d'explication à ce comportement. Un autre astucien peut-être ...

Bon au moins, mes MFC semblent correctes et ça me fait plaisir

Et oui apparemment, ce sont les versions antérieures à 2007 je crois pour les 3 MFC max...

Merci d'y avoir passé du temps en tout cas, si d'autres astuciens ont la soluce, je patiente un peu... sinon je vais essayer ce que tu me dit entre-temps.

Merci encore ! Bonne soirée poussebois !

DjiDji59430
 Posté le 12/03/2019 à 17:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

J'ai regardé ton fichier, il fonctionne chez moi.

J'ai refait les mfc et mis un choix dans prépa,four; etc

https://www.cjoint.com/c/ICmqWKyXobV


Crdlmt

NyaH
 Posté le 12/03/2019 à 17:58 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne
DjiDji59430 a écrit :

Bonjour,

J'ai regardé ton fichier, il fonctionne chez moi.

J'ai refait les mfc et mis un choix dans prépa,four; etc

https://www.cjoint.com/c/ICmqWKyXobV


Crdlmt

Bonjour DjiDji59430 ! Et merci,

La liste pour la colonne Prépa, four et auto ok. mais c'est surtout la ligne qui ne reste pas en noire lorsque l'on met le "p".

Même sur ton tableau, au début quand je mets le "p" tout fonctionne bien, puis je descends... et quand je remonte au début de mon tableau, toutes les lignes où j'ai mis "p" sont redevenues rouge

Incompréhensible ce truc... ou alors j'en demande trop à Excel ?? lool ça m'étonne vu tout ce qu'on peut faire... Arf on dirait bien que je pose une colle à nos Experts

Merci quand même

poussebois
 Posté le 12/03/2019 à 18:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien

,

Le fichier qui "marche" bien là : https://cjoint.com/c/ICmrq3KzbNN

Je n'ai pas mis le choix de DjiDji59430 , je suppose que tu sais faire ...

jpr73
 Posté le 12/03/2019 à 18:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Modifications des MFC sur toute la plage pour la couleur de police

Modifications des MFC sur la colonne montant réglé et flag P pour la couleur de cellule

Mise en place des ordres de priorités : interrompre si vrai

Complément des formules de la colonne montant à régler

NB : la plage des MFC a été réduite à la taille du tableau

Cordialement

https://www.cjoint.com/c/ICmr64P2tZh

Publicité
Debrief
 Posté le 13/03/2019 à 07:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je peux provoquer un comportement étrange qui met en rouge les caractères en ouvrant un autre classeur. Mais pas tous, certains seulement, et ça varie !!!

D'autres actions ou évènements sur le PC provoquent aussi ce phénomène très étrange. Ça m'a l'air d'un gros bug Excel (2013 dans mon cas).

Tu pourrais déjà simplifier tes MFC caractères noirs en 2 MFC au lieu de 6 avec un test =$J4="p".
Même chose pour tes 2 MFC de fond jaune. Mais ça ne change rien au problème.



Modifié par Debrief le 13/03/2019 08:51
Debrief
 Posté le 13/03/2019 à 08:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Dans les MFC j'ai remplacé ton format de caractère couleur noire par couleur Automatique. Chez moi cela fixe le problème.

Cordialement,
D.

P.S. C'est un problème Excel manifestement.



Modifié par Debrief le 13/03/2019 08:23
NyaH
 Posté le 13/03/2019 à 09:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne
poussebois a écrit :

,

Le fichier qui "marche" bien là : https://cjoint.com/c/ICmrq3KzbNN

Je n'ai pas mis le choix de DjiDji59430 , je suppose que tu sais faire ...

Merci poussebois mais même problème sur ce fichier... oui je sais faire mais pas utile chez nous en fait, je veux limiter le nombre de clics pour les utilisateurs (ils ne sont pas très à l'aise avec Excel et l'informatique en général d'ailleurs )

Donc il fallait que je fasse un tableau un minimum "automatisé" et simple surtout... si je commence à faire des macros, je vais en perdre quelques uns je pense ;) même si j'en ai quand même fait sur certain fichier

NyaH
 Posté le 13/03/2019 à 09:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne
jpr73 a écrit :

Bonjour,

Modifications des MFC sur toute la plage pour la couleur de police

Modifications des MFC sur la colonne montant réglé et flag P pour la couleur de cellule

Mise en place des ordres de priorités : interrompre si vrai

Complément des formules de la colonne montant à régler

NB : la plage des MFC a été réduite à la taille du tableau

Cordialement

https://www.cjoint.com/c/ICmr64P2tZh

Bonjour jpr73 ! Et UN GRAND MERCI ! ton fichier fonctionne très bien !

Je vais étudier ce que tu as fait et en prendre de la graine ;)

Il semble que le $J4 change tout

Merci encore !

NyaH
 Posté le 13/03/2019 à 09:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne
Debrief a écrit :

Je peux provoquer un comportement étrange qui met en rouge les caractères en ouvrant un autre classeur. Mais pas tous, certains seulement, et ça varie !!!

D'autres actions ou évènements sur le PC provoquent aussi ce phénomène très étrange. Ça m'a l'air d'un gros bug Excel (2013 dans mon cas).

Tu pourrais déjà simplifier tes MFC caractères noirs en 2 MFC au lieu de 6 avec un test =$J4="p".
Même chose pour tes 2 MFC de fond jaune. Mais ça ne change rien au problème.

Bonjour debrief,

oui le $J4 y est pour beaucoup, et oui c'est très étrange comme comportement d'Excel, surtout qu'au début tout fonctionnait bien...

Et pour la couleur, j'ai mis en noir puisque ça ne fonctionnait pas chez moi au "automatique".

Merci pour le temps consacré en tout cas !

Debrief
 Posté le 13/03/2019 à 11:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Et pour la couleur, j'ai mis en noir puisque ça ne fonctionnait pas chez moi au "automatique".

Alors ça c'est encore plus étrange :).

D'autant plus que je viens de voir que le fichier de jpr73 utilise la couleur Automatique et pas Noire .

D.



Modifié par Debrief le 13/03/2019 11:35
NyaH
 Posté le 13/03/2019 à 11:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne
Debrief a écrit :

Bonjour,

Et pour la couleur, j'ai mis en noir puisque ça ne fonctionnait pas chez moi au "automatique".

Alors ça c'est encore plus étrange :)

D.

Oui comme tu dis... J'ai toujours le chic pour avoir des choses étranges...

Bon alors après avoir testé, même avec le tableau de Jpr73 qui fonctionnait très bien... J'ai testé ses MFC dans mon tableau mais ça ne fonctionnait toujours pas.

Je pense avoir trouvé la solution, j'ai changé mes MFC en indiquant de mettre en noir et en gras quand J=p (de B jusqu'à la colonne J) et en fond jaune pour les colonnes I et J.

Peut-être qu'Excel n'aime pas non plus les problèmes circulaires en MFC ? Peut-être que le fait que la "base" soit en police rouge, il n'aime pas non plus - Enfin bref, il doit avoir ses règles quoi

Pour l'instant ça fonctionne comme ça, et c'est quand même grâce à vous tous

Debrief
 Posté le 13/03/2019 à 11:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je te renvoie ton propre fichier avec seulement le format caractère couleur Noire modifié en couleur Automatique.

Chez moi ça marche, plus de couleur rouge intempestive lorsque "p" est en colonne J.

Qu'est-ce que ça donne chez toi ? -> https://www.cjoint.com/c/ICnkTqM1GNi

Publicité
NyaH
 Posté le 13/03/2019 à 11:56 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne
Debrief a écrit :

Je te renvoie ton propre fichier avec seulement le format caractère couleur Noire modifié en couleur Automatique.

Chez moi ça marche, plus de couleur rouge intempestive lorsque "p" est en colonne J.

Qu'est-ce que ça donne chez toi ? -> https://www.cjoint.com/c/ICnkTqM1GNi

J'ai testé, tout comme le tableau de jpr73 ça fonctionne très bien aussi. Seulement dès que je l'applique dans mon tableau officiel, ça bug

J'ai évidemment plus de données et plein de feuilles alors je sais pô...

Debrief
 Posté le 13/03/2019 à 12:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Seulement dès que je l'applique dans mon tableau officiel, ça bug

Qu'est-ce que tu veux dire par là ? Le phénomène des "caractères rouges" se reproduit ?

Et comment tu "l'appliques" dans ton tableau ?



Modifié par Debrief le 13/03/2019 12:21
Debrief
 Posté le 13/03/2019 à 12:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Sinon, autre possiblité...

-Créé un fichier Excel nouveau.

- Sélectionne toute ta feuille à problème et fais Copier

- Colle sur la feuille de ton nouveau fichier

- Sélectionne toute ta feuille du nouveau fichier et clique droit puis effacer le contenu

=> la feuille est vide mais les formats et donc MFC y sont encore.

Peux-tu envoyer cette feuille ?

NyaH
 Posté le 13/03/2019 à 13:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne
Debrief a écrit :

Seulement dès que je l'applique dans mon tableau officiel, ça bug

Qu'est-ce que tu veux dire par là ? Le phénomène des "caractères rouges" se reproduit ?

Et comment tu "l'appliques" dans ton tableau ?

J'ai refaits mes MFC comme dans le tableau TEST qui fonctionne... et ça marche pô... les caractères rouges reviennent...

Du coup, je te renvoie le même fichier test avec en Feuil2 le tableau effacé. Tu verras j'ai créé une feuille "Anciennes MFC" où ce qui est bizarre, c'est que quand je mets le p, ça fonctionne puis je descends juste le tableau jusqu'à ce que cette ligne où j'ai mis le p ne soit plus à l'écran, et quand je remonte pour voir cette ligne, elle est redevenue rouge...

Bref, en tout cas les changements que j'ai fait, en mettant en gras, fonctionnent donc te prends pas trop la tête non plus Merci !

https://www.cjoint.com/c/ICnmiqq3OFj

Debrief
 Posté le 13/03/2019 à 13:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bon ok, si tu as résolu le problème en mettant en gras, autant s'arrêter là car difficile de se mettre dans tes conditions de travail avec un fichier complet.

Peut-être que la couleur automatique (au lieu de noire) n'est pas suffisante dans ton cas pour déclencher l'application de la MFC et que l'ajout du Gras l'y contraint (?).

@+
D.

NyaH
 Posté le 13/03/2019 à 13:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petite astucienne
Debrief a écrit :

Bon ok, si tu as résolu le problème en mettant en gras, autant s'arrêter là car difficile de se mettre dans tes conditions de travail avec un fichier complet.

Peut-être que la couleur automatique (au lieu de noire) n'est pas suffisante dans ton cas pour déclencher l'application de la MFC et que l'ajout du Gras l'y contraint (?).

@+
D.

Oui peut-être que c'est ça... Étrange quand même...

Là j'ai simplifié mes MFC comme conseillé, en espérant que ça ne plante pas dans quelques temps

Merci Debrief ! Bonne journée

Publicité
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Aucun sujet pertinent lié trouvé
 > Tous les forums > Forum Bureautique