> Tous les forums > Forum des Webmasters
 Migration PHP 5.3 vers 5.5 ou 5.6 (avec WAMP)Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
galopin01
  Posté le 02/04/2015 @ 08:41 
Aller en bas de la page 
Astucien

Bonjour,

Je dispose d'un site sur OVH et je suis contraint de passer de PHP 5.3 vers une version plus récente J'envisage de passer à 5.5 ou 5.6.

Pour info je n'utilisait jusqu'à présent qu'une infime partie de PHP dont l'essentiel est include et isset !

Je n'utilise aucun cms et aucune base de données et le site comporte plusieurs centaines de pages .php et plusieurs dizaines de milliers de photos et d'archives...

1er problème quand on interroge Google on s'aperçoit que la mise à jour de PHP semble liée (pour mon cas) à la mise à jour de WampServer

Il semble qu'il existe 2 possibilités :

http://www.wampserver.com/#download-wrapper

et http://sourceforge.net/projects/wampserver/files/

La première source affiche plusieurs mise en garde et nécessite notamment la mise à jour de Visual Studio

tandis que Source Forge n'affiche aucune mise en garde.

Pour info ma version actuelle de WampServer est 2.1

et ma version de Visual Studio (que je n'utilise pas) est de 2010

Que dois-je faire ?

Merci



Modifié par galopin01 le 02/04/2015 13:31
Publicité
galopin01
 Posté le 02/04/2015 à 18:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Je me répond à moi même, j'ai téléchargé

Microsoft visual C++ 2012 redistribuable 64 et

Microsoft visual C++ 2012 redistribuable 86

et WampServer 64



Modifié par galopin01 le 02/04/2015 19:30
y.bli
 Posté le 02/04/2015 à 21:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Maître astucien
Message original par galopin01

Je dispose d'un site sur OVH et je suis contraint de passer de PHP 5.3 vers une version plus récente J'envisage de passer à 5.5 ou 5.6.

Bonjour,

WampServer te permet de faire tourner Apache sur ton PC.

OVH signale qu'il faut migrer vers des versions plus récentes de PHP (5.5 ou 5.6), non pas pour le fonctionnement sur ton PC mais pour le fonctionnement sur leurs serveurs (ton PC ils en ont rien à faire).

Je pense que les quelques fonctions que tu utilises ne sont pas impactées par PHP 5.5 ou 5.6. et il suffit de mettre le fichier .ovhconfig à la racine de ton espace avec app.engine.version=5.5

@+



Modifié par y.bli le 03/04/2015 13:31
galopin01
 Posté le 03/04/2015 à 04:18 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

bonjour,

Je suis bien content d'apprendre que je me suis fait c... pour rien ! Merci quand même de m'avoir déniaisé !

D'un autre coté une petite update de tous ces prog n'a pas fait de mal : Leur installation datait de 2010 ça va dépoussiérer.

Comme je suis vraiment une buse sur PHP, Apache et SQL je n'ai jamais réellement compris faire fonctionner TOUSSA

(Je n'avais d'ailleurs jamais eu le temps de creuser !) alors "mettre un fichier .ovhconfig" à la racine, pour moi c'était du javanais... Mais j'ai fini par me rappeler qu'il y a très longtemps j'avais du y déposer un fichier .htaccess dont je ne me rappelle même plus à quoi il servait...

J'ai fait de même et visiblement et c'est ok : Je n'ai pas de dysfonctionement sur mon site. Mon seul problème a été pour le paramétrage de wampserver qui n'affichait plus le localhost, mais j'ai fini par dénicher "le loup"...

Merci quand même de ton intervention.

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
449,99 €Portable Dell Inspiron 15 3501 (15.6 pouces, FullHD, Core i3, 8Go, SSD 256Go) à 449,99 €
Valable jusqu'au 24 Janvier

RueDuCommerce fait une promotion sur l'ordinateur portable Dell Inspiron 15 3501 qui passe à 449,99 € alors qu'on le trouve ailleurs à partir de 529 €. Cet ordinateur possède un écran 15,6 pouces Full HD (1920x1080), un processeur Intel Core i3-1115G4 avec chip graphique Intel UHD intégré, 8 Go de RAM (extensibles à 16 Go) et un SSD NVMe de 256 Go. Le tout tourne sous Windows 10 qui peut être mis à jour pour Windows 11.


> Voir l'offre
34,99 €Ventirad processeur Thermaltake ToughAir 510 à 34,99 €
Valable jusqu'au 23 Janvier

TopAchat solde le ventirad processeur Thermaltake ToughAir 510 à 34,99 € au lieu de 58,99 €. Fourni avec 2 ventilateurs de 120 mm. TDP 180W. 


> Voir l'offre
GratuitJeu PC Relicta gratuit
Valable jusqu'au 27 Janvier

Epic Game Store offre actuellement le jeu Relicta. Relicta est un jeu d'énigmes basées sur la physique. En vue à la première personne, vous devez combiner magnétisme et gravité pour que les secrets de la Base Chandra vous soient révélés. Seule dans les profondeurs de la lune, votre esprit scientifique est la seule chose qui va pouvoir garder votre fille en vie… Audio en anglais, texte en français. Pegi 16.


> Voir l'offre

Sujets relatifs
je ne sais pas créer une bdd avec wamp !
pb localhost avec Wamp et Drupal en local
courriel avec lien vers site
prob' avec php, redirection vers lemonde.fr
lien vers la messagerie avec frontpage 2003
Lien vers un mail avec son titre ?
Chemin vers répertoire privé
Hébergement de site avec nom de domaine
background css disparait avec le responsive design
Site codé vers CMS
Plus de sujets relatifs à Migration PHP 5.3 vers 5.5 ou 5.6 (avec WAMP)
 > Tous les forums > Forum Forum des Webmasters