> Tous les forums > Forum Linux
 mise a jour adobeSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
pat62
  Posté le 08/07/2015 @ 14:32 
Aller en bas de la page 
Petit astucien

bonjour

je recherche une mise à jour adobe pour mon système d’exploitation nouva linux.

merci d'avance

Publicité
reivillo
 Posté le 16/07/2015 à 22:43 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir pat62.

Ne t’étonnes pas, de l'absence de réponses vu l'Avalanche d'Infos que tu as donné!...
1_ Infos sur le Matériel.
2_ Pour quel Système d'Exploitation Linux.
3_ De quel Adobe parles-tu...Flash player?

Ça, serait déjà pas mal pour que des Intervenants s'intéressent à ton Sujet.( Sont peut-être Divins, mais pas Devins. )


Amicalement.
Reivillo.



Modifié par reivillo le 16/07/2015 22:48
beezapa
 Posté le 17/07/2015 à 12:14 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Reivillo,

Quelle prose.....

Mori
 Posté le 17/07/2015 à 17:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

salut, la distro a été donnée : nouvalinux http://nouvalinux.org/nouvalinux-rescue-cd/ mais la logique d'un CD de sauvegarde ne doit pas être dans des mises à jour de la distro elle-même. enfin je suppose puisque je n'ai jamais utilisé de rescue-CD. pourquoi as-tu besoin d'une mise à jour de adobe flashplayer ?
beezapa
 Posté le 17/07/2015 à 18:33 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Parce que comme beaucoup, ils sont sur Facebook et autres réseaux sociaux qui mangent à chaque page du flash à tour de bras.


Fait mouliner inutilement le ou les processeurs.


Contient des failles suffisamment dangereuses pour être mis en suspend, voilà pourquoi j'emploie flashplugin-nonfree pour autant

que votre Linux soit un dérivé de Debian.


https://wiki.debian.org/fr/FlashPlayer

Anonyme
 Posté le 01/08/2015 à 21:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Nouvel astucien

Le flash est déjà remplacé par le HTML5 qu'on peut lire avec le plugin shumway

Slyvester
 Posté le 02/08/2015 à 10:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Etant donné que : http://doc.ubuntu-fr.org/flashplayer

Adobe arrête le développement du plugin Flash pour GNU/Linux pour se consacrer à Windows. La dernière version stable est la 11,2,202,xxx. Adobe continuera à fournir les correctifs de sécurité pendant 5 ans (soit la durée de vie d'Ubuntu Précise 12.04 LTS). Néanmoins, Adobe refuse de corriger des bugs qui rendent FlashPlayer inutilisable pour certaines vidéos et animations. https://blogs.adobe.com/flashplayer/2012/02/adobe-and-google-partnering-for-flash-player-on-linux.html?PID=4165004" href="https://blogs.adobe.com/flashplayer/2012/02/adobe-and-google-partnering-for-flash-player-on-linux.html?PID=4165004" rel="nofollow"> (en) Source blog d'Adobe .

Pour bénéficier alors d'une version supérieure de FlashPayer pour Ubuntu, (par exemple pour pouvoir jouer à Forge of empires ou utiliser Audiotool), il suffit soit d'utiliser:

J'ai choisi la solution de Freshplayer : http://doc.ubuntu-fr.org/flashplayer#pour_firefox Je dispose ainsi du Shockwave Flash 18.0.0.209.



Modifié par Slyvester le 02/08/2015 10:36
Mimile
 Posté le 02/08/2015 à 11:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

Je ne sais de quoi dérive ton OS (nouva Linux ?).

SI c'est basé sur Debian, voici comment procéder à condition que tu utilises Firefox comme navigateur.

Sur le site adobe, télécharger la version tar.gz de flashplayer :

Une fois téléchargé, décompresser le fichier obtenu avec le gestionnaire d'archive dans un dossier quelconque (moi, j'ai créé dans mon /home un dossier Flashplayer (mkdir /home/ton_nom_d'user/Flashplayer).

La décompression de l'archive va te donner 4 objets :

Le plugin est libflashplayer.so.

Maintenant, il s'agit de le copier dans le dossier /usr/lib/mozilla/plugins :

Il faut d'abord te loger dans le répertoire Flashplayer : cd /home/ton_nom_d'user/Flashplayer puis : sudo cp libflashplayer.so /usr/lib/mozilla/plugins

Autre façon de faire : tu te loges dans le dossier /usr/lib/mozilla/plugins (cd /usr/lib/mozilla/plugins) puis : sudo ln -s /home/ton_nom_d'user/Flashplayer/libflashplayer.so

Au final, tu auras le dernier plugin Flasplayer dans la liste des plugins de Firefox.

A+



Modifié par Mimile le 02/08/2015 11:04
Slyvester
 Posté le 03/08/2015 à 14:32 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

La méthode de Mimile ne permet d'obtenir que le Shockwave Flash 11.2.202.491. Celle que j'utilise & préconise permet d'installer le Shockwave Flash 18.0.0.209 = Firefox avec le plugin Freshplayerplugin. Freshplayer : http://doc.ubuntu-fr.org/flashplayer#pour_firefox



Modifié par Slyvester le 03/08/2015 14:33
Publicité
Mimile
 Posté le 07/08/2015 à 12:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut,

J'ai suivi ton lien à la lettre mais de toute évidence, il ne convient pas à mon OS (Linux Mint 17.1 - 64 bits).

J'ai bien un shockwave flash 13.03 qui est venu s'ajouter à Firefox mais l'ancien (11.2 reste en place).

Ce qui est étrange, c'est que quand je désactive l'ancien 11.2, cela désactive aussi le nouveau.

Si j'active les deux, Firefox plante.

J'ai donc supprimer le plugin relatif à Freshplayer dans /usr/lib/mozilla/plugins ce qui a rendu sa stabilité à Firefox.

Je me contenterai donc de l'ancienne version.

A+



Modifié par Mimile le 07/08/2015 12:39
beezapa
 Posté le 07/08/2015 à 13:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Salut à vous tous,

J'ai fait de même et cela ne fonctionne pas Mint 17 LTS, donc j'attends une solution qui j'espère rendra Firefox complet.En attendant, je me sers de chromium, mais cela me perturbe dans la façon d'utiliser ce navigateur, certaine habitude onla vie dure

reivillo
 Posté le 07/08/2015 à 15:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

@ beezapa.

Tu n'arrives pas à faire tourner Flashplayer sur Mint 17 LTS...c'est ça?
On utilise une ancienne Bibliothèque libflashplayer.so soit la Shockwave Flash 10.3 d180.
Un exemple: Le processeur( ancien ), un AMD Athlon XP + ( Alias Barton ) n'intégrant pas les Instructions SSE2, mais simplement l' SSE.
Les nouveaux Shockwave Flash, se servant uniquement des instructions SSE2.
Si tu veux, je peux te Développer notre mise en place de FlashPlayer, sur les Mint 17 LTS...ou Autres OS Linux.
Ici,
on y est aguerrit à ce genre de Manip, sur nos Ordinosaures, en Recyclage...

beezapa
 Posté le 07/08/2015 à 21:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Salut toi,



Ce n'est pas que ça ne tourne pas, c'est que ça fait planter Firefox.

Je regarde maintenant sur chromium les vidéos de YouTube, j'attends qu'ils proposent un nouveau package, j'ai fait remonter les bugs

comme d'habitude, mais pas de réponse actuellement.

Mais tu me proposes Byzance oui bien sûr que je serais heureux de l'accepter, pourquoi ne pas proposer le package sur le site de Mint.
Quand une chose me manque, je vais souvent a tâtons sur le site http://pkgs.org/

Bon Week-end

reivillo
 Posté le 07/08/2015 à 22:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

@ beezapa.

Mais tu me proposes Byzance...

Byzance, Bysance... Tu as dit Bysance! Comme c'est Byzance...

Reivillo....

Note: http://pkgs.org/; OUI bien sûr; Mais...Lien à suivre avec Parcimonie, et à bon Escient.



Modifié par reivillo le 07/08/2015 22:31
Mimile
 Posté le 08/08/2015 à 12:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut

Finalement, j'ai réussi à intégrer Freshplayerplugin 18.0.0.209 dans la liste des plugins de Firefox.

Comme manifestement, ça ne marchait pas en ligne de commande (sudo apt-get install freshplayerplugin), après avoir ajouté le PPA puis mis à jour mes dépôts, j'ai ouvert synaptic et j'ai constaté que freshplayerplugin était installé (sans toutefois apparaître dans la liste des plugins de Firefox).

J'ai opté pour la solution de "réinstallation" et miracle, à l'issue des opérations, le plugin apparaissait enfin.

J'ai désactivé l'ancien plugin (11) car j'ai constaté que la commande sudo apt-get remove adobe-flashplugin avait un impact négatif dans la mesure où elle ne se contente pas de supprimer adobe-flashplugin mais aussi mint-codecs dont j'ignore le rôle mais qui doit avoir son importance.

Bref, en ce qui me concerne, problème résolu !

Un merci tout particulier à Sylvester qui m'a orienté sur le wiki d'Ubuntu.

Amicalement



Modifié par Mimile le 08/08/2015 12:09
Slyvester
 Posté le 08/08/2015 à 17:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Re Mimile,

Ce flashplayer me cause beaucoup de problèmes, vu le nombre élevé de distributions - toutes basées sur Debian - ainsi que par les nombreux navigateurs basés sur Mozilla Firefox que j'utilise. Je suis, depuis des semaines, voire des mois, très ennuyé par ce shockwave player dont j'ai presque toutes les versions (via Freshplayer).

Je viens d'installer le navigateur Palemoon = dérivé de Firefox et là, mauvaise surprise, je dispose maintenant d'un vieux Shockwave Player 11.2.202.468 qui ne s'ouvre jamais. Quelqu'un a-t-il essayé d'installer Pipelight ?? http://doc.ubuntu-fr.org/pipelight

Ce problème de mise-à-jour du FlashPlayer commence tout doucement à me les brer menus ! Les posts à ce sujet foisonnent sur le net. Il suffit de saisir dans l'explorateur : "mise a jour adobe flash player mozilla" ou "flash player+mises-à-jour impossibles+mozilla+Ubuntu+2015" pour s'en rendre compte !



Modifié par Slyvester le 10/08/2015 10:14
beezapa
 Posté le 08/08/2015 à 18:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,



Las de ne plus le voir fonctionner correctement l'ami Firefox, j'avais basculé sur chromium, mais les habitudes

sont que j'ai désinstallé tout ce qui avais à voir avec Flash et Firefox, avec suppression de tous les fichiers qui

lui correspondait et liaison même si elle pointais dans le vide.

Puis réinstallation Basic via synaptic et j'ai appliqué la formule de Slyvester qui précédemment ne fonctionnais

pas, je suppose suite a certain résidus non désinstallé.

http://doc.ubuntu-fr.org/flashplayer

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install freshplayerplugin
sudo add-apt-repository --remove ppa:nilarimogard/webupd8



Et ça marche les gars, merci Slyvester de m'avoir poussé a persévérer et le soutien byzantin de reivillo..

Publicité
fiche
 Posté le 08/08/2015 à 19:46 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonsoir,

J'ai installé à plusieurs reprises Pipelight sur Debian. Cela fonctionne !

https://forum.pcastuces.com/debian___iceweasel___disposer_de_flash_player_17_avec_pipelight-f8s14566.htm

Slyvester
 Posté le 09/08/2015 à 09:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Merci Fiche pour ta réponse mais aussi pour ce rappel qui mérite une relecture : https://forum.pcastuces.com/debian___iceweasel___disposer_de_flash_player_17_avec_pipelight-f8s14566.htm

Mon navigateur "PaleMoon" - dérivé de Mozilla Firefox mais plus léger et plus véloce - installé hier m'a gratifié aujourd'hui après un "sudo apt-get update && sudo apt-get dist-upgrade" du Shockwave Player 13.1.2.3. en plus du 11.2.202.468.

A noter - et ceci n'est pas un conseil- que j'utilise Mozilla Firefox + Iceweasel + PaleMoon et que Firefox continue en se crasher à la fermeture du logiciel mais pas les deux autres (Iceweasel + PaleMoon) alors que Firefox dispose d'un ShockWave Player 18.0.0.209 (toujours via FreshPlayer) et pas les autres, d'où mon étonnement .



Modifié par Slyvester le 09/08/2015 09:59
Mimile
 Posté le 09/08/2015 à 12:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut Sylvester,

En ce qui me concerne, Firefox fonctionne parfaitement avec le plugin 18.0.0.209.

Toutefois le shockwave 11.2.202.241 restait présent dans la liste mais à l'analyse, toutes les vidéos vues sur Youtube et Dailymotion était gérées par le plugin 18.0.0.209.

J'ai donc supprimé le plugin 11.2.202.241 du dossier /usr/lib/mozilla/plugin et mystère, un autre shockwave encore plus ancien est apparu dans la liste.

Après diverses recherches, j'ai trouvé qu'il y avait également deux flashplugins dans un dossier /usr/lib/adobe-flashplugin/plugins : libflashplayer.so et libpepflashplayer.so ; pour voir, j'ai modifié les finales *.so en *os.

Depuis lors, dans la liste de mes plugins, je n'ai plus que le 18.0.0.209 qui, jusqu'à présent ne m'a causé aucun souci.

A+

Slyvester
 Posté le 14/08/2015 à 15:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

En cas d'utilisation de "pepperflashplugin'", il est important de le mettre à jour via le terminal :

sudo update-pepperflashplugin-nonfree --status
Flash Player version installed on this system  : 18.0.0.233
Flash Player version available on upstream site: 18.0.0.209

"pepperflalshplugin" n'est pas à jour et il faut saisir - afin d'obtenir la version 18.0.0.233 - la commande suvante :

sudo update-pepperflashplugin-nonfree --install

Slyvester
 Posté le 18/08/2015 à 15:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Pour mettre-à-jour "Flashplugin-nonfree" : sudo update-flashplugin-nonfree --install --verbose

Pour le configurer automatiquement : sudo update-alternatives --auto flash-mozilla.so
ou sudo update-alternatives --config flash-mozilla.so : configuration manuelle

Publicité
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Mise à jour de ma Debian Wheezy vers Jessie
Archlinux : mise à jour foireuse - merci chroot !
Carte wifi plus reconnue après mise à jour Debian Testing
Besoin de conseils pour mise à jour Debian Testing
Debian Wheezy HS après mise à jour
demande de resignements (vesion et mise a jour)
Prévenir la mise-à-jour d'un paquet sous Debian et dérivées
Mise-à-jour du EFI/BIOS sans installation Windows OEM ?!
Ajustement de ( Mise-à-jour Météo ) Xubuntu 12.10
problèmes mise à jour kubuntu 12.04
Plus de sujets relatifs à mise a jour adobe
 > Tous les forums > Forum Linux