> Tous les forums > Forum Internet et Réseaux
 mise en réseau portable sous w7Sujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
foremar
  Posté le 23/02/2015 @ 11:30 
Aller en bas de la page 
Petit astucien

Bonjour

Je désire mette en réseau mon portable sous w7 pro avec mon pc sous XP familial

J'ai la communication de xp vers w7, mais impossible d'avoir une connexion de w7 vers xp, malgré les différents conseils trouvés sur le forum.

Sous w7, je vois mon pc ainsi que les dossiers mis en partage, mais impossible d'y accéder, j'ai un message d'erreur qui ne correspond à rien (mémoire insuffisante....)

Alors, j'aimerais comprendre certains points sur le fonctionnement du partage.

1) clé de sécurité

La clé de sécurité entrée dans mon modem adsl (linksys) pour la liaison internet doit-elle être différente de celle du réseau?

- si non, pourquoi lors de la configuration du pc, m'a t'il fourni des paramètres différents à utiliser via une clé usb vers les autres équipements à mettre en réseau?

- si oui, pourquoi ces paramètres entrés dans mon portable ont-il planté la connexion internet du portable sans pour autant faire marcher le réseau?

Actuellement, j'ai remis la clé de sécurité du modem pour le portable

2) adresse ip

Le pc et le portable communiquent avec le modem avec la même adresse (192.xxx.x.1)

XP = 192.xxx.x.100

W7=192.xxx.x.101

Est-ce correct, le ping répond indifféremment sur les 2 machines avec les 3 adresses IP?

Qu'est-ce qui m’empêche d'accéder aux dossiers mis en partage sur XP?

Merci

Publicité
ferrand
 Posté le 23/02/2015 à 12:09 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Si tes 2 PC sont connectés à une box pour accéder à internet, ils sont en réseau ! Pour qu'ils puissent communiquer, il convient d'activer le Partage de fichiers et d'imprimantes sur les 2 PC.

Rien compris à ton histoire de paramètres-clés... mais ne concerne pas le réseau local (peut avoir un rapport avec la connexion à la box, mais si la connexion fonctionne, tout est normalement OK de ce point de vue).

Pour faire communiquer les 2 PC, il convient qu'ils aient des noms différents, qu'ils soient de préférence (cela facilite) dans le même groupe de travail, que le partage soit activé sur les 2 comme déjà dit (si partage avec mot de passe, l'utilisateur qui accède doit disposer d'un profil utilisateur sur le PC), sous W7 le groupe résidentiel doit absolument être désactivé.

Si des difficultés d'accès, il convient de vérifier les autorisations données lors du partage de dossiers et l'acceptation par le pare-feu.

Sois plus précis dans l'indication de tes manipulations, et dans les messages d'erreurs. Tu dis que la difficulté concerne l'accès au PC XP : si à partir du XP aucun problème pour accéder aux dossiers partagés de W7, le problème concerne alors seulement le XP. Vérifie les paramètres de partage indiqués, que l'on puisse faire le point.

foremar
 Posté le 23/02/2015 à 15:37 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Merci Astucien pour ta réponse

Sous XP Home(familial),
- le partage de fichiers est activé par défaut et est le seul mode disponible
(source microsoft)
- le pare-feu est activé et le partage de fichiers et imprimantes est coché
dans les exceptions

Sous w7,
- le partage des fichiers est activé,
- la protection par mot de passe est désactivée
- groupe résidentiel désactivé (donc, "utiliser les comptes utilisateurs..."
est activé )

Le message d'erreur quand je fais:
Reseau => ordinateur XP => Mon dossier partagé, est:


\\ordinateur XP\\Mon dossier partagé n'est pas accessible....
Mémoire insuffisante sur le serveur pour traiter cette commande

Bien qu'étant pratiquement sûr de cette configuration, je précise quand même
que j'ai tout vérifié avant de poster. S'il y a erreur de ma part, je ne vois
pas laquelle, et je suis prêt à donner la main à quelqu'un pour régler ce
problème.

Merci

ferrand
 Posté le 23/02/2015 à 17:25 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bon je reviens après manger ! Décalage horaire oblige.

Mais est-ce que l'utilisateur Win7 voulant accéder à XP dispose d'un profil utilisateur sous XP ?

Et est-ce que sous XP tu disposes de l'onglet Sécurité dans les Propriétés des dossiers ?

foremar
 Posté le 23/02/2015 à 19:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Enfin une piste, merci

Sous XP Home, il n'y a pas d'onglet sécurité dans les propriétés des dossiers.


En cherchant dans les docs Microsoft, j'ai trouvé une procédure pour l'obtenir.
C'est fait, et j'ai maintenant un onglet sécurité avec:
- Nom d'utilisateur: "Tout le monde" avec les autorisations "Read & execute, List folder contents et Read". Ce qui me semble correct.


Mais ça ne marche toujours pas

Par contre, je comprend mal:
Mais est-ce que l'utilisateur Win7 voulant accéder à XP dispose d'un profil utilisateur sous XP ?
J'ai plusieurs compte sur XP et un compte administrateur sur W7!

ferrand
 Posté le 23/02/2015 à 20:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

C'est fait, et j'ai maintenant un onglet sécurité

Parfait Tu avances !

Donc, tu autorises "tout le monde". D'abord, je conseillerais de tester en désactivant le pare-feu, il n'est pas rare que ce dernier rechigne...

NB: Pour être sûr que le pare-feu est désactivé, tu le désactives, tu redémarres, tu vérifies qu'il est bien désactivé...

NB2: Ne pas s'impatienter avec les accès réseau, pour que les accès puissent se faire, il faut que les ordinateurs se soient reconnus, ce qui prend un peu de temps (ça peut aller un peu au delà de 10 minutes), donc laisser suffisamment de temps avant d'être sûr que ça continue de bloquer.

Autre question : celle d'avoir un compte sur XP : si l'utilisateur qui accède a un profil sur l'ordinateur XP, il sera reconnu. Dans le cas contraire, il sera Anonyme. Et Windows XP peut fort bien considérer dans certains cas qu'un utilisateur anonyme, ce n'est pas "tout le monde" ! Dans ce cas, il faut le forcer à accepter les anonymes en tant que "tout le monde"... (à voir ensuite si ça bloque encore, quelques valeurs de registre à modifier).

foremar
 Posté le 23/02/2015 à 23:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

J'ai désactivé les 2 pare-feu.
Il me semble que l'apparition du message d'erreur soit plus rapide.
Tant que je ne ferme pas sa fenêtre, l’ascenseur d'avance mouline mais n'avance plus à environ 98%.
Mais j'ai largement dépassé les 20mn maintenant.

Pour info, j'ai déjà rajouté une valeur dans le registre (IrpStackSize il me semble) qui n'avait rien changé.


Je l'ai supprimé depuis

ferrand
 Posté le 24/02/2015 à 00:15 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Pour info, j'ai déjà rajouté une valeur dans le registre (IrpStackSize il me semble) qui n'avait rien changé.

Tu avais un message d'erreur de type "mémoire insuffisante" ? Quelle valeur avais-tu mis ? (le max. est 32 [en décimal]) Pour que la modif. prenne effet, il faut redémarrer.

Autre essai :

Dans la clé Lsa (voir ci-dessus), modifier les valeurs des 4 entrées encadrées : 2 sont à mettre à 1 et les 2 autres à 0. Redémarrer ensuite.

ferrand
 Posté le 24/02/2015 à 00:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

J'avais oublié : 2 pare-feux ! En principe, c'est un de trop ! La concurrence entre plusieurs pare-feux n'est généralement pas conseillée.

Publicité
foremar
 Posté le 24/02/2015 à 14:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour Ferrand

Tout d'abord, je suis très sensible au fait que malgré des horaires impossibles, tu continue encore à essayer de résoudre mon problème. Merci

Concernant les 2 pare-feu, je voulais parler de celui de XP et celui de W7. Désolé, j'aurais dû être plus précis.

Pour IrpStackSize, j'avais mis 6. Mais bon, je pense que c'est un message général sans relation particulière avec mon problème.

J'ai modifié les valeurs comme tu me l'a indiqué, mais c'est bète, je n'ai pas pensé à sauvegarder le registre auparavent.
Je crois que j'avais déjà 1 pour "forceguest" et pour "restrictanonymoussam"

L'apparition du message d'erreur est à nouveau assez long... mais y à t'il un rapport?

ferrand
 Posté le 25/02/2015 à 10:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour,

Hier j'étais en "interruption médicale", pas dans une disposition favorable pour la recherche de solutions techniques...

Pour IRPStackSize : ce paramètre définit la mémoire allouée aux opérations d'entrée/sortie, si je me souviens bien sa valeur par défaut est 15 (hexadécimal : F), en réglant à 6 tu renforces les obstacles... Quand une erreur du type "mémoire insuffisante" apparaît, ce réglage peut apporter la solution en augmentant la valeur du paramètre, sans dépasser 32 (hexadécimal : 20)...

Reprenons : l'accès en réseau local bloque pour accéder aux dossiers partagés sur l'ordi. XP à partir de l'ordi. W7, donc tu vas constater les blocages et avoir les messages d'erreur sur W7 mais les interventions en vue de débloquer sont à faire sur XP, c'est lui qui bloque à l'entrée.

La connexion des 2 ordis à une box qui leur permet d'accéder à internet, utilisant la fonction routeur de ladite box, conduit à ce que les 2 ordis appartiennent d'emblée à un même réseau local. Ils peuvent donc communiquer sous certaines conditions.

Les pré-requis : chaque ordi a un nom distinct (à vérifier), et les ordis appartiennent à un même groupe de travail (ce dernier point n'est pas absolument indispensable mais facilite la communication, l'ordi doit être redémarré lorsqu'on change le nom du groupe de travail), et le partage de fichiers doit être activé.

Plus spécifiquement pour l'ordi XP : tu partages les dossiers que tu souhaites partager (onglet Partage), tu définis les autorisations d'accès (onglet Sécurité), tu as opté pour un partage sans mot de passe, tu autorises l'utilisateur "Tout le monde" à accéder (tu ajoutes cet utilisateur s'il n'existe pas préalablement), tu lui donnes le contrôle total. Tu autorises les accès réseau local dans le pare-feu (en théorie cela suit automatiquement, mais le pare-feu est souvent récalcitrant à s'adapter, c'est pourquoi il est utile de le désactiver pour le réactiver une fois l'accès dûment établi : le pare-feu doit laisser passer les communications entre ordinateurs de ton réseau (192.168.?.0) et déverrouiller les ports 137 à 139...

Reste le flitrage effectué par Windows : sur les entrées de registre que je t'ai signalé, généralement tu as au départ une des deux entrées restrictanonymous à 1 et les autres à 0. Il convient de mettre les 2 entrées restrictanonymous à 0 (pour réduire les exigences de Windows à l'entrée) et les 2 autres à 1 : forceguest force le partage de fichier simple et autorise le compte invité, everybodyincludesanonymous signifie que les utilisateurs anonymes seront considérés comme appartenant à "Tout le monde" car un utilisateur non expressément identifié est considéré comme anonyme.

Cela n'est pas le seul point qui peut bloquer, mais à ce stade il faut voir les messages d'erreur exacts pour avoir un indice plus précis et tester différents points....

foremar
 Posté le 25/02/2015 à 16:53 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour Ferrand

Bonne nouvelle... ça marche!!

Je t'avais préparé des saisies d'écran pour qu'il n'y ai pas de doute sur ma configuration.

Et puis je suis revenu sur IrpStackSize
Cette valeur DWORD n'existait pas à l'origine sur XP Home. Je l'avais crée et mise à 6 un peu au hasard, puis comme ça ne changeait rien, je l'avais supprimée.
Je l'ai donc recréé avec la valeur hexa 20.... je n'en suis plus à un essai près!
Et pouf!!! ça fonctionne.

Je ne sais pas si c'est cette seule valeur qui a débloquée le système, ou si c'est la combinaison de tout ce que tu m'as indiqué, mais pour moi, c'est bon, sauf si tu veux que je fasse des essais complémentaires histoire de blinder ces manipulations.


Quand à moi, je sauvegarde ma partition système dans cette configuration immédiatement.

Encore merci

Foremar

ferrand
 Posté le 25/02/2015 à 17:44 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Si ça marche, touche plus !

Toujours difficile d'avoir une certitude car conjonction d'un bon nombre d'éléments...

Bonne continuation.

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Mise réseau Livebox 1 pc bureau 1 portable
mise en réseau de PC sous live box et Norton antiv
Mise en réseau wifi de 2 PC sous XP ?
réseau sous 2 versions de windows
Mise à jour carte réseau
Plus de connexion wifi sur pc portable sous w7
calcul sous réseau
Mettre un portable XP en reseau
mise en réseau d'un graveur DVD
problème pour mise en reseau
Plus de sujets relatifs à mise en réseau portable sous w7
 > Tous les forums > Forum Internet et Réseaux