> Tous les forums > Forum Linux
 Monter HDD réseau sous UbuntuSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
oliblues
  Posté le 05/02/2010 @ 19:13 
Aller en bas de la page 
Petit astucien

Bonjour à tous

J'ai un souçi pour monter un disque dur réseau sous Ubuntu 9.10

Il s'agit d'un disque dur USB Western Digital 320Go (FAT32), relié à un adaptateur NAS (http://www.addonics.com/products/nas/NAS2XU2.asp), lui même relié à un router Netgear par RJ45. La configuration de l'adaptateur à l'air juste (IP, dossier partagé (PUBLIC), user, password etc...) C'est l'adaptateur qui a formaté le HDD en FAT32. Le router donne une adresse fixe (155.83.214.9). Jusque là, tout baigne.

Sous Ubuntu, j'arrive à faire les choses suivantes: connexion avec le HDD fonctionne (avec "se connecter à un serveur"), je peut lire et écrire (j'ai créé des Dossiers "documents", "images" etc...) mais seulement avec l'IP, pas avec le "nom" (HDD-NAS)

Avec les infos glanés sur la toile, j'ai éssayé de monter mon disque dur réseau automatiquement au démarrage. J'ai donc ajouté à "/etc/fstab" une ligne, après avoir créé le dossier pour mon point de montage (/home/adminoli/Public) et le fichier contenant user et password (/home/adminoli/.smbdata)

Voici mon fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda1 during installation
UUID=e5c73faf-598b-4bd5-acfc-24383c3d6446 / ext4 errors=remount-ro 0 1
# /home was on /dev/sdb5 during installation
UUID=a488e14a-2ea3-4102-96f2-89c5b610fee7 /home ext4 defaults 0 2
# swap was on /dev/sda5 during installation
UUID=d4493ee6-a301-4c75-9ba6-ab32f40a8120 none swap sw 0 0
/dev/scd1 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
# Partitions FAT32
# Disque dur réseau HDD-NAT/Public
//155.83.214.9/PUBLIC /media/Public smbfs user,rw,uid=1000,gid=100,file_mode=0640,dir_mode=0750,iocharset=utf8,credentials=/home/adminoli/.smbdata 0 0

La partition se monte au démarrage, mais quand je l'ouvre: rien de rien dans la fenètre !! (les dossiers présents sur le HDD réseau n'apparaissent pas)

Problème de compatibilité, omission et/ou erreure dans ma ligne ? (même chose avec cifs ou smbfs)

Si quelqu'un à une p'tite idée SVP ? D'avance merci

salut

Publicité
Mimile
 Posté le 15/02/2010 à 09:21 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut

Un cas à peu près similaire. Au démarrage de mon PC (sous Debian), je monte automatiquement une partition située sur le disque dur du PC de mon fils (sous Windows NTFS) grâce à cette ligne de montage incluse dans mon /etc/fstab :

//192.168.2.3/share /media/Alex_share cifs rw,mand,nosuid,nodev,user=mon_nom_d'utilisateur

Ca marche sans problème : j'ai un accès complet à sa partition, tant en écriture qu'en lecture.

Grâce à cette petite manip, la partition de mon fils apparaît dans l'explorateur (konqueror ou - encore mieux : krusader) au même titre que les autres partitions de mon PC.

Tu pourrais peut-être t'en inspirer pour ton propre problème.

Amicalement,



Modifié par Mimile le 15/02/2010 09:25
oliblues
 Posté le 11/03/2010 à 22:59 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Salut

merci pour ta réponse, mais j'ai entretemps résolu mon problème mais because obligations proffessionnelles, j'ai pas pu répondre avant.

la solution consiste à ajouter dans etc/fstab l'option "noserverinfo" dans la ligne de commande, ce qui donne:

HDD-NAS/PUBLIC /media/Public cifs noserverinfo,user,rw,uid=1000,gid=100,file_mode=0640,dir_mode=0750,iocharset=utf8,credentials=/home/olivier/.smbdata 0 0

... et ça marche!!

A+

Mimile
 Posté le 11/03/2010 à 23:12 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Content pour toi

La partition cible est en FAT ou en NTFS ?

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Problème configuration réseau sous Ubuntu
Installation Réseau-Internet via wifi sous UBUNTU
reseau sous Ubuntu
monter un reseau sous linux
Logiciels de nettoyage sous linux ubuntu 14.04 ?
Cle usb sous Ubuntu
Résolution trop basse sous Ubuntu
Applications au démarrage sous UBUNTU 13.04
Impossible lire vidéo youtube sous ubuntu
jeux sous linux ubuntu
Plus de sujets relatifs à Monter HDD réseau sous Ubuntu
 > Tous les forums > Forum Linux