> Tous les forums > Forum Linux
 Multiple boot et GrubSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Mimile
  Posté le 31/10/2011 @ 10:30 
Aller en bas de la page 
Astucien

Bonjour,

Ce week-end, j'ai installé LMDE sur deux partitions logiques récupérées par prelèvement de 10 Go sur la partition de stockage voisine.

Auparavant, lors de l'installation de Squeeze, j'avais installé le boot loader à la racine de sda (1er de mes deux disques internes) et pointait vers la partition racine de Squeeze (/dev/sda5) ; mon écran d'accueil Grub me donnait le choix entre :

  1. Debian Squeeze (/dev/sda5 et /dev/sda6 dans une partition étendue /dev/sda3)
  2. Debian Squeeze mode recovery
  3. Windows 7
  4. Debien Lenny (/dev/sdb5 et /dev/sdb6 dans une partition étendue /dev/sdb3)
  5. Debian Lenny mode recovery

Pour accéder à XP, il me faut choisir l'option 3 (Win7) qui, à son tour affiche un petit menu d'options :

  1. une "ancienne version de Windows" (en fait XP)
  2. Windows 7

J'ai récupéré de l'espace par prelèvement de 10 Go sur la partition de stockage et je l'ai intégrée à la partition étendue /dev/sda3 par augmentation par la gauche ; l'espace ainsi intégré m'a permis de créé deux partitions logiques destinées à recevoir LMDE : /dev/sda7 et /dev/sda8.

Voilà à quoi mes disques ressemblent maintenant :

J'ai donc installé LMDE dans ces partitions et pour le choix de l'emplacement de Grub, j'ai eu un doute : le mettre à la racine de /sda comme je l'avais fait pour Squeeze ou à la racine de LMDE ou ne pas l'installer du tout.

Dans un premier temps, j'ai choisi de ne pas l'installer du tout, considérant qu'en exécutant un update-grub depuis Squeeze, il intégrerait LMDE dans son menu d'accueil.

J'ai ensuite installé les innombrables mises à jour en rencontrant un problème lors de l'installation d'un paquetage (gstreamer-really_bad plugin ou quelque chose comme ça) qui interrompait la séquence d'installation que j'ai dû recommencer plusieurs fois jusqu'à ce que je le décoche de la liste des paquetages à installer.

Finalement, je suis arrivé au bout de mes peines constatant en cours de route l'installation du nouveau noyau 3.0.0.1.

Donc, j'ai fait un update-grub depuis Squeeze et j'ai eu l'agréable surprise de voir aparaître LMDE parmi les choix possibles.

J'ai booté dessus et il a démarré sans problème mais sans me donner le choix du noyau à utiliser : d'office, c'était l'ancien noyau 2.6.39 qui était en fonction.

Or, sous virtualbox, le Grub de LMDE me donne effectivement le choix entre les deux noyaux et leurs versions "recovery".

Je décide donc de réinstaller en choisissant d'installer le booloader de Grub à la racine de LMDE ce qui s'est avéré être une mauvaise pioche car juste après avoir confirmer ce choix, un message est apparu signalant que c'était vraiment une mauvaise idée mais sans me donner la possibilité d'un retour en arrière.

A la fin de cette nouvelle installation, update-grub depuis Squeeze mais quand j'ai voulu démarrer LMDE, la cata : défilement ininterrompu d'indications en boucle et obligation d'arrêter le PC à la sauvage.

Je n'ai plus d'autre choix que de réinstaller à nouveau LMDE en installant Grub à la racine de /sda, en espérant que je ne perdrai pas les options de boot sur les autres OS.

Qu'en pensez-vous ?



Modifié par Mimile le 31/10/2011 10:37
Publicité
Esclapion
 Posté le 31/10/2011 à 11:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Bonjour Mimile,

J'ai hésité à faire un sujet là-dessus, mais il y a un bug (et un seul que j'aie noté) lors du passage en 3.0, c'est le module :

gstreamer0.10-plugins-really-bad

Il suffit de le désinstaller avant la mise à jour vers 3.0 pour que celle-ci se passe avec 0 pb, si ce n'est le temps de téléchargement (env. 2h chez moi ).

Sinon, vachement compliquée, ton installation. {#} Je relirai encore ça quand je serai réveillé , voir si je peux apporter une idée.

Pour l'instant, je ne vois pas où sont sda7 et 8, par exemple.

Tous tes Linux étaient en Grub2 ou non ?

(edit)

Ah si : c'est la 4 et 5 de ta figure que Linux appelle 7 et 8, je pense. Dommage qu'il n'y ait pas renumérotation.



Modifié par Esclapion le 31/10/2011 11:35
Esclapion
 Posté le 31/10/2011 à 11:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Dans un premier temps, j'ai choisi de ne pas l'installer du tout, considérant qu'en exécutant un update-grub depuis Squeeze, il intégrerait LMDE dans son menu d'accueil.

Je pense que le pb est là : il n'a pas installé le Grub, mais il n'a pas non plus mis à jour (?) les fichiers de configuration internes relatifs au Grub de LMDE.

En démarrant sur LMDE via Rescatux ou l'autre (son nom m'échappe), il aurait peut-être été possible de le recupérer, en lançant l'update-grub depuis le LMDE. En le lançant depuis Squeeze, on fait pointer le grub général vers ces fichiers de configuration grub LMDE pas à jour.



Modifié par Esclapion le 31/10/2011 11:48
Mimile
 Posté le 31/10/2011 à 13:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Salut Esclapion et merci pour l'intérêt que tu portes à ce sujet.

La numérotation des partitions semble évidemment un peu illogique ; cela s'explique par le fait qu'à l'origine, dans la partition étendue du 1er disque (/dev/sda3), il n'y avait que Squeeze (root et home, respectivement sda5 et sda6).

Quand j'ai agrandi sda3 vers la gauche après diminution de la partition de stockage contiguë, les deux nouvelles partitions destinées à LMDE que j'ai créées ont été numérotées sda7 et sda8, ce qui au final donne une séquence de partitions logiques illogique (sda7, sda8, sda5, sda6) mais bon, on s'en fiche et finalement je suis content que ce soit resté comme ça : ça m'évite de devoir modifier tous les fstab des autres OS.

En ce qui concerne Grub :

Lors de ma première installation, j'ai décidé de ne pas l'installer ; En faisant update-grub sous Squeeze, LMDE est apparu dans la liste et a été accessible normalement mais sans possibilité de choisir le noyau à utiliser.

Lors de ma seconde installation, j'ai décidé d'installer le bootloader sur la partition racine de LMDE, en me disant qu'en choisissant de lancer LMDE depuis le menu Grub de Squeeze, j'allais parvenir au menu Grub de LMDE me donnant le choix entre les deux noyaux, ce qui s'est révélé complètement foireux.

Je crois que la seule solution consiste à installer Grub à la racine de sda en espérant qu'un update-grub effectué depuis LMDE rétablira le choix multiple actuel.

Enfin, pendant les deux installations, le programme de mise à jour a chaque fois planté au moment de l'installation de gstreamer0.10-plugin-really-bad.

Finalement, je n'ai pu finir l'installation des mises à jour qu'après avoir décoché gstreamer-etc.. dans la liste.

A noter qu'aucun de ces problèmes ne s'est produit sous VirtualBox ...

Donc, dès demain, je recommence l'installation et avant de lancer les mises à jour, je désinstalle gstreamer0.10-etc...

Est-ce un bidule qu'on peut supprimer avec une commande du genre : apt-get remove --purge gstreamer-etc... ?

Merci pour ton conseil

Esclapion
 Posté le 31/10/2011 à 13:50 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

A noter qu'aucun de ces problèmes ne s'est produit sous VirtualBox ...

Chez moi, si, il y a eu des warnings.

Est-ce un bidule qu'on peut supprimer avec une commande du genre : apt-get remove --purge gstreamer-etc... ?

Oui, tout à fait. Mais je ne vais pas jusque-là : je l'ai viré une fois par apt-get remove seul, sans plus. Depuis, je le supprime simplement par le gestionnaire de paquets, même pas complètement.

Mais normalement, même sans le supprimer, ça passe, il suffit d'insister un peu.

Je me suis amusé aussi à utiliser :

aptitude full-upgrade sans le virer, et ça passe aussi.

Mimile
 Posté le 31/10/2011 à 23:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Hello

J'ai ré-installé (pour la 3ème fois) LMDE en indiquant d'installer Grub sur la racine de /dev/sda

Tout s'est bien passé (en mon absence : parti faire des courses) et à mon retour, quand j'ai re-démarré le PC, mon nouveau menu Grub faisait bien état de tous les OS présents (LMDE et LMDE recovery - W7 permettant aussi d'accéder à XP - Squeeze et squeeze recovery - et enfin Lenny qui apparaît 6 fois ?!!).

Je verrai ça demain pour rendre à ce nouveau menu un aspect un peu plus agréable (fond noir et texte gris, ça déprime un peu mais bon, le principal, c'est que ça fonctionne) et aussi supprimer cette redondance de Lenny que je ne comprends pas.

Je n'ai pas encore installé les centaines de mises à jour qui sont en attente mais j'ai déjà supprimé totalement cette saloperie de gstreamer0.machin-chose-bad (bad ! le bien nommé ).

Je reviens demain dire ce qu'il en aura été de mes manip's.

Amicalement

Esclapion
 Posté le 31/10/2011 à 23:45 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Un update-grub devrait te virer ces répétitions, non ?

Sinon, par défaut le fond est chez moi gris métallique. Perso, je le change pour des couleurs un peu plus chaudes.

Mimile
 Posté le 05/11/2011 à 16:28 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Désolé, j'ai changé de sujet et j'ai omis de te répondre.

En fait, il s'avère que c'est la version 1.99 de Grub qui pose problème par rapport - sans doute - au fait que Lenny utilise l'ancienne version de Grub (legacy).

J'ai réinstallé la version 1.98 (en utilisant le disque d'installation de Squeeze - option rescue) et tout est rentré dans l'ordre.

Amicalement,

Esclapion
 Posté le 05/11/2011 à 16:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

Oui, je l'ai lu sur l'autre sujet.

Ce qui est casse-pieds, c'est que Grub soit comme ça sans cesse en développemement.

Apparemment, tu ne pourras pas passer à Wheezy non plus ?

La dernière version de Legacy doit dater de 2005, celle de Grub2 de Mai de cette année.

Publicité
Mimile
 Posté le 05/11/2011 à 22:51 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

En fait, j'ai installé Wheezy (sid) sur l'espace où se trouvait LMDE et grâce au CD d'install. de Squeeze (option rescue), j'ai pu récupérer le menu de démarrage Grub 1.98.

Finalement, j'aurais tout aussi bien pu laisser LMDE et faire la même chose.

Je rencontre d'ailleurs le même problème avec mon imprimante HP LaserJet 1020 qui est bien reconnue mais qui n'imprime pas alors que tout se passe comme si elle le faisait (le fichier dans la file d'attente disparaît au bout de quelques secondes, comme s'il avait été correctement imprimé).

Finalement, Wheezy ne m'apporte rien à ce stade (j'ai eu deux ou trois plantages) et je crois que je vais tenter une ré-installation de LMDE dont le menu Gnome est plus "sympathique".

Ou alors aller voir ailleurs et installer un bidule dans le genre Simply Mepis, Fedora ou autre Suse (Knoppix, j'ai donné : j'avais fait un beau petit tuto ( en 2004 : voir ici) mais depuis qu'ils ont épuré leur live-CD en passant à la version 6 (Adriane), c'est devenu sans intérêt).

Je me tâte ...

A bientôt pour dire ce que j'aurai décidé

Amicalement,



Modifié par Mimile le 05/11/2011 22:51
Esclapion
 Posté le 05/11/2011 à 23:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

J'ai essayé Fedora et suse très récemment, mais elles ne correspondaient pas à ce que je cherchais.

Pas de problèmes pour les installer, mais bon, à part ça... L'interface de Fedora est amusante, mais un peu lassante, ça fait un peu jouet.

Autant prendre une Ubuntu ou une Debian, il y a une communauté plus étendue. Quant à LMDE, elle est plus réactive qu'Ubuntu. Et son système de dépôts intermédiaires devrait lui garantir une grande stabilité, tout en étant en pointe pour les versions des paquets.

Si j'étais tenté par qqch d'autre, ce serait une Debian "pure", mais il y a tout à faire pour le bureau (alors que la disposition de LMDE me convient, même si j'ai encore du mal à m'y retrouver), et les paquets sont un peu anciens.

Ce qui m'avait aussi agacé avec Debian, ça avait été les pbs pour installer depuis un PC en Wifi.

Tout dépend évidemment des critères de chacun.



Modifié par Esclapion le 05/11/2011 23:05
Mimile
 Posté le 06/11/2011 à 10:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Des Debian "pures" (comme tu dis), j'en ai déjà 3 (Lenny, Squeeze et Wheezy - sans parler de Etch qui se trouve sur mon ordinosaure à côté de W98 SE).

Ubuntu ? rien à faire, j'y suis allergique sans vraiment pouvoir en donner la raison, peut-être parce qu'elle évolue (pas toujours bien) tous les 6 mois.

J'avais eu un coup de coeur pour Linux Mint quand je l'ai découverte (version 7 Gloria) qui m'avait tout installé en deux temps trois mouvements (y compris mon imprimante HP LaserJet 1020) et dont le menu Gnome est particulièrement agréable mais comme Linux Mint suivait le rythme d'Ubuntu, finalement je l'ai remplacée par Squeeze tout en conservant Lenny sur lequel j'ai beaucoup travaillé)

Quand LMDE est apparue, je me suis dit : chouette : une Linux Mint qui sera constamment à jour sans devoir faire d'upgrade.

Malheureusement, son installation sur mon PC n'a pas été des plus simples (peut-être parce que mon PC est trop vieux) à cause d'un paquetage gstreamer0-je-ne-sais-plus-quoi-bad qui plantait à chaque fois l'installation des paquetages suivants.

De plus, pas moyen d'utiliser ma LaserJet - bien que reconnue et annoncée comme prête à l'emploi.

Finalement, j'ai écrasé LMDE et installé Wheezy qui, hormis son noyau 3.0.0.1 ne m'apporte pas grand chose de plus que Squeeze (et ne fait pas non plus tourner ma LaserJet).

Je pense toutefois qu'il faut attendre un peu : chez HP, il vont probablement mettre au point le bon pilote car pour l'instant, la version Debian la plus évoluée pour laquelle ils proposent une solution est la 6.0.3 (Squeeze).

Je suis donc dans l'expectative ...

beezapa
 Posté le 06/11/2011 à 15:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Tester donc Mandriva j' y retourne même si KDE n'est pas au top.

Logicien
 Posté le 06/11/2011 à 16:13 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Allo,

Mimile, je suis curieux de savoir ce que te retourne la commande

cat /etc/debian_version

sur tes installations Etch, Lenny, Squeeze et Wheezy ou tout autre distribution basée sur Debian telle Mint et Mint LMDE. Si comme tu l'as dis je crois, tu utilises les noms de dépôts stable et testing dans tes sources.list, tu es vraiment en rolling-releases. Ta Lenny peut aussi bien être à jour côté version des paquets que ta Wheezy. Si tu fais tes mise-à-jours sur chacune évidemment. Peu importe, la course à relai dans laquelle tu es, offre un intérêt au fil d'arrivé autant que l'imbroglio Debianesque associé à l'évolution de toutes ces distributions.

{#}



Modifié par Logicien le 06/11/2011 16:15
Mimile
 Posté le 06/11/2011 à 16:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour Paul

Bien content de te rencontrer à nouveau.

En fait, je dois avouer que je suis comme une girouette : Wheezy a fini par me decevoir à ne pas vouloir faire tourner une de mes imprimantes et son menu Gnome n'était pas à mon goût.

Bref, cet après-midi, j'ai écrasé Wheezy et j'ai ré-installé LMDE !!! et mes disques sont donc tels que présentés au début de mon sujet :

Bref, pour répondre à ta question quand j'étais sous Wheezy, cat /etc/debian_version me renvoyait : wheezy

Maintenant que je suis à nouveau sous LMDE, la réponse est : wheezy/sid

Voici le sources.list qui a été installé d'office et auquel je n'ai pas apporté de modification :

deb http://packages.linuxmint.com/ debian main upstream import
deb http://debian.linuxmint.com/latest testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free

Toutes ces distributions m'amusent et je dois avouer que ma préférence va maintenant à Squeeze qui est d'une stabilité à toute épreuve.

A te lire.

Amicalement

webby
 Posté le 11/11/2011 à 04:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

c'est vrai que la Sqeeze est d'une stabilité à toute épreuve ..

Esclapion
 Posté le 11/11/2011 à 12:54 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Grand Maître astucien

webby a écrit :

c'est vrai que la Sqeeze est d'une stabilité à toute épreuve ..

Oui, mais elle a des paquets anciens. Je préfère ma LMDE, avec laquelle j'attends le premier problème, et qui a des paquets niveau Wheezy déjà testés.

Notamment un noyau 3.0.



Modifié par Esclapion le 11/11/2011 13:01
Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
13,99 €Clé USB Sandisk Ultra 64 Go à double connectique USB 3.1 Type A et C à 13,99 €
Valable jusqu'au 18 Mai

Amazon fait une promotion sur la clé USB Sandisk Ultra 64 Go à double connectique USB 3.1 Type A et C qui passe à 13,99 € alors qu'on la trouve ailleurs à plus de 25 €. Cette clé USB  dispose d'un connecteur réversible USB Type C et d'un connecteur classique de type A. Grâce à elle, transférez en toute simplicité et rapidement (jusqu'à 150 Mo/s) vos fichiers entre vos smartphones, tablettes et ordinateurs. 


> Voir l'offre
39,92 €Haut-parleurs Bluetooth Logitech Z207 à 39,92 €
Valable jusqu'au 18 Mai

Amazon fait une promotion sur les haut-parleurs bluetooth Logitech Z207 qui passent à 39,92 € livrés gratuitement alors qu'on les trouve ailleurs à partir de 50 €. Vous pouvez connecter ces haut-parleurs 10W à votre ordinateur, votre appareil mobile via une connexion sans fil bluetooth. Une entrée 3,5 mm est présente ainsi qu'un bouton de volume. 


> Voir l'offre
42,51 €Support ERGOsolid articulé pour 2 écrans PC de 17 à 27 pouces avec hub USB 3.0 intégré à 42,51 €
Valable jusqu'au 18 Mai

Amazon fait une promotion sur le support ERGOsolid articulé pour 2 écrans PC de 17 à 27 pouces à 42,51 €. On le trouve ailleurs à partir de 60 €. Compatible VESA 75 x 75 mm et 100 x 100 mm. 9 kg par écran max. Ce bras de moniteur unique est extrêmement polyvalent et l'installation est simple. Le support de montage à pince robuste ou à visser sur votre bureau. Bras articulés faciles à régler. Ils permettent la rotation des écrans à 360°, pivot à 180°, inclinaison de + 90° à – 45°. 2 ports USB 3.0 sont intégrés à la base.


> Voir l'offre

Sujets relatifs
Multiple boot WinXP - Win7 - Debian Lenny
Problème Boot Windows XP via le GRUB...
Changer l'ordre du DualBoot (/boot/grub/menu.lst)
Grub et dual boot vista impossible
dula boot xp et vista avec grub possible?
Problème de multiple-boot avec Fedora 11
script boot grub fstab ?
[Grub] Désinstallation Aurox. Boot possible ?
Réparer Win XP en dual boot avec grub
grub> au lieu du dual-boot [Résolu]
Plus de sujets relatifs à Multiple boot et Grub
 > Tous les forums > Forum Linux