> Tous les forums > Forum Bureautique
 ne pas prendre en charge les faux zérosSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
mondeheureux
  Posté le 11/06/2010 @ 14:42 
Aller en bas de la page 
Petit astucien

salut

dans une feuille de calcul il y a de vrais et de faux zéros.les vrais zéros sont une valeur (une note) que j'ai saisie et doivent être calculés, alors que les faux zéros proviennent du lien de la feuille 1 et de la feuille 2 et qui ne sont que ces lignes vides dans la Feuil2.

je voudrais que seuls les vrais zéros qui doivent être pris en considération pour calculer la moyenne.

merci

Publicité
DjiDji59430
 Posté le 11/06/2010 à 15:19 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Au lieu d'ecrire = A2 qui devient 0 si il n'y a rien dans A2, tu ecris

=SI(ESTNUM(A2);A2;"")

mondeheureux
 Posté le 11/06/2010 à 20:27 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

salut DjiDji59430

je voudrais une petite explication.si la plage de cellule qui va être calculée est (C5:c52),comment vais-je écrire la formule?

le résultat sera dans la cellule D5.

merci

galopin01
 Posté le 11/06/2010 à 23:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

mondeheureux,

djidji te suggère de remplacer "ta formule qui génère des faux zéros" par une formule qui ne génère pas de faux zéros.

comme dans ce modèle

A+

DjiDji59430
 Posté le 11/06/2010 à 23:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

ta plage C5:c52 est le resultat d'un collage d'un autre onglet ?

en c5, tu mets =SI(ESTNUM(Feuil2!Xn);Feuil2!Xn;"")

Xn cellule d'origine du collage, et tu tires jusqu'en C52, ou, si les cellules ne sont pas contigües, les bonnes references.

en d5, çà ne changera pas = MOYENNE(C5:C52)

Autrement dit si la cellule d'origine est numerique (ESTNUM(Xn)), tu la copies, sinon, il n'y a rien ("")


Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Sujets relatifs
Explorateur Windows charge lentement
format personnalisé avec des zéros devant un nbre
prendre certains passage dans un texte PDF
Adobe Reader lomg à chargé sur W7?
Prendre en compte les données d'une nouvelle feuil
Prendre qu'une page avec PDF Viewer
Suppression des zéros
Tableau dynamique qui est faux
comment avoir des tirets à la place des zeros !
supprimer les zéros devant un nombre
Plus de sujets relatifs à ne pas prendre en charge les faux zéros
 > Tous les forums > Forum Bureautique