> Tous les forums > Forum Bureautique
 Ne pas prendre en compte dans une formule la cellule masquée
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
delta70
  Posté le 23/08/2019 @ 12:53 
Aller en bas de la page 
Petit astucien

Bonjour, à toutes et à tous
J’utilise une simple formule pour déterminer les numéros des pages
La cellule de départ est J51 elle n’est pas verrouillée c’est là que je saisi le n° de la première page les autres (en j202, j153, J204, J306) seront calculés par simple formule
Par exemple : en J306 c’est la formule « =J204+1 » et je veux que la formule en J306 change en fonction du masquage ou affichage de la cellule J204.
Si la cellule J204 n’est pas masquée la formule reste « =J204+1 » mais si J204 est masquée la formule change est sera « =J153+1 »
Merci de votre collaboration.



Modifié par delta70 le 23/08/2019 13:01
Publicité
Debrief
 Posté le 23/08/2019 à 19:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Ton affaire est un peu étrange.

La seule façon que je connaisse de tester si une cellule est masquée est d'utiliser la fonction SOUS.TOTAL(103; <Celllule>) à condition d'être sûr que <Cellule> contient une valeur ou une formule.

Si c'est le cas (ici si J204 contient une valeur ou une formule), tu peux utiliser une formule du type en J306 -> =SI(SOUS.TOTAL(103;J204)>0;J204+1;J153+1)
Ou par sécurité -> =SI(ESTVIDE(J204);"Impossible à déterminer";SI(SOUS.TOTAL(103;J204)>0;J204+1;J153+1))

Mais alors que se passe-t-il si J153 est elle aussi masquée ? Tu ne vas pas remonter toutes les cellules pour les tester !? Il faudra trouver une autre approche.
Si c'est le cas, dis-le et on peut trouver une solution plus simple et plus sûre (*).

Cordialement,
D.

(*) Edit: comme par exemple dédier une colonne X masquée ou hors zone d'impression, où, aux lignes des sauts de page, on place une info quelconque (ex.: "Saut de page") et qui permet de déterminer le n° de la page avec une formule du genre:
=SI(X52 <> "";J$51 + SOUS.TOTAL(103; X$52:X52);"") à étendre de J52 à J<dernière ligne>

Ou pour simplifier / clarifier, placer le n° de la 1ère page hors colonne J (ex. en Y1) et:
=SI(X1 <> "";$Y$1 + SOUS.TOTAL(103; X$1:X1);"") à étendre de J1 à J<dernière ligne>



Modifié par Debrief le 24/08/2019 12:59
delta70
 Posté le 24/08/2019 à 08:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour, Debrief

Merci bien

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
64,13 €Disque dur externe portable Toshiba Canvio Basics 2 To USB 3.0 à 64,13 €
Valable jusqu'au 03 Mars

Amazon propose actuellement le disque dur externe portable Toshiba Canvio Basics 2 To USB 3.0 à 64,13 € seulement ! Avec ses 2 To et sa connectique USB 3.0 compatible USB 2.0, vous aurez de quoi stocker rapidement et emporter avec vous vos photos, vos films, etc.  La livraison est gratuite.


> Voir l'offre
79,99 €Kit 5.1 Logitech Z607 bluetooth à 79,99 €
Valable jusqu'au 03 Mars

Amazon fait une promotion sur le kit d'enceintes 5.1 Logitech Z607 qui passe à 79,99 € livré gratuitement alors qu'on le trouve ailleurs autour de 125 €. Ce kit dispose d'un caisson de basses, d'une voie centrale et de 4 satellites offrant au total  une puissance de crête de 160 Watts et 80 Watts en puissance RMS. De quoi profiter pleinement de vos films et de vos jeux dans une pièce moyenne. D'autant que des câbles extra-longs (6,2 m) sont fournis pour les satellites arrières. Grâce à ses entrées 3.5mm et RCA, vous pourrez relier le kit à un PC, à une console de jeux, un lecteur DVD/Blu-Ray tandis que sa connexion bluetooth vous permettra de l'utiliser pour vos appareils sans fil. Vous pouvez même lui brancher directement une carte mémoire ou une clé USB et écouter la radio FM. Une télécommande (sans fil) vous permettra de contrôler tout cela. Une excellente affaire !


> Voir l'offre
18,90 €Microsoft Office Professionnel 2016 Plus à 18,90 €
Valable jusqu'au 01 Mars

Le vendeur sérieux Digital FR sur Amazon propose la clé d'activation légale pour Microsoft Office Professionnel 2016 Plus en français à 18,90 €. Cette clé livrée par email vous permettra d'activer Microsoft Office Professionnel 2016 Plus légalement et vous permettra ainsi d'utiliser autant de temps que vous voulez (il s'agit de la version complète et pas d'un abonnement) Word,Excel, PowerPoint, OneNote, Outlook, Publisher et Access 2016 sur un PC. La clé sera à activer sur Office.com où vous pourrez ensuite télécharger toute la suite bureautique. Si la version 2019 fonctionne uniquement avec Windows 10, cette version 2016 fonctionne avec Windows 7, Windows 8 et Windows 10 !


> Voir l'offre

Sujets relatifs
Changer la formule quand la cellule est masquée
Changer de couleur une cellule avec une maccro
Changement couleur cellule excel / mise en forme conditionnelle / formule
Référence de cellule variable dans une formule Excel
Repérer une cellule "vide" qui contient une formule
Open Office - formule à mettre dans une cellule
Changer un mot dans une cellule
verrouiller ou déverrouiller une cellule avec la formule SI
[LibreOffice] Changer hauteur cellule tableau
Zoom à changer quand on ouvre word 2007
Plus de sujets relatifs à Ne pas prendre en compte dans une formule la cellule masquée
 > Tous les forums > Forum Bureautique