> Tous les forums > Forum Bureautique
 Ne pas prendre en compte dans une formule la cellule masquée
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
delta70
  Posté le 23/08/2019 @ 12:53 
Aller en bas de la page 
Petit astucien

Bonjour, à toutes et à tous
J’utilise une simple formule pour déterminer les numéros des pages
La cellule de départ est J51 elle n’est pas verrouillée c’est là que je saisi le n° de la première page les autres (en j202, j153, J204, J306) seront calculés par simple formule
Par exemple : en J306 c’est la formule « =J204+1 » et je veux que la formule en J306 change en fonction du masquage ou affichage de la cellule J204.
Si la cellule J204 n’est pas masquée la formule reste « =J204+1 » mais si J204 est masquée la formule change est sera « =J153+1 »
Merci de votre collaboration.



Modifié par delta70 le 23/08/2019 13:01
Publicité
Debrief
 Posté le 23/08/2019 à 19:36 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bonjour,

Ton affaire est un peu étrange.

La seule façon que je connaisse de tester si une cellule est masquée est d'utiliser la fonction SOUS.TOTAL(103; <Celllule>) à condition d'être sûr que <Cellule> contient une valeur ou une formule.

Si c'est le cas (ici si J204 contient une valeur ou une formule), tu peux utiliser une formule du type en J306 -> =SI(SOUS.TOTAL(103;J204)>0;J204+1;J153+1)
Ou par sécurité -> =SI(ESTVIDE(J204);"Impossible à déterminer";SI(SOUS.TOTAL(103;J204)>0;J204+1;J153+1))

Mais alors que se passe-t-il si J153 est elle aussi masquée ? Tu ne vas pas remonter toutes les cellules pour les tester !? Il faudra trouver une autre approche.
Si c'est le cas, dis-le et on peut trouver une solution plus simple et plus sûre (*).

Cordialement,
D.

(*) Edit: comme par exemple dédier une colonne X masquée ou hors zone d'impression, où, aux lignes des sauts de page, on place une info quelconque (ex.: "Saut de page") et qui permet de déterminer le n° de la page avec une formule du genre:
=SI(X52 <> "";J$51 + SOUS.TOTAL(103; X$52:X52);"") à étendre de J52 à J<dernière ligne>

Ou pour simplifier / clarifier, placer le n° de la 1ère page hors colonne J (ex. en Y1) et:
=SI(X1 <> "";$Y$1 + SOUS.TOTAL(103; X$1:X1);"") à étendre de J1 à J<dernière ligne>



Modifié par Debrief le 24/08/2019 12:59
delta70
 Posté le 24/08/2019 à 08:55 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour, Debrief

Merci bien

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
329,90 €Ecran ultra large LG 34 pouces 34WL50S-B à 329,90 €
Valable jusqu'au 01 Mars

Amazon propose actuellement l'écran 34 pouces LG 34WL50S-B à 329,90 € livré gratuitement alors qu'on le trouve à partir de 400 € ailleurs. Cet écran ultra large est au format 21/9, possède une dalle IPS et offre une résolution de 2560 x 1080 pixels. Avec lui, vous pourrez bénéficier d'une plus grande immersion dans les jeux et les films. Cet écran est compatible FreeSync.


> Voir l'offre
13,99 €Microsoft Office 2019 Professional Plus à 13,99 €
Valable jusqu'au 27 Février

Le vendeur sérieux Digital FR propose sur Amazon la clé d'activation légale pour Microsoft Office Professionnel 2019 Plus en français à 13,99 €. Cette clé livrée par email vous permettra d'activer Microsoft Office Professionnel 2019 Plus légalement et vous permettra ainsi d'utiliser autant de temps que vous voulez (il s'agit de la version complète et pas d'un abonnement) Word,Excel, PowerPoint, OneNote, Outlook, Publisher et Access 2019 sur un PC. La clé sera à activer sur Office.com où vous pourrez ensuite télécharger toute la suite bureautique. Pour mémoire, Microsoft Office Professionnel 2019 nécessite Windows 10. Sous Windows 7 ou 8, vous devrez vous tourner vers la version 2016. Pour plus d'info sur la procédure, n'hésitez pas à jeter un oeil à notre dossier pratique Acheter une clé OEM d'Office 2019 et l'installer.


> Voir l'offre
30,17 €SSD SanDisk Plus 240 Go à 30,17 €
Valable jusqu'au 28 Février

Amazon propose actuellement le SSD SanDisk Plus 240 Go à 30,17 € livré gratuitement. Une bonne affaire pour ce SSD très fiable et performant qui offre des débits de 530 Mo/s en lecture et 445 Mo/s en écriture. Il est garanti 3 ans. On le trouve ailleurs à partir de 42 €.


> Voir l'offre

Sujets relatifs
Changer la formule quand la cellule est masquée
Changer de couleur une cellule avec une maccro
Changement couleur cellule excel / mise en forme conditionnelle / formule
Référence de cellule variable dans une formule Excel
Repérer une cellule "vide" qui contient une formule
Open Office - formule à mettre dans une cellule
Changer un mot dans une cellule
verrouiller ou déverrouiller une cellule avec la formule SI
[LibreOffice] Changer hauteur cellule tableau
Zoom à changer quand on ouvre word 2007
Plus de sujets relatifs à Ne pas prendre en compte dans une formule la cellule masquée
 > Tous les forums > Forum Bureautique