> Tous les forums > Forum Bureautique
 Nombre d'agents dans la colonneSujet résolu
Ajouter un message à la discussion
Page : [1] 
Page 1 sur 1
Duduche59
  Posté le 17/05/2013 @ 13:36 
Aller en bas de la page 
Petit astucien

Bonjour,

Une nouvelle fois coincé, je reviens vers vous pour essayer de me dépanner.

Mon problème:

J'ai une liste d'agents sur plusieurs sites, chaque agent ayant 0 à plusieurs produits.

1er problème

Je voudrais connaitre par site le nombre d'agents dans la colonne agents. J'ai bien trouvé une formule

=SOMMEPROD(1/NB.SI(col "agent":col"agent))

Mais, outre que je ne comprend pas comment elle fonctionne, je ne peux l'utiliser le nombre de produits va évoluer toute l'années et je rajouterai des ligne dans mon tableau pour chaque agent ayant un nouveau produit.

Si vous résolvez ca , ce serai déjà super.

2ème problème.

Je souhaiterais connaître par site, le nombre d'agent ayany au moins 1 produit.

Ci-joint un tableau pour être plus clair.

Par avance merci de vous intéresser à mon cas.

Duduche59

http://cjoint.com/?CErnE0Qi082

Publicité
ferrand
 Posté le 17/05/2013 à 14:34 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

1er élément : ta formule qui renvoie DIV/0! parce que cellule vide quand pas de produit. Au lieu de laisser vide, tu mets "aucun" et tu fais : =SOMMEPROD(1/NB.SI(C1:C20;C1:C20))-1, tu auras ainsi ton nombre de produits.

Ensuite: nb d'agents du site 1 : =SOMMEPROD(1/NB.SI(A1:A20;A1:A20);--(B1:B20="site 1"))

Pour site 2 et site 3, remplacer 1 par 2 ou 3.

jpr73
 Posté le 17/05/2013 à 14:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Bonjour,

Une autre solution à l'aide de tableaux croisés dynamiques

Mettre les données sous forme de tableau dans la feuille Tableau :

- l'ajout de données provoque automatiquement l'extension du tableau

- éviter les cellules avec des valeurs vides (voir le résultat dans le 2ème TCD)

- pas de calcul dans une feuille de données

Les calculs demandés sont effectués dans la feuille TCD :

- Lors de l'ajout de données dans le tableau il ne faut pas oublier d'actualiser les TCD

- il sera facile d'ajouter des critères dans l'un ou l'autre des TCD ou en créant une autre variante avec un nouveau TCD

Cordialement

http://cjoint.com/?CErour7PQ5B

ferrand
 Posté le 17/05/2013 à 14:40 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Suite :

Nb d'agents du site 1 ayant au moins un produit :

=SOMMEPROD(1/NB.SI(A1:A20;A1:A20);--(B1:B20="site 1");--(C1:C20<>"aucun"))

Pour site 2 et 3, remplacer 1 par 2 ou 3.

ferrand
 Posté le 17/05/2013 à 15:00 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

NB: pour étendre ton tableau sans avoir à modifier tes formules, il te faut nommer tes plages de façon dynamique, soit :

Agent : =DECALER(Feui1!$A$1;;;NBVAL(Feuil1!$A:$A);1)

Site : =DECALER(Feuil1!$B$1;;;NBVAL(Feuil1!$B:$B);1)

Produit : =DECALER(Feuil1!$C$1;;;NBVAL(Feuil1!$C:$C);1)

[Si tu as une ligne d'en-tête dans ton tableau réel, ta plage ne part pas de A1 mais de A2 et faire NBVAL(...)-1 pour compenser [même chose pour B et C]

Tes formules deviennent : =SOMMEPROD(1/NB.SI(Agent;Agent))

et ainsi de suite pour les autres...

Duduche59
 Posté le 17/05/2013 à 16:41 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Petit astucien

Grand merci Ferrand

Je n'aurais jamais réussi à trouver ces formules tout seul.

Tu me sauves la mise,

Bon WE

Page : [1] 
Page 1 sur 1

Vous devez être connecté pour participer à la discussion.
Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !
Recevoir PC Astuces par e-mail


La Lettre quotidienne +226 000 inscrits
Avec l'actu, des logiciels, des applis, des astuces, des bons plans, ...

Les bonnes affaires
Une fois par semaine, un récap des meilleurs offres.

Les fonds d'écran
De jolies photos pour personnaliser votre bureau. Une fois par semaine.

Les nouveaux Bons Plans
Des notifications pour ne pas rater les bons plans publiés sur le site.

Les bons plans du moment PC Astuces

Tous les Bons Plans
279,00 €TV 43 pouces Thomson 43UG6400E LED 4K UHD, HDR10, Android 9 à 279 €
349 € -20%

Amazon Fait une promotion sur le téléviseur 43 pouces (108 cm) Thomson 43UG6400E TV LED 4K UHD qui passe à 279 €. Cette TV offre une résolution 4K Ultra HD de 3840x2160, possède le WiFi, est compatible avec le HEVC (H.265), Android 9 (Youtube, Netflix, Canal, Disney+, Amazon Prime, ...), HDR10, DLNA, Tuner TNT HD, ... Elle possède 2 ports HDMI, 1 ports USB pour lire vos contenus multimédias et un port Ethernet RJ45.

La version 50 pouces est également en promotion à 329 € au lieu de 419 € et la version 55 pouces à 369 € au lieu de 449 €.


Voir l'offre
48,50 €Calculatrice graphique Casio Graph 35+ E II Python à 48,50 €
62,50 € -22%

Boulanger fiat une promotion sur la calculatrice graphique Casio Graph 35+ E II Python à 62,50 €. Or Casio rembourse actuellement 14 € pour l'achat de cette calculatrice qui vous reviendra à 48,50 € après remboursement. La calculatrice de référence pour les 3 ans du lycée, équipée du langage de programmation Python.


Voir l'offre
65,09 €Alimentation modulaire Corsair RM650X 80+ Gold à 65,09 € livrée
89,99 € -28%

Amazon Royaume-Uni propose actuellement l'alimentation modulaire Corsair RM650X à 44,99 £. Avec la conversion en euros et la livraison en France, elle vous reviendra à 65,09 € livrée. Cette alimentation de 650W est certifiée 80+ Gold et est garantie 10 ans. Entièrement modulaire, vous pourrez brancher uniquement les câbles (fournis) dont vous avez besoin. On la trouve ailleurs à partir de 89,99 €. 


Voir l'offre
18,99 €Hub USB C 6 en 1 ZESKRIS (HDMI 4K, lecteur SD/MicroSD 2xUSB 3.0 et 1xUSB C PD 100W) à 18,99 €
23,99 € -21%

Amazon fait une double promotion sur le hub USB C 6 en 1 Selore qui passe à 18,99 €. On le trouve habituellement à 23,99 €. Ce hub vous permettra de rajouter un port HDMI 4K, 2 ports USB 3.0, 1 port USB C PowerDelivery de 100W, un lecteur de carte SD et un lecteur de carte microSD à votre ordinateur via un simple USB-C.


Voir l'offre

Sujets relatifs
nombre de mots dans 1 colonne
nombre de noms dans une colonne
listing et somme valeurs unique dans colonne excel
Figer colonne ou ligne dans excell
Protéger introduction données dans une colonne
Adresses Mail dans colonne restent noires
insérer nombre de pages dans word 2010
Ajouter une colonne dans writter (Open office 4)
Recherche dans une colonne
Nombre dans exel 2003
Plus de sujets relatifs à Nombre d''agents dans la colonne
 > Tous les forums > Forum Bureautique