× Aidez la recherche contre le COVID-19 avec votre ordi ! Rejoignez l'équipe PC Astuces Folding@home
 > Tous les forums > Forum Linux
 Paquet cassé dans pips-snx100 Lubuntu 14.04Sujet résolu
Ajouter un message à la discussion
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]
16mai1956
  Posté le 20/07/2014 @ 19:35 
Aller en bas de la page 
Astucien

Bonjour,

Après bien des déboires pour installer, je débute enfin dans Linux, en l'occurrence Lubuntu 14.04.

J'ai tenté d'installer mon imprimante (Epson SX100) et déjà engrangé certains succès. Un couac, cependant, et qui me coince pour pas mal de choses : un paquet cassé est signalé dans mon système. Pour l'instant, je ne sais ni comment réaliser une copie d'écran, ni comment copier le contenu de ces écrans noirs (terminaux ?)

Dans les informations qui me reviennent : "le sous-processus script pre-removal installé a retourné une erreur de sortie d'état 1".

J'ajoute que ma connaissance de l'anglais est plutôt moyenne.

Merci d'avance pour toute aide,

Luc

Publicité
Logicien
 Posté le 20/07/2014 à 21:48 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Bonjour et bienvenu sur le forum Linux.

as-tu mis à jour la liste des paquets disponibles pour installation? Cette possibilité existe avec Synaptic comme en ligne de commande

sudo apt-get update

Je m'assure que cette liste est à jour avant toute modification des paquets installés. Lorsque la liste est à jour, il est bon de faire une mise-à-jour des paquets installés. En ligne de commande c'est

sudo apt-get upgrade

Si, après ça, tu as toujours un paquet cassé, nos donner le nom du paquet peut aider. Quelqu'un peut avoir une solution. Je n'ai que très rarement un paquet cassé. Il peut y avoir une alternative, un autre paquet pour le remplacer, qui est peut-être déjà installé.

Certains paquets ne peuvent être installés en même temps, il y a conflit. C'est différent d'un paquet cassé. Un paquet est cassé quand un ou des paquets dont il dépend ne peuvent être installés parce-qu'ils ne sont pas dans la base de données des paquets installables.

D'où l'importance de mettre cette liste à jour. Cela peut aussi régler le problème d'erreur d'un paquet. Je m'assure que tous les paquets installés sont configurés correctement, le plus souvent après une mise-à-jour, avec la commande

sudo dpkg --configure -a



Modifié par Logicien le 20/07/2014 21:57
16mai1956
 Posté le 20/07/2014 à 21:57 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

J'ai réussi une copie d'écran... assez bof. Mais en inversant les couleurs sur la partie qui me parait importante, on a ceci :

L'image complète, si elle peut se révéler utile :

À partir de là, pouvez-vous me dire quels éléments sont encore nécessaires à une bonne compréhension du problème ? Merci d'avance.

Logicien
 Posté le 20/07/2014 à 22:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Plus important pour le moment est de fermer Synaptic et de faire dans un terminal en lignes de commandes

sudo apt-get update

sudo apt-get upgrade

sudo dpkg --configure -a

Relit bien mon message précédent.



Modifié par Logicien le 20/07/2014 22:05
m_n
 Posté le 20/07/2014 à 22:31 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

sudo dpkg --configure -a

sudo apt-get install -f



sudo apt-get update

Logicien
 Posté le 20/07/2014 à 22:42 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Tu ne tiens pas compte m_n que

sudo apt-get update

sudo apt-get upgrade

peut résoudre les problèmes de configuration et de paquets cassés. Ça doit être fait en premier. On peut rajouter

sudo dpkg --configure -a

sudo apt-get install -f

Si ces deux dernières commandes ont quelque chose à faire, elles le feront, sinon, elles ne posent aucun problème.



Modifié par Logicien le 20/07/2014 22:44
16mai1956
 Posté le 20/07/2014 à 23:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Logicien et m_n,

Logicien, j'avais manqué ton premier message. Je procède autant que possible dans l'ordre.

J'ai fermé Synaptic.

Pour écrire en ligne de commande, j'ai (dans le menu principal) : "Exécuter", et aussi, dans "Outils système" : UXterm et Xterm. Si cela fait une différence pour ces opérations-ci, dites-le moi. Je commence avec "Exécuter".

16mai1956
 Posté le 20/07/2014 à 23:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Bon, avec "Exécuter", la fenêtre disparait après l'envoi. Je préfèrerais voir la succesion des choses, donc... Xterm.

Logicien
 Posté le 20/07/2014 à 23:17 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Uxterm c'est Xterm avec support UTF-8 alors qu'Xterm est sans UTF-8. Uxterm est préférable. Il ne faut pas utiliser Exécuter. Effectivement, tu ne vois rien, ce dont tu as de besoin.

Recommence le tout avec Uxterm.



Modifié par Logicien le 20/07/2014 23:18
Publicité
16mai1956
 Posté le 20/07/2014 à 23:23 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

OK !

Logicien
 Posté le 20/07/2014 à 23:26 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Redémarrer après une mise-à-jour complète du système est ce qu'il y a de plus sûr pour que le système utilise toutes les nouvelles versions des paquets installés. Après ça, tu peux ajouter et supprimer des paquets avec le moins de chances de problèmes. L'important est de savoir ce que l'on fait.



Modifié par Logicien le 20/07/2014 23:30
16mai1956
 Posté le 20/07/2014 à 23:30 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Voilà. Il m'est suggéré d'utiliser l'option -f.

La syntaxe est ici "apt-get -f install".

Mes copies d'écran sont encore laborieuses.

16mai1956
 Posté le 20/07/2014 à 23:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je copie :

Les paquets suivants contiennent des dépendances non satisfaites : pips-snx100 Dépend: pips-common (>= 3.3.0) mais il n'est pas installable

Logicien
 Posté le 20/07/2014 à 23:35 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

As-tu fais

sudo apt-get update

sudo apt-get upgrade

sudo dpkg --configure -a

avant? Bon, il faut sûrement exécuter la commmande

sudo apt-get -f install

de toutes façons. Si cela ne résoud pas le problème du paquet cassé, il faudra le désinstaller de force, puis refaire une tentative de mise-à-jour pour s'assurer que tout est correct.



Modifié par Logicien le 20/07/2014 23:35
16mai1956
 Posté le 20/07/2014 à 23:47 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Non, vu la suggestion apparue dans UXterm, j'ai d'abord fait [...] -f install... sans résultat (même blocage que dans Synaptic).

Donc, là, je fais sudo dpkg --configure -a

16mai1956
 Posté le 20/07/2014 à 23:49 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Voilà. Après une fraction de seconde, il me renvoie le prompt, sans autre.

m_n
 Posté le 21/07/2014 à 00:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

lorsque tu fait tes updates ..

y a-t-il encore une erreur a la fin des updates ?

Publicité
16mai1956
 Posté le 21/07/2014 à 00:01 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Quant à pips-common, qui pose problème, voici d'où il vient :

C'est possible que j'aie essayé d'installer l'autre avant d'avoir téléchargé et décompressé celui-ci.

16mai1956
 Posté le 21/07/2014 à 00:03 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

OK, je refais update et upgrade et reviens "te dire quoi".

Logicien
 Posté le 21/07/2014 à 00:04 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
  Astucien

Si sudo dpkg --configure -a te retourne l'invite de commandes sans message, c'est bien. Tu peux essayer

sudo apt-get -fm install

pour résoudre les problème du paquet cassé sans tenir compte des paquets manquants. Le mieux est de le faire dans l'ordre

sudo apt-get update

sudo apt-get upgrade

sudo dpkg --configure -a

Si apt-get te dit qu'il y a un ou des paquets cassés, alors faire

sudo apt-get -f install

S'il y en a toujours, alors essayer

sudo apt-get -fm install

Sinon, sans paquet cassé, ces commandes ne sont pas nécessaires, même si ce n'est pas un problème de les faire. Quand

sudo apt-get upgrade

ne retourne pas d'erreur, c'est que la mise-à-jour du système est un succès. Rien de plus est nécessaire.



Modifié par Logicien le 21/07/2014 00:06
16mai1956
 Posté le 21/07/2014 à 00:07 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Oui, hélas, c'est toujours exactement le même souci, y compris après l'option -f.

m_n
 Posté le 21/07/2014 à 00:08 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

sudo dpkg --configure -a

sudo apt-get install -f

sudo apt-get update

16mai1956
 Posté le 21/07/2014 à 00:10 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

On s'est croisés. Je reprends tout dans l'ordre... si l'ordi veut bien. Je crains qu'il chauffe car il tarde à afficher ce que je tape.

À tout de suite.

m_n
 Posté le 21/07/2014 à 00:16 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

ferme tout , et ne travaille qu'avec seulement ta console ( terminal ) ..

et ton navigateur ( firefox ) .. ;-)



Modifié par m_n le 21/07/2014 00:18
16mai1956
 Posté le 21/07/2014 à 00:20 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Rien à faire : toujours le même résultat. L'option -fm pareil que -f.

16mai1956
 Posté le 21/07/2014 à 00:22 
Aller en bas de la page Revenir au message précédent Revenir en haut de la page
Astucien

Je ferme tout ce qui n'est pas console et FF et réessaie.

Publicité
Pages : [1] 2 ... Fin
Page 1 sur 2 [Fin]

Vous devez être connecté pour poster des messages. Cliquez ici pour vous identifier.

Vous n'avez pas de compte ? Créez-en un gratuitement !


Les bons plans du moment PC Astuces

Tous les Bons Plans
52,23 €Coffret de 15 fraises à bois Bosch (queue de 8 mm) à 52,23 €
Valable jusqu'au 10 Août

Amazon fait une promotion sur le coffret de 15 fraises à bois Bosch 2608628396  avec des queues de 8 mm à 52,23 € livré gratuitement grâce à un coupon de réduction alors qu'on le trouve ailleurs à plus de 70 €. Différentes géométries de coupe permettent de fraiser un large éventail de profilés dans divers matériaux.


> Voir l'offre
19,99 €Clé USB 3.0 et Micro USB Sandisk Ultra OTG 128 Go à 19,99 €
Valable jusqu'au 10 Août

Amazon fait une promotion la nouvelle version de la clé USB 3.0 SanDisk Dual Drive 128 Go qui passe à 19,99 €. La particularité de cette clé USB réside dans le fait qu'elle dispose à la fois d'un connecteur USB pour la brancher sur votre ordinateur ou votre TV, mais également d'un connecteur micro USB pour la brancher sur votre smartphone ou votre tablette. Compatible USB 3.0 (et 2.0), cette clé USB offre des débits jusqu'à 150 Mo/s. 


> Voir l'offre
7,99 €Souris sans fil Logitech M171 à 7,99 €
Valable jusqu'au 11 Août

Amazon fait une promotion sur la souris sans fil Logitech M171 qui passe à 7,99 € au lieu de 13,90 € ailleurs. Branchez simplement le récepteur 2,4 GHz fourni sur un port USB de votre ordinateur et profitez d'une portée jusqu'à 10 mètres. Cette souris peut fonctionner 12 mois sur une seule pile AA. Plutôt robuste, vous pourrez l'emmener partout avec vous !


> Voir l'offre

Sujets relatifs
LOCalc sous Lubuntu : raccourcis manquants
Bug dans Korganizer : couleurs de catégories se réinitialisent
Logiciel pour extraire le son dans un film!!!
install Gentoo dans VB. Qui me suit ?
Fichier ppd manquant dans HPLIP (ubuntu 14.04)
Installer Pare-feu dans Debian ?
demande de renseignement ( instalation test lubuntu )
Y a-t'il des femmes dans le monde linux ?
Emmabuntüs redonne vie à des PC bons pour la casse
Quels plugin sous Linux pour lire les avi, mp4, mkv dans Chromium ?
Plus de sujets relatifs à Paquet cassé dans pips-snx100 Lubuntu 14.04
 > Tous les forums > Forum Linux